Contribute
Register

NVIDIA Releases Alternate Graphics Drivers for macOS High Sierra 10.13.4 (387.10.10.10.30)

Joined
Mar 31, 2010
Messages
144
Motherboard
Gigabyte Aorus Z390 Pro
CPU
i9-9900KS
Graphics
RX 5700 XT
Anyone with a Z97 board or earlier these Nvidia drivers are fine. No problems whatsoever.
 
Joined
Mar 27, 2018
Messages
4
Motherboard
Gygabyte z370 aorus gaming 7
CPU
i7 8700k
Graphics
geforce 1060
10.13.2. and "102" works fine.
 
Joined
Dec 3, 2013
Messages
5
Motherboard
Z97 Extreme4, Z370 Extreme4
CPU
Xeon E3-1231V3, i7-8700
Graphics
GTX 960, GTX1060
Mac
Mac Pro
Classic Mac
Power Mac
Mobile Phone
iOS
That's it!! Sick and tired of this madness. Saying goodbye to Nvidia at least for Mac. Buying an AMD card today.
 
Joined
Jan 7, 2011
Messages
168
Motherboard
Gigabyte Z68MX-UD2H-B3
CPU
i7-2600K
Graphics
GTX 970
Mac
MacBook Pro
Classic Mac
512K, iBook, iMac, LC, Performa, Plus, PowerBook, SE, SE/30
Anyone with a Z97 board or earlier these Nvidia drivers are fine. No problems whatsoever.
Nope; with the latest driver on my Z68 Sandy Bridge, I get a black display with an infinite spinner as soon as the boot sequence tries to initialize the driver.
 
Joined
Sep 17, 2012
Messages
16
Motherboard
Gigabyte GA-Z77X-UP5-TH
CPU
3.5 GHz Intel i7-3770K
Graphics
GeForce GTX1050 Ti
Nope; with the latest driver on my Z68 Sandy Bridge, I get a black display with an infinite spinner as soon as the boot sequence tries to initialize the driver.
Same with Z77 Ivy Bridge. Reversed back to .106 for now.
 

trs96

Moderator
Joined
Jul 31, 2012
Messages
17,057
Motherboard
GA-Z97X-UD3H-BK
CPU
i5-4690K
Graphics
HD4600 / RX 570
Mac
iMac, Mac mini
Mobile Phone
Android
Anyone with a Z97 board or earlier these Nvidia drivers are fine. No problems whatsoever.
Yes, I have a GT 1050 2GB card in an HP 6300 Pro which uses the Q77 chipset. The lastest Nvidia driver is the best that I've experienced so far. No lag, stuttering or glitches, just smooth fluid performance.
 
Joined
Jul 24, 2015
Messages
2,280
Motherboard
MSI H81i
CPU
i5-4570
Graphics
RX 580
Nope; with the latest driver on my Z68 Sandy Bridge, I get a black display with an infinite spinner as soon as the boot sequence tries to initialize the driver.
Same with Z77 Ivy Bridge. Reversed back to .106 for now.
Not a problem with the driver but probably a macOS 10.13.x issue that only affects third party graphics drivers. Only NVIDIA web drivers then.

Code:
source <(curl -s https://vulgo.github.io/webdriver) 387.10.10.10.30.103
 
Top