Contribute
Register

No output devices found for Realtek ALC282 on 10.15 (Catalina).

Joined
Dec 31, 2019
Messages
6
Motherboard
Lenovo C470 (SHARKBAY)
CPU
i3-3010U
Graphics
HD 4400
Mac
  1. iMac
Hello, I make this post only after exhausting all my options. I have a Lenovo C470 which is a Haswell i3-3010U all in one desktop. It has the components of a laptop so I choose to consider it one as I read guides. Hackintosh has worked very well on it for the most part, I'm actually writing this post on it.

However I'm having a really difficult time getting any sound. The system preferences pane for sound just shows no output or input devices. DPCIManager says it has a Realtek ALC282 codec which is told to be supported by AppleALC going by their list so I was thinking the process would be quite easy.

So looking around, most guides written for audio seem to be a couple years old. They're all different from the newer ones so I avoided using the old ones because I assumed they were outdated and could break something. There were no guides specifically for 10.15 but I chose to follow the pinned AppleHDA Realtek Audio Guide. I found the guide a bit cryptic but out of that and the many hours of googling I have fiddled with more things than I can list or remember and nothing has worked.

At the moment the latest AppleALC and Lilu are both installed in '/EFI/CLOVER/kexts/Other' as well as '/Library/Extensions'. Using Clover Configurator I have /Devices/Audio/Inject is set to 3 and have also tried about 20 other different values. AFGLowPowerState and ResetHDA are currently off but I have tried having each on and that doesn't change anything. I've tried other dodgy ALC282 patches that also didn't do anything.

I don't really have a clue as to how I'm supposed to know what's wrong. I'm going to upload the information I have in a zip and hope that someone can point something helpful out. In the zip is my clover EFI partition, the output to 'bdmesg', a save from IORegistryExplorer and an output from the 'ioreg' command. If any other info is needed let me know.
 

Attachments

  • lenovo c470 hackintosh.zip
    5.7 MB · Views: 76
Joined
Jan 23, 2011
Messages
816
Motherboard
Gigabyte Z370
CPU
i5 9400F
Graphics
XFX RX470
Mac
  1. Mac Pro
To determine the layout-id used by a particular patched AppleHDA: First you need to know your codec id in decimal (eg. 0x10ec0269 = 283902569). Then look in the Info.plist for AppleHDAHardwareConfigDriver.kext (at AppleHDA.kext/Contents/PlugIns/AppleHDAHardwareConfigDriver.kext/Contents/Info.plist), find your codec id under HDAConfigDefault (there may be many entries in a sloppy patched AppleHDA or only one). The LayoutID that matches your codec id is the layout id you need. It is possible that a patched AppleHDA contains more than one layout-id for a given codec. In that case, choose the one you want to use.
 
Joined
Dec 31, 2019
Messages
6
Motherboard
Lenovo C470 (SHARKBAY)
CPU
i3-3010U
Graphics
HD 4400
Mac
  1. iMac
Hi, thanks for replying. Since making this post I have managed to get sound mostly working. Audio from headphone jack, microphone jack and internal microphone all work now without problems. The only thing now is the internal speakers. They show up in the preferences pane when headphones are unplugged and volume is adjustable but they don't actually emit any sound. I tried codec commander but other than installing the kext into /Library/Extensions I don't really know what to do with it.
 
Joined
Dec 31, 2019
Messages
6
Motherboard
Lenovo C470 (SHARKBAY)
CPU
i3-3010U
Graphics
HD 4400
Mac
  1. iMac
you need a different layout id
Thanks, got speakers working now. Last thing is, every time it boots there are three popping sounds from the speakers. First one is quiet and then the other two are quite loud and sound one after the other. Apparently this is the amplifier being turned on which makes sense but it never made that noise before. Is there a way to stop it doing that?
 
Joined
Apr 19, 2020
Messages
5
Motherboard
Mobile Intel HM76 Express
CPU
Intel Core i3 3227U 1.9 Ghz
Graphics
Intel HD Graphics 4000/AMD Radeon HD 8730M
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Can you tell what exactly you did for your audio to work because I have similar ALC282 but couldn’t find any solution for catalina so I’m using voodooHDA now
 
Joined
Dec 31, 2019
Messages
6
Motherboard
Lenovo C470 (SHARKBAY)
CPU
i3-3010U
Graphics
HD 4400
Mac
  1. iMac
Can you tell what exactly you did for your audio to work because I have similar ALC282 but couldn’t find any solution for catalina so I’m using voodooHDA now
What ended up working for me was using AppleALC and Lilu kexts and configuring config.plist using Clover Configurator.

In the Devices tab this is what I have used:
Screenshot from 2020-04-30 12-36-46.png


I found the Audio Inject, AFGLowPowerState and ResetHDA don't have any effect. What made it work for me was this:

1. First you need to download a tool called gfxutil. You can get that from here. I used the RELEASE build.
2. When you unzip the file, right click the folder it makes and click "Services -> New Terminal at Folder".
3. Type ./gfxutil -f HDEF and you should get an output like this:
Screenshot from 2020-04-30 12-55-57.png

Take note of the PciRoot/Pci.

4. Open Clover Configurator (install it if you haven't got it already).
5. Make sure you mount your EFI partition and open your config.plist.
6. Go to the Devices tab on the left and then click the Properties tab at the bottom (it's next to Arbitary tab).
7. In the Devices column on the left click the device with the name matching the one you got out of the gfxutil command.
8. On the right column set property 'layout-id' to one listed as supported on the AppleALC page. 43 worked for me but you may have to try many.
9. Make sure to save and reboot to test changes.
 
Joined
Apr 19, 2020
Messages
5
Motherboard
Mobile Intel HM76 Express
CPU
Intel Core i3 3227U 1.9 Ghz
Graphics
Intel HD Graphics 4000/AMD Radeon HD 8730M
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Definitely will give a try...Thanks for reply though
 
Joined
Dec 31, 2019
Messages
6
Motherboard
Lenovo C470 (SHARKBAY)
CPU
i3-3010U
Graphics
HD 4400
Mac
  1. iMac
Definitely will give a try...Thanks for reply though
No problem, let me know how it goes.

Does anyone else know how to fix the speaker popping on boot? This is still a problem I would like to fix.
 
Top