Contribute
Register

Need Help! Intel WorkStation S5520SC and 2 Xeon x5960 build

Joined
Oct 11, 2011
Messages
5
Motherboard
Lion
CPU
i7 3370k
Graphics
Geforce GTX 680
Mac
Mac Pro
Classic Mac
Mobile Phone
Android, iOS
#1
Hi guys i need some help. I managed to install Moutain Lion 10.8.4 on this system using PCIRootUID=0 boot flag, but when i run multibeast on it, i got KP. I don't need audio and network drivers, cause there no drivers for this board. Anyone can help?

My System:
Intel WorkStation S5520SC
Dual Xeon X5690
32gb 1333 Ram
Nvidia Quadro 4000
 

Attachments

Joined
Feb 3, 2011
Messages
1,402
Motherboard
asrock pro 3 bois 2.10
CPU
i5 3570k macmini6,1
Graphics
hd4000
#2
install nullcpumanagement kext in multibeast to fix the kp. later if u r able to patch your bios u can remove it.run dpcimanager click on misc then on autopatch if successfull then remove nullcpumanagement kext from system/library/extensions then run kext utility and reboot.
 

Attachments

Joined
Feb 3, 2011
Messages
1,402
Motherboard
asrock pro 3 bois 2.10
CPU
i5 3570k macmini6,1
Graphics
hd4000
#3
download dpcimanager from this site open it and select misc click on autopatch if successfull then remove nullcpumanagement kext from system/library/extensions get kext utility from downloads run it and reboot done

your mobo doesnt have native power management so u need to do a fresh install with easybeast
 

Attachments

Joined
Oct 11, 2011
Messages
5
Motherboard
Lion
CPU
i7 3370k
Graphics
Geforce GTX 680
Mac
Mac Pro
Classic Mac
Mobile Phone
Android, iOS
#5
Man, i try the dpcimanager autopatch but i got an error. What can i do?
 
Joined
Feb 3, 2011
Messages
1,402
Motherboard
asrock pro 3 bois 2.10
CPU
i5 3570k macmini6,1
Graphics
hd4000
#6
ignor it.looks like u r not going to have power management unless u use clover boot loader as it will binary patch applecupmanagement kext do lots of research befor u try and do on a flash drive for testing and format mbr/fat32 u will have edit themes because metal isn't working
 
Joined
May 31, 2011
Messages
3
Motherboard
Intel S5520HC hackintosh
CPU
Xeon E5620
Graphics
Nvidia 640GT
Mac
MacBook Air
Classic Mac
Mobile Phone
iOS
#8
bump...

Count me in, I have a S5520HC also and am working on completing my new daily driver. Almost all basics are working after unibeast install (no multibeast yet, still experimenting on cloned partition). If anyone has this working and completed I would be extremely grateful for any advice you may have.

Working:
Processor: Xeon E5620
Motherboard: Intel S5520HC
Sound: turtle beach micro - usb
Video: dual monitors on an nvidia 640gt
bluetooth: using an old kensington usb for magic mouse and apple bt kb
HD: SATA hotplug via antec drive bay

To do items:
embeded nic's
power states on cpu
boot (still using unibeast usb for boot)
adaptec raid controller
possible creation of user dsdt (will be my first so....)
icloud - can't login
 
Joined
Dec 3, 2014
Messages
26
Mac
Classic Mac
Mobile Phone
#9
Gigibatt ... I have seen your name come up in several S5520hc threads but I cant find much posted information regarding working installs and best practices with the board

I am using 2 x l5640, 48gb ram, gt8600 card (temp to install will probably run headless server)

I have tried unibeast but cant get my bios settings right. if I boot a MBR stick I can get to the installer but no mouse, keyboard sort of works but seems like the keys are wrong

if I set up a unibeast as UEFI, I can get to the clover boatload screen but when I click on the USB installer it changes the screen to a clover icon and nothing else seems to be happening.

I looked in the clover settings at the boot loader screen and its choosing macbookpro5,1 as smbios.. I would think this board would be more xserve3,1 or generic macpro3,1?

any help, bios settings and versions, clover settings, config file, DSDT, kexts etc you can provide to get me going in the right direction would be appreciated!!

Thanks
 
Top