Contribute
Register

Solved > NEC/RENESAS CSL USB 3.0 Expresscard MacbookPro5,1 MacOS 10.12

Joined
Jun 16, 2018
Messages
3
Hi folks,

I am trying to make an CSL USB 3.0 Expresscard working in my old MacbookPro5,1 running MacOS 10.12 Sierra.
I tried a bunch of solutions to this problem but i seem to do something wrong because it wont work.

My status right now:
The Card is showing up as an USB 3.0 Bus
with Host-Controller: AppleUSBXHCIPCI
Device ID: 0x0015
Rev ID: 0x00012
Manufactur ID: 0x1912

If i connect my USBStick 3.0 in, it shows up in the system report with these informations:
Product ID, Manufactur ID, Version, Serialnumber, Manufactur and Location ID.
And my external USB 3.0 drive shows additional information like:
Speed and Current.

But none of my devices, connected to the express card, even the USB 2.0 ones show up in Finder or the Disk Utility.

Please help me to get USB 3.0 working on my trusty old MBP.

Thanks,
Decay

Additional Information about the MBP:

MacbookPro5,1
Intel Core 2 Duo @2.4GHZ
8GB Ram
Bootrom: MBP51.007E.B06
SMC: 1.33f8
 

P1LGRIM

Moderator
Joined
Mar 2, 2012
Messages
23,678
Motherboard
Lenovo ThinkStation p300 ⌘
CPU
i7-4790K
Graphics
HD 4600
Mac
MacBook Pro, Mac mini
Classic Mac
Power Mac
Mobile Phone
iOS
I had a similar card with my old MacBookPro and still have the driver on my server, maybe it will work for you too.
 

Attachments

Joined
Jun 16, 2018
Messages
3
Works like a charm in either El Capitan and Sierra.
Thanks a lot!
I wasnt even sure anymore if its even possible.

Thread can be closed.
 
Joined
Nov 18, 2011
Messages
1
Motherboard
P9X79Pro
CPU
i7-3930K
Graphics
GTX 560 Ti
This patch (NECUSBXHCI.kext version 2.3.0) worked for me with 10.11.6, but since I upgraded to Mojave, it stopped working.

Does anyone know if there is a workaround or newer version of the kext?

I'm on a Macbook Pro 5,2.

Thanks.
 
Joined
Aug 28, 2020
Messages
1
Motherboard
mbp pro 2009
CPU
core 2 duo
Graphics
nvidia
Mac
MacBook Pro
Mobile Phone
Android
I had a similar card with my old MacBookPro and still have the driver on my server, maybe it will work for you too.
this worked great for me, thx very much!
macbook pro 15 late 2008 running yosemite 10.10.5
 
Top