Contribute
Register

Mojave on ASRock Z390 Phantom Gaming-ITX/ac

Status
Not open for further replies.
Joined
Jun 15, 2019
Messages
49
Motherboard
Z390 Phantom Gaming-ITX/ac
CPU
i9-9900K
Graphics
Vega 56
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
Hey all, I have to admit I've read the start and end of this thread but not all of it!

I'm looking to combine my interest in Hackintosh with my interest in SFFPCs. I'm looking to build an extremely small Hackintosh based on the "Asrock Z390 Phantom Gaming-ITX". I chose this board mainly cause it has Wifi, Bluetooth and Thunderbolt built into an mITX board and is somewhat Hackintosh compatible. My priorities are size, connectivity, silent running and stability, not speed. For size I'm intending to use:
  • Integrated graphics
  • M.2 SSD
  • Onboard WiFi
  • Onboard Bluetooth
  • Onboard Audio (via both direct outputs and via HDMI/DisplayPort)
  • Onboard Thunderbolt 3
I'd like a vanilla install but don't know if that would be possible.

Can you guys tell me what works and what doesn't, how difficult it is to get stuff working stable, including anything I've committed from my list?

I'm working on my build, but you're going to want to know a few things:
  • You need to replace the onboard M.2 Wifi/Bluetooth controller. There are no drivers for the included Intel one. It's a straightforward card swap, but you're going to have to delve into eBay or elsewhere and get one.
  • The onboard TB3 may not be what you want. It's specifically powered by a "Low Power" Alpine Ridge JHL6240 controller (see here). Just be sure it'll correctly run whatever device you wanted to use. As best I can tell, this mostly means you get two (instead of four) PCIe lanes connected to the CPU, and hence a max throughput of 16 Gbps instead of 32 [references: LP Alpine Ridge article, anandtech, official brief document, intel spec page]. Furthermore, the DisplayPort protocol the Alpine Ridge controllers support is capped at 1.2 (not 1.4); this means the display bandwidth you could use is 4k@60hz (the same as the actual DisplayPort port on the motherboard), and it's unclear if you could use a TB3 port + the DisplayPort port for 2 x 4k60hz.
  • Both M.2 slots work for me with NVMe SSDs. Just be aware that if you get a "SATA M.2" instead of an NVMe M.2, they will cancel out corresponding SATA lanes for the actual SATA3 ports (there are four, though, so you'll be fine). I'm using the Samsung 970 NVMe drives (which are not SATA), and could therefore use all four onboard SATA ports for 2.5" or 3.5" HDDs.

Overall, after reading the several threads about this board, getting a stable system is not hard [with some USB, ethernet, wifi, bluetooth, and sound]. However, getting TB3 working will be difficult and involve hours of debugging/tuning, i.e. far from vanilla. Also, you may run into issues if you rely on the iGPU completely - I have a dGPU and avoided some of the needed framebuffer fixes which seem necessary for that.

Hope that helps! Good luck.
 
Last edited:
Joined
Jul 15, 2019
Messages
12
Motherboard
Z370 Aorus Gaming 3
CPU
i7-8700K
Graphics
GTX 1070 TI
Mac
  1. iMac
  2. MacBook Air
  3. MacBook Pro
Mobile Phone
  1. iOS
I am not experiencing any coil whine either. My build is quite silent. I haven’t pushed it beyond running benchmarks.
This is what I’m running with my ASRock z390 Phantom ITX: Corsair SF600 SFX, LPX 16 GB 3000, i5-8400, RX 580, noctua CPU cooler, and two noctua case fans packed into a node 202 case.

Hi @Greek07 I'm planning on getting the same MB and the same case as you do, but still kind of confused with the thermal issue all over the internet. Checked some post about using the Cryroig C7, however some pointed out that it doesn't fit. Then about the noctua NH-L9i, someone shared that it couldn't reach the case thus causing heat staying in the case.

It seems that you're using the MB and the case running a build smoothly. Could you share the Noctua CPU cooler and the fans? It'll be nicer if you could share how you install the fans.

Much appreciations, mate!
 
Joined
Dec 29, 2018
Messages
15
Motherboard
ASRock Z390 Phantom Gaming ITX
CPU
i5-8400
Graphics
RX 580
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Hi @neuf79, I haven't been on in a while but here is my setup for the fans. As you can see in the photos, I placed a spacer I made from a plastic mounting bracket that came with a SanDisk SSD. Worked quite well because it is sticky on one side.

IMG_0352.JPGIMG_0324.jpegIMG_0323.jpeg
 
Joined
Jul 15, 2019
Messages
12
Motherboard
Z370 Aorus Gaming 3
CPU
i7-8700K
Graphics
GTX 1070 TI
Mac
  1. iMac
  2. MacBook Air
  3. MacBook Pro
Mobile Phone
  1. iOS
Hi @neuf79, I haven't been on in a while but here is my setup for the fans. As you can see in the photos, I placed a spacer I made from a plastic mounting bracket that came with a SanDisk SSD. Worked quite well because it is sticky on one side.

View attachment 419265View attachment 419267View attachment 419266

I’ve bought a Cryroig C7 and 2 Cryroig QF120 instead.

Now it works pretty well with only one chassis fan implemented. I use the C-fan for inhaling while the GPU fans exhale.

So you remove the original GPU holder and use the chassis fan to hold the card right? Also, how do your chassis fans work? One inhale and one out? I only see one chassis fan 4-pin header on the MB so don’t know how to get 2 of them work with speed control.

Thank you for replying!

7BE463AA-9F51-4626-8CBB-0557254D3DDD.jpeg
 
Joined
Oct 13, 2019
Messages
5
Motherboard
MSI Meg Z390 Godlike
CPU
i9-9900K
Graphics
GTX 1080
[QUOTE = "nickboy, publicación: 1953997, miembro: 2234970"]
La placa base vino con v1.5 y se bajó a v1.20, pero se reiniciaba al cargar el instalador. Comprobado el último mensaje de error es

"localhost: com.apple.xpc.launchd [1] <Error>: rc.cdrom: señalado: Asesinado: 9"

¿Alguien tuvo el mismo problema y se resolvió? Gracias.
[/CITAR]

Hola amigo, ¿podrías resolverlo? Estoy atrapado en ese error y muy desesperado :(
 
Joined
Apr 14, 2019
Messages
72
Motherboard
Dell Inspiron 7586
CPU
i7-8565U
Graphics
UHD 620
Mobile Phone
  1. Android
For all guys with problems on the new Asrock BIOSes (for this board, and for other Asrock boards), add in Clover's config.plist,
under ACPI\DSDT\Patches the following patch (I already posted my patch in the General Z390 thread):
Code:
        <dict>
          <key>Comment</key>
          <string>Fix AsRock Z390 BIOS DSDT Device(RTC) bug</string>
          <key>Disabled</key>
          <false/>
          <key>Find</key>
          <data>
          oAqTU1RBUwE=
          </data>
          <key>Replace</key>
          <data>
          oAqRCv8L//8=
          </data>
        </dict>


The problem his an uninitialized variable in Device(RTC) that makes OSX DSDT parser freak out.
I am quite sure AsRock will eventually fix this, but for now, it is a usable solution.

This also fixed my Dell Inspiron 15 7000 (2-in-1) (model 7586) for some reason.
 
Joined
Sep 19, 2018
Messages
11
Motherboard
Z370-I Gaming
CPU
i7-8700K
Graphics
UHD630 / Radeon VII
Mac
  1. iMac
Can anyone with this board confirm that z390 native nvram now works?

Ala this: https://www.tonymacx86.com/threads/nvram-motherboards-z390.274780/

Also anyone with experience using iMacPro1,1 smbios please share.
I have an asus Z370-I and Radeon VII, smbios 18,3. I will shortly move up to 19,1 and then iMacPro1,1 to get the most out of the GPU.
But I'd like to have thunderbolt for an Apogee Ensemble.
Hotplug is not critical, but it'd still be nice to get that working as it is supposed to.
 
Joined
Oct 28, 2012
Messages
43
Motherboard
ASRock > Need model # > See Rules!
CPU
i5 > Need model # > See Rules!
Graphics
Intel version # > See Rules!
Native nvram does not work on Z390. Aptio guys did not fix it yet, that's false news.
 
Joined
Aug 26, 2017
Messages
178
Motherboard
Gigabyte Z170X-UD5 TH
CPU
i7-6700K
Graphics
RX 580
Mac
  1. iMac
Classic Mac
  1. iMac
  2. LC
  3. Power Mac
  4. Quadra
i confirm, that iss a false new: until today, nvram couldn 't be use on Z390: you need a, EmuVariableUefi-64.efi in clover.
 
Joined
Jan 10, 2012
Messages
41
Motherboard
GA Z68X-UD3H-B3
CPU
Intel Core i7 - 3.49 GHz
Graphics
AMD Radeon HD 7950
Mac
Classic Mac
Mobile Phone
So I managed to install this build on macOS Catalina 10.15.2 using only the Clover.config provided, no DSDT.
And of course the usual kexts that are required.

  • AppleALC.kext (Audio)
  • IntelMausi.kext (Intel LAN)
  • Lilu.kext
  • VirtualSMC.kext
  • SMCProcessor.kext
  • SMCSuperIO.kext

My UEFI is the latest 4.30

The installation went fairly smoothly although I think I had problems shutting down.
For instance, during the installation it would be 'in progress' and appear to be frozen (mouse wouldn't respond) and I left it running for 45 minutes to be sure.

After waiting I held the power button to force shut down, booted back into clover and launched the new install drive the macOS installer made. This continued fine until it said "Your computer will restart shortly" and as expected, didn't actually restart. So I force shut down and continued the installation again.

This time the installation finished successfully.

The System Info seems to report I have the correct CPU and 32GB of memory.
I'm not sure how to check if the NVRAM is good? Or whether my USBs are all working

My Radeon VII shows up as a Vega 56 or something, not sure why.

Shutting down hangs again, I tried removing the "FixShutdown" DSDT fix (which sometimes break shutdown) but it didn't do anything.

Also weirdly, when I hot-plug in my Ethernet cable to the computer, my mouse behaves erratically, but if I reboot with it already plugged in, it's fine. I'm not sure if this is because I haven't removed the M.2 Wifi card yet (I don't plan on using wifi).

Any tips would be greatly appreciated. If you need any further information, let me know.
 
Last edited:
Status
Not open for further replies.
Top