Contribute
Register

Mavericks Black Screen

Joined
Sep 30, 2013
Messages
28
Motherboard
Probook 4540s
CPU
i5-3210m
Graphics
HD4000/7650M
Mac
  1. MacBook Pro
Classic Mac
Mobile Phone
Trying to install Mavericks without any luck. I am just getting a black screen after the apple logo when booting from the unibeast usb. I have tried with GraphicsEnabler=no and =yes.

Probook 4540s that was successfully running 10.8.5, i5 3210m.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,285
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Trying to install Mavericks without any luck. I am just getting a black screen after the apple logo when booting from the unibeast usb. I have tried with GraphicsEnabler=no and =yes.

Probook 4540s that was successfully running 10.8.5, i5 3210m.

Make sure you use all flags mentioned in the guide.
 
Joined
Sep 30, 2013
Messages
28
Motherboard
Probook 4540s
CPU
i5-3210m
Graphics
HD4000/7650M
Mac
  1. MacBook Pro
Classic Mac
Mobile Phone
Make sure you use all flags mentioned in the guide.

I tried all the flags in the guide and get the same thing. I let it sit on the black screen and it just stays black. I can hit caps lock and the light comes on the key, If I let it sit there long enough it goes to sleep. Press the power button and it turns the machine back on but still to a black screen.

For Mountain Lion to boot unibeast the only flag I needed was GraphicsEnabler=no. To boot after install I only needed GraphicsEnabler=no -x

Not working for Mavericks including the ones in the guide.

This is all from booting from unibeast 3.0 attempting install. I made sure I chose Mavericks 10.9 and Laptop support.
 
Joined
Sep 30, 2013
Messages
28
Motherboard
Probook 4540s
CPU
i5-3210m
Graphics
HD4000/7650M
Mac
  1. MacBook Pro
Classic Mac
Mobile Phone
I have read the guide numerous times. I tried the exact way the guide suggested with no luck. I am having the same issue someone else is having in the sticky thread but you tell him something different?

I did what you suggested that "other" user do and I am at least getting farther this time without a black screen. As a matter of fact the welcome screen just came up.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,285
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
I have read the guide numerous times. I tried the exact way the guide suggested with no luck. I am having the same issue someone else is having in the sticky thread but you tell him something different?

I don't think you followed the link. Never judge a book by its cover.
 
Joined
Sep 30, 2013
Messages
28
Motherboard
Probook 4540s
CPU
i5-3210m
Graphics
HD4000/7650M
Mac
  1. MacBook Pro
Classic Mac
Mobile Phone
I don't think you followed the link. Never judge a book by its cover.

I was reading his post before you ever posted the link already.

I am at the language selection screen but no mouse or keyboard is working. Going to try again.

Booted again making sure I used all the flags. I have Keyboard but no mouse.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,285
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
I was reading his post before you ever posted the link already.

I am at the language selection screen but no mouse or keyboard is working. Going to try again.

Booted again making sure I used all the flags. I have Keyboard but no mouse.

I assume you mean no trackpad. Use a USB mouse. The trackpad will be fixed when you get to installing things with the ProBook Installer.
 
Joined
Sep 30, 2013
Messages
28
Motherboard
Probook 4540s
CPU
i5-3210m
Graphics
HD4000/7650M
Mac
  1. MacBook Pro
Classic Mac
Mobile Phone
Only USB mouse I have is a wireless one and it will not work in any of the other ports. On the previous version of unibeast when installing 10.8.5 trackpad and the keyboard work. I am going to try something though. Usually when I use -x to boot to the installer this happens.

Just as I thought, booting without -x the trackpad and keyboard work.

So the flags I used were IGPlatformID=01660003 IGPEnabler=Yes GraphicsEnabler=no

Trying with
PCIRootUID=0 along with the other flags causes the trackpad and the keyboard to not work. So the above flags are working for me.

Fully up and running with everything working so far. USB did not require me to sleep the device for the rest of the ports to function.

Mavericks so far is much faster, Really liking the new Safari as well.
 
Joined
Nov 10, 2012
Messages
79
Motherboard
HP Probook 4540s-A1C68AV
CPU
i3 3120M
Graphics
Intel Graphics HD 4000
Mac
Classic Mac
Mobile Phone
  1. iOS
IGPEnabler=Yes
We only need this flag when laptop comes with both HD4000 and discrete graphic card, is that correct ?
My 4540s has intel HD4000 only as GPU, and I don't remember the exact flags I used the last time I installed ML
:banghead:
MrBeast said:
Mavericks so far is much faster, Really liking the new Safari as well.
Good to know, I start to hate Chrome for its annoying flickering-on-gray problem.
 
Top