Contribute
Register

MacMan's Build: ASUS TUF Z390-PRO GAMING - i9-9900K - Vega 64 - Updated for 10.14.6 and NVRAM Support

Joined
May 13, 2019
Messages
12
Motherboard
ASUS TUF Z390-Pro Gaming
CPU
i7-9700K
Graphics
RX 580/ RTX 2060
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Oh, @MacMan. Thank you so much saving my days and money. I don't know how much time I spent hackintoshing. After months of trial, I followed exactly you said and my hackintosh working 100 %. THANK YOU SO MUCH :)

And, also, can you please tell me which Bluetooth connector you use with this motherboard? I use the same motherboard, and I am yet to buy one. But, thanks for all the support. This community is Wonderful!
 
Joined
Jun 2, 2019
Messages
36
Motherboard
Asus Z390 Tuf Pro Gaming
CPU
i7-9700K
Graphics
UHD 630
Mac
  1. MacBook Air
Mobile Phone
  1. Android
  2. iOS
hello
Please may you explain How to do this step
You will need to install the patch on your UniBeast drive and then on your destination disk after running MultiBeast. The command would look like this if Clover was just install to the destination:
:O
 
Joined
Jun 11, 2019
Messages
16
Motherboard
ASUS TUF Z390-PLUS GAMING WI-FI
CPU
i9 9900K
Graphics
UHD 630
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
If you want to disable secure boot, you gotta delete the keys, and it will show up as disabled

What I did was:
-open key options
-save keys to drive (pendrive formatted with a non apple file system)
once the keys are stored in your pendrive
-you can delete the keys and secure boot will be disabled.

Hope this helps



Hello!
Finally, my machine is ready. I tried to install Mojave.
Mobo z390 tuf pro gaming
Cpu i7 9700k
BIOS version 2417
I did the same settings for UEFI.
But secure boot not able to change it's always enabled.
I tried 3 USB sticks Samsung 3.1/Kingston 2.0/sandisk 2.0 all of them 32GB.
The system can see the USB stick before I make the bootable drive by UniBeast, but, after that system, the never sees them. Also, I tried all the USB ports.
More than 8 hours trying. I'm mad. 11 time bootable drive. But every time the USB stick not detected by boot menu. :cry:
 
Joined
Jun 11, 2019
Messages
16
Motherboard
ASUS TUF Z390-PLUS GAMING WI-FI
CPU
i9 9900K
Graphics
UHD 630
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
That means that, when you open the installer for that patch, you must select your pendrive, and, after installation, do the same in your main drive where Mojave is installed. At least that is what I did.


Hello
Please may you explain How to do this step
You will need to install the patch on your UniBeast drive and then on your destination disk after running MultiBeast. The command would look like this if Clover was just install to the destination:
:O
 
Joined
Mar 9, 2011
Messages
10
Motherboard
Asus Z390 TUF PRO
CPU
i7-8700K
Graphics
GTX 970
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. Android
@MacMan - I followed your guide (up to running UniBeast to boot) and I got to install Mojave but when I tried to boot from USB drive after install has been done, I get the KP. I have attached the picture of my screen and EFI from the USB drive. Can you please point out what could be wrong?

20190627_185822_resized.jpg
MB: Z390 TUF PRO Gaming
CPU: i7 8700K
BIOS version is 2012
GFX: iGPU UHD 630
SSD - Samsung 850 EVO 250 GB
RAM - G.SKILL 2x8192MB @ 3200Mhz CL14
 

Attachments

  • EFI.zip
    3.4 MB · Views: 115
Last edited:
Joined
Jun 2, 2019
Messages
36
Motherboard
Asus Z390 Tuf Pro Gaming
CPU
i7-9700K
Graphics
UHD 630
Mac
  1. MacBook Air
Mobile Phone
  1. Android
  2. iOS
Hello
Mobo z390 tuf pro gaming last ver
I7 9700k
igpu

Before I was stuck before kext loading start
I communicate with mattystonnie. He is tried to help me, and he did a great job. He edited my EFI folder
Kext start loading, but after that system automatically restart and went to safe mode cause of system instability.
So maybe you can understanding my problem cause you have same mobo. I put some Mark's on pictures. I don't know if it will help to diagnose the problem.
 

Attachments

  • PicsArt_06-28-04.49.27.jpg
    PicsArt_06-28-04.49.27.jpg
    813.7 KB · Views: 122
  • PicsArt_06-28-04.47.38.jpg
    PicsArt_06-28-04.47.38.jpg
    1.3 MB · Views: 114
  • PicsArt_06-28-04.50.43.jpg
    PicsArt_06-28-04.50.43.jpg
    1.1 MB · Views: 110
  • PicsArt_06-28-04.51.32.jpg
    PicsArt_06-28-04.51.32.jpg
    308.9 KB · Views: 115
  • PicsArt_06-28-04.45.55.jpg
    PicsArt_06-28-04.45.55.jpg
    577.3 KB · Views: 115
  • EFI.zip
    5.5 MB · Views: 102
  • PicsArt_06-28-03.36.30.jpg
    PicsArt_06-28-03.36.30.jpg
    1.4 MB · Views: 103
Last edited:
Joined
Jun 2, 2019
Messages
36
Motherboard
Asus Z390 Tuf Pro Gaming
CPU
i7-9700K
Graphics
UHD 630
Mac
  1. MacBook Air
Mobile Phone
  1. Android
  2. iOS
Hello
I have same build
Except i7 9700k
Thank you for this perfect guide
I installed Mojave 10.14.5 with huge support from the great @mattystonnie he almost did everything
Now
Every thing working except Lan
Can't get internet access May you help me to fix that ?
 

Attachments

  • IMG-20190630-WA0007.jpeg
    IMG-20190630-WA0007.jpeg
    1.8 MB · Views: 76

P1LGRIM

Moderator
Joined
Mar 2, 2012
Messages
24,419
Motherboard
Lenovo ThinkStation p300 ⌘
CPU
i7-4790K
Graphics
HD 4600
Mac
  1. MacBook Pro
  2. Mac mini
Classic Mac
  1. Power Mac
Mobile Phone
  1. iOS
Can't get internet access May you help me to fix that ?

You should install IntelMausiEthernet.kext as per Post #1 of this thread.
 
Joined
Jun 2, 2019
Messages
36
Motherboard
Asus Z390 Tuf Pro Gaming
CPU
i7-9700K
Graphics
UHD 630
Mac
  1. MacBook Air
Mobile Phone
  1. Android
  2. iOS
You should install IntelMausiEthernet.kext as per Post #1 of this thread.
After I finished the installation and boot Mojave, MultiBeast always fail to install.
So I used the Clover.
So now I little lost how to adding it?
 

P1LGRIM

Moderator
Joined
Mar 2, 2012
Messages
24,419
Motherboard
Lenovo ThinkStation p300 ⌘
CPU
i7-4790K
Graphics
HD 4600
Mac
  1. MacBook Pro
  2. Mac mini
Classic Mac
  1. Power Mac
Mobile Phone
  1. iOS
After I finished the installation and boot Mojave, MultiBeast always fail to install.
So I used the Clover.
So now I little lost how to adding it?
Download the kext and place it on the desktop.
Download and run KextBeast, choose /Library/Extensions as the destination.
 
Top