<< Solved >> Internal card reader suddenly stopped working

Oct 4, 2013
Asus TUF Z390 Plus Gaming
i5 9600K @5GHz
Radeon RX 580
Mobile Phone
  1. Android
This is my internal SD card reader. It is connected to a USB3 internal connector on the motherboard. The other side of the cable has 2 connectors going into the reader. One is for the cards and the other cable is probably just for the USB port on the reader.
Suddenly, without any change to system software or hardware, the card reader part stopped working. Yesterday it was completely ok. Only the USB port is working now.
Booted to Windows, the reader is working ok. The LED turns on when inserting a card. Same was until yesterday in MacOS.
The consistency of system status and stability and resilience is main reason I'm sticking to MacOS because I know that such sudden failures and involuntary configuration changes and various unexpected behavior is common in windows. But now something like this seems to have just happened in MacOS to me.
My OS is 10.15.5
The reader is not listed in USB devices of system profiler. I don't know how it looked when it was there.

pc:~ ja$ find /Volumes/EFI/EFI/CLOVER -type f|grep -ve themes -ve /\\. -ve /Contents/ -ve /doc/

I must again emphasize that absolutely NOTHING changed in the system since yesterday. I am shutting down system properly every evening, no sleep mode. I tried multiple cards and card slots. The HW is ok because it works in windows.