Contribute
Register

Solved > Intel UHD 620 (Dell Inspiron 5584) and no acceleration or black screen

Joined
Apr 21, 2016
Messages
1,359
Motherboard
ASUS X556UA-Clover
CPU
i5-6200U
Graphics
HD 520,1366x768
Mobile Phone
  1. iOS
Hi, here are the PR file when no device-id and ig-platform-id WEG are injected
<09 00 a5 3e> ig-platform-id is automatically setted
It's possible that adding the lilucpu=7 boot flag will solve that. Currently it injects an 8th Gen ig-platform-id, while it should inject a 7th Gen.
Intel's messy releases are causing issues :p

Notice your SSDTs reference IGPU, while your native ACPI files reference GFX0.
As you disabled the rename from GFX0 to IGPU in your config.plist, you should use the original name in your add-on SSDTs.
 
Joined
Jan 1, 2019
Messages
14
Motherboard
Dell Inspiron 5584
CPU
i5-8265U
Graphics
UHD 620
Mac
  1. iMac
Try compiling latest WhateverGreen from source:
The latest commit should fix your problem, I believe.

Don't set a FakeID yourself, nor an ig-platform-id. Let WhateverGreen do that for you.

Make sure DVMT-prealloc is set to 64MB+ in the BIOS, otherwise patch the graphics kexts to allow 32MB (Can be done with WhateverGreen by injecting the required properties)

I don't have any settings in BIOS.
I have recompiled the lates Lilu+WhateverGreen so it has the patch for Whiskey Lake
as well I have injected the properties as per Hackintool please see config.plist
I didn't set device-id

Unfortunately I'm still getting no graphic acceleration
GPU Name Intel UHD Graphics 620
Platform ID 0x59160000
GPU Device ID 0x3EA08086
VRAM 0 MB
Quartz Extreme (QE/CI) No
Metal No
VDA Decoder Decoder Failed

from kernel_log.txt:

2019-07-06 01:12:51.948189-0700 0x73 Default 0x0 0 0 kernel: (kernel) WhateverGreen: init @ (DBG) WhateverGreen bootstrap DBG-130-2019-07-06
2019-07-06 01:12:51.948201-0700 0x73 Default 0x0 0 0 kernel: (kernel) WhateverGreen: rad @ (DBG) not enabling CAIL_DisableDrmdmaPowerGating
2019-07-06 01:12:51.948204-0700 0x73 Default 0x0 0 0 kernel: (kernel) WhateverGreen: rad @ (DBG) not enabling CAIL_DisableGfxCGPowerGating
2019-07-06 01:12:51.948207-0700 0x73 Default 0x0 0 0 kernel: (kernel) WhateverGreen: rad @ (DBG) not enabling CAIL_DisableUVDPowerGating
2019-07-06 01:12:51.948210-0700 0x73 Default 0x0 0 0 kernel: (kernel) WhateverGreen: rad @ (DBG) not enabling CAIL_DisableVCEPowerGating
2019-07-06 01:12:51.948213-0700 0x73 Default 0x0 0 0 kernel: (kernel) WhateverGreen: rad @ (DBG) not enabling CAIL_DisableDynamicGfxMGPowerGating
2019-07-06 01:12:51.948215-0700 0x73 Default 0x0 0 0 kernel: (kernel) WhateverGreen: rad @ (DBG) not enabling CAIL_DisableGmcPowerGating
2019-07-06 01:12:51.948218-0700 0x73 Default 0x0 0 0 kernel: (kernel) WhateverGreen: rad @ (DBG) not enabling CAIL_DisableAcpPowerGating
2019-07-06 01:12:51.948221-0700 0x73 Default 0x0 0 0 kernel: (kernel) WhateverGreen: rad @ (DBG) not enabling CAIL_DisableSAMUPowerGating
2019-07-06 01:12:51.948225-0700 0x73 Default 0x0 0 0 kernel: (kernel) WhateverGreen: shiki @ (DBG) will autodetect autodetect GPU 0 whitelist 0
2019-07-06 01:12:51.948228-0700 0x73 Default 0x0 0 0 kernel: (kernel) WhateverGreen: shiki @ (DBG) pre-config: online 0, bgra 0,


2019-07-06 01:12:54.868133-0700 0x44e Default 0x0 0 0 kernel: (kernel) WhateverGreen: weg @ (DBG) configRead16 IGPU 0x00001000 at off 0x02, result = 0x3ea0
2019-07-06 01:12:54.868140-0700 0x44e Default 0x0 0 0 kernel: (kernel) WhateverGreen: iokit @ (DBG) getOSData device-id has 3EA0 value
2019-07-06 01:12:54.868158-0700 0x44e Default 0x0 0 0 kernel: (kernel) WhateverGreen: weg @ (DBG) configRead32 IGPU 0x00001000 at off 0x00, result = 0x3EA08086
2019-07-06 01:12:54.868163-0700 0x44e Default 0x0 0 0 kernel: (kernel) WhateverGreen: iokit @ (DBG) getOSData device-id has 3EA0 value
2019-07-06 01:12:54.868165-0700 0x44e Default 0x0 0 0 kernel: (kernel) WhateverGreen: weg @ (DBG) configRead32 reported 0x3ea08086 instead of 0x3ea08086
 

Attachments

  • config.plist
    9.7 KB · Views: 54
  • debug_29894.zip
    3.2 MB · Views: 37
Last edited:
Joined
Apr 21, 2016
Messages
1,359
Motherboard
ASUS X556UA-Clover
CPU
i5-6200U
Graphics
HD 520,1366x768
Mobile Phone
  1. iOS
I don't have any settings in BIOS.
I have recompiled the lates Lilu+WhateverGreen so it has the patch for Whiskey Lake
as well I have injected the properties as per Hackintool please see config.plist
I didn't set device-id

Unfortunately I'm still getting no graphic acceleration
GPU Name Intel UHD Graphics 620
Platform ID 0x59160000
GPU Device ID 0x3EA08086
VRAM 0 MB
Quartz Extreme (QE/CI) No
Metal No
VDA Decoder Decoder Failed
That ig-platform-id injection you have is wrong, remove :)
It's a Kaby Lake value, while you want to use the Coffee Lake drivers.
 
Joined
Jan 1, 2019
Messages
14
Motherboard
Dell Inspiron 5584
CPU
i5-8265U
Graphics
UHD 620
Mac
  1. iMac
Without AAPL,ig-platform-id the platform ID is changing in Framebuffer info but still no difference and no acceleration:
Now the Platform ID is automatically set to 0x19160000

The rest stays the same
GPU Name Intel UHD Graphics 620
Platform ID 0x19160000
GPU Device ID 0x3EA08086
VRAM 0 MB
Quartz Extreme (QE/CI) No
Metal No
VDA Decoder Decoder Failed

In About this Mac I still have Intel UHD Graphics 620 7MB
 

Attachments

  • debug_5035.zip
    3.3 MB · Views: 36
Joined
Nov 26, 2017
Messages
262
Motherboard
Dell Inspiron 5379 - 1.13 - Clover UEFI
CPU
i5-8250U
Graphics
UHD 620, 1920x1080
Mac
  1. iMac
  2. MacBook Air
Mobile Phone
  1. Android
It's possible that adding the lilucpu=7 boot flag will solve that. Currently it injects an 8th Gen ig-platform-id, while it should inject a 7th Gen.
Intel's messy releases are causing issues :p

Notice your SSDTs reference IGPU, while your native ACPI files reference GFX0.
As you disabled the rename from GFX0 to IGPU in your config.plist, you should use the original name in your add-on SSDTs.

When adding lilucpu=7 - IOReg is showing Broadwell <06 00 26 16>

In WEG FAQ it is suggested :
  1. Delete or disable binary patches DSDT: GFX0 to IGPU, PEGP to GFX0, HECI to IMEI, MEI to IMEI, HDAS to HDEF, B0D3 to HDAU.
That is why I deactivated my clover renames for testing thinking - WEG make rename.
Do you have explanation on how WEG rename are actually working ?
 
Last edited:
Joined
Apr 21, 2016
Messages
1,359
Motherboard
ASUS X556UA-Clover
CPU
i5-6200U
Graphics
HD 520,1366x768
Mobile Phone
  1. iOS
Without AAPL,ig-platform-id the platform ID is changing in Framebuffer info but still no difference and no acceleration:
Now the Platform ID is automatically set to 0x19160000

The rest stays the same
GPU Name Intel UHD Graphics 620
Platform ID 0x19160000
GPU Device ID 0x3EA08086
VRAM 0 MB
Quartz Extreme (QE/CI) No
Metal No
VDA Decoder Decoder Failed

In About this Mac I still have Intel UHD Graphics 620 7MB
When adding lilucpu=7 - IOReg is showing Broadwell <06 00 26 16>

In WEG FAQ it is suggested :
  1. Delete or disable binary patches DSDT: GFX0 to IGPU, PEGP to GFX0, HECI to IMEI, MEI to IMEI, HDAS to HDEF, B0D3 to HDAU.
That is why I deactivated my clover renames for testing thinking - WEG make rename.
Do you have explanation on how WEG rename are actually working ?

Had a look at the Lilu sources, apparently the lilucpu count is not as we expected:

@Lukaszjg I actually think you don't need the lilucpu boot flag at all. I believe it should recognize your hardware as CFL automatically. Anyway your lilucpu=8 means Skylake, not Coffee Lake as you expected.
Try omitting the flag first. Otherwise try lilucpu=10.

@favoriti Try lilucpu=9 instead. Should mean Kaby Lake.

About the DSDT renames - WEG does not rename the devices in the ACPI code level. I don't remember what's the exact process, but it's done after your ACPI tables are loaded. Clover does the renames before.
In order to make your SSDTs valid, they must match the code in your DSDT. Clover renamed the devices before the SSDTs were loaded, but it's not the case when using WEG renames.
That's why your SSDTs should use the original identifiers (like GFX0).
 
Joined
Nov 26, 2017
Messages
262
Motherboard
Dell Inspiron 5379 - 1.13 - Clover UEFI
CPU
i5-8250U
Graphics
UHD 620, 1920x1080
Mac
  1. iMac
  2. MacBook Air
Mobile Phone
  1. Android
try lilucpu=9 instead. Should mean Kaby Lake.
Have tried : now I got a laptop Kabylake ig-platform-id <00 00 1b 59> but no acceleration with it

When reading WEG manuals it looks like Kabylake-R UHD 620 is a special WEG Kabylake case needing to specify at least device-id, not letting WEG do it automatically :

For UHD620 (Kaby Lake Refresh) fake device-id 16590000 for IGPU.


Btw tanks for the WEG rename explanation,
but wonder why the WEG manual recommendation is to disable some DSDT patches whereas its rename is done after ACPI table is loaded
 
Joined
Apr 21, 2016
Messages
1,359
Motherboard
ASUS X556UA-Clover
CPU
i5-6200U
Graphics
HD 520,1366x768
Mobile Phone
  1. iOS
Have tried : now I got a laptop Kabylake ig-platform-id <00 00 1b 59> but no acceleration with it

When reading WEG manuals it looks like Kabylake-R UHD 620 is a special WEG Kabylake case needing to specify at least device-id, not letting WEG do it automatically :

For UHD620 (Kaby Lake Refresh) fake device-id 16590000 for IGPU.


Btw tanks for the WEG rename explanation,
but wonder why the WEG manual recommendation is to disable some DSDT patches whereas its rename is done after ACPI table is loaded
Oh, that's interesting. The UHD 620 definition in WEG includes an HD 620 fake ID. No idea why it's not actually used. Probably need to have a further look at the source...
Anyway, if you're not seeing a fake ID of the HD 620 in IOReg, inject it yourself. I'd keep the lilucpu flag tho.
With the manual injection it's working, right?

It recommends you to remove the renames from your config because WEG takes care of that for you. The OS will still see the wanted device names, while the ACPI code is untouched. Cleaner solution, I'd say.
 
Joined
Nov 26, 2017
Messages
262
Motherboard
Dell Inspiron 5379 - 1.13 - Clover UEFI
CPU
i5-8250U
Graphics
UHD 620, 1920x1080
Mac
  1. iMac
  2. MacBook Air
Mobile Phone
  1. Android
Anyway, if you're not seeing a fake ID of the HD 620 in IOReg, inject it yourself. I'd keep the lilucpu flag tho.
With the manual injection it's working, right?
Here is a summary of what is fully working in my case when manual 16590000 device injection :
- lilucpu=9 boot flag / 16590000 device id (attached config)
- no lilucpu=9 boot flag / 16590000 device id + AAPL,ig-platform-id

What is not working (unable to finalize OS boot)
- no lilucpu=9 boot flag / 16590000 device id (with no AAPL,ig-platform-id setting)

When ilucpu=9 boot flag only (no manual setting) : <00 00 1b 59> is automatically setted (no acceleration)

Can post you one PR file of one case if you need
 

Attachments

  • Capture d’écran 2019-07-06 à 20.50.39.png
    Capture d’écran 2019-07-06 à 20.50.39.png
    148.8 KB · Views: 149
Last edited:
Joined
Jan 1, 2019
Messages
14
Motherboard
Dell Inspiron 5584
CPU
i5-8265U
Graphics
UHD 620
Mac
  1. iMac
Had a look at the Lilu sources, apparently the lilucpu count is not as we expected:

@Lukaszjg I actually think you don't need the lilucpu boot flag at all. I believe it should recognize your hardware as CFL automatically. Anyway your lilucpu=8 means Skylake, not Coffee Lake as you expected.
Try omitting the flag first. Otherwise try lilucpu=10.

@favoriti Try lilucpu=9 instead. Should mean Kaby Lake.

About the DSDT renames - WEG does not rename the devices in the ACPI code level. I don't remember what's the exact process, but it's done after your ACPI tables are loaded. Clover does the renames before.
In order to make your SSDTs valid, they must match the code in your DSDT. Clover renamed the devices before the SSDTs were loaded, but it's not the case when using WEG renames.
That's why your SSDTs should use the original identifiers (like GFX0).

Thank you all for help

So what works for i5-8265U is setting lilucpu=10 and then pasting Patch from Hackintool for
Coffe Lake and Platform ID 0x3EA50009

Latest Lilu+WhateverGreen + SSDT-PNLF.dsl in CLOVER - ACPI - patched

I have attached my working config.plist, screen shot from clover and full debug output
 

Attachments

  • config.plist
    11.7 KB · Views: 388
  • Screenshot 2019-07-06 at 12.49.49.png
    Screenshot 2019-07-06 at 12.49.49.png
    171.1 KB · Views: 436
  • Screenshot 2019-07-06 at 12.51.21.png
    Screenshot 2019-07-06 at 12.51.21.png
    203.3 KB · Views: 433
  • debug_8925.zip
    3.4 MB · Views: 99
  • SSDT-PNLF.dsl
    10.5 KB · Views: 194
  • Lilu.kext.zip
    309.9 KB · Views: 87
  • WhateverGreen.kext.zip
    218.8 KB · Views: 92
Top