Contribute
Register

<< Solved >> Intel HD 520 Graphics glitch.

Status
Not open for further replies.
Joined
May 9, 2017
Messages
66
Motherboard
Dell Inspiron 15 5567
CPU
i3-6006U
Graphics
HD 520 (1920 x 1080)
Mobile Phone
  1. Android
Hi there. My Dell Inspiron 15 5567 runs on an Intel i3-6006U chip, which uses the Intel HD 520 Graphics and it is running macOS High Sierra (10.13.2). No discreet GPU is present. I have run into this issue, in which when my display turns off for any given reason (sleep, display timer runs its course, etc), I get a really glitchy display output when the display comes back online. Picture for reference...

QwtkT67.jpg


The only way to set things right from this state, is to reboot.To save some time, I've already installed IntelGraphicsFixup.kext in my EFI/CLOVER/kexts/Other folder, and I'm still getting what you're seeing in the above picture. Thanks for your time.

EDIT - THIS ISSUE HAS BEEN SOLVED. IT WAS DONE USING A SIMPLE EDID EDIT. READ POST #45 OF THIS THREAD - https://www.tonymacx86.com/threads/solved-black-screen-after-upgrade-to-high-sierra.237050/
 

Attachments

  • WhatsApp Image 2018-01-23 at 3.47.20 PM.jpeg
    WhatsApp Image 2018-01-23 at 3.47.20 PM.jpeg
    63.8 KB · Views: 245
Last edited:

RehabMan

Moderator
Joined
May 2, 2012
Messages
184,100
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Hi there. My Dell Inspiron 15 5567 runs on an Intel i3-6006U chip, which uses the Intel HD 520 Graphics and it is running macOS High Sierra (10.13.2). No discreet GPU is present. I have run into this issue, in which when my display turns off for any given reason (sleep, display timer runs its course, etc), I get a really glitchy display output when the display comes back online. Picture for reference...

QwtkT67.jpg


The only way to set things right from this state, is to reboot.To save some time, I've already installed IntelGraphicsFixup.kext in my EFI/CLOVER/kexts/Other folder, and I'm still getting what you're seeing in the above picture. Thanks for your time.

Read here:
https://www.tonymacx86.com/threads/readme-common-problems-in-10-13-high-sierra.233582/
 
Status
Not open for further replies.
Top