Install El Capitan on HP 800 G1 PC

Not open for further replies.
Feb 6, 2016
Classic Mac
Mobile Phone

I have been trying to install 10.11 on my HP G1 SFF PC for 2 days but i seem to get stuck.

Intel i7-4765T
HD4600 Desktop Graphics
256 GB SSD
Intel Q87 express chipset
6x USB 3.0
1x VGA
2x DP
Intel I217LM NIC
Intel Wireless 7260 card

I tried Unibeast (with clover).
Changed all the BIOS settings according to the guide. (i dont have USB 2 so i cannot disable USB3)
Removed E1000 network interface card kext files, because i dont have the E1000 card.
Tried Fake PCIID Intel HD Graphics and FakePCIID kexts. (still no video, only text) with several Intel FAKEID.

Command line switch which i tried: -v -f nv_disable=1 dart=0
KernelHaswellE enabled.
Tried APCI Fixdisplay, FIXusb, FIX_INTELGFX and also InjectIntel

I am assuming i have the wrong display drivers here for the HD4600 Desktop?
I tried both the DP port and VGA Port but only text and it seems to stop.

Any Ideas? :confused:
With -v i am stuck at PCI Configuration End.
With -x it's not able to load kernel
With -v it stops at Setting MTU to 1500 E1000intel driver

Also tried NPCI 0x2000 and 0x3000, UseBuiltInEthernet, USBBusFix, UseKernelCache, GraphicsEnabler, Maxmem and some more both yes and no..

Regular boot without -V it stops at the loading bar without progress..
I got a bit further now.
Needed to fix USB permissions and Inject them.
Now i am stuck at hfs: set VeryLowDisk: vol:untitled

Fixdisplay = Yes
Intel Inject = True
Latest Bios from HP
Tried both VGA en DisplayPort output
InjectKexts = Yes

Moved kexts from 10.11 folder to other and deleted the rest.

So my HD4600 graphics on my haswell is not starting.

What to do?
The 4600 has native support/set inject nvidia to true, no other graphic flags.
While building UniBeast installer did you select anything in the graphics section?

No i did not select any graphics drivers in unibeast.

Why should i use inject nvidia, since there is only an HD4600 GPU?
Then i get stuck at set VeryLowDisk: vol:untitled..
Attached screenshot

Last line is hfs: set VeryLowDisk: vol untitled, freeblks:0, dangerLimit:12


  • 20160210_095603.jpg
    1 MB · Views: 184
Last edited:
Not open for further replies.