Contribute
Register

I built one however...

Joined
May 9, 2019
Messages
53
Motherboard
GigaByte Z390 Aorus Pro Wifi
CPU
i7-8700K
Graphics
RX 580
Mobile Phone
iOS
I can't for the life of me get the damn display to work. I dont know what I did wrong or what to do. Please help
 
Joined
Apr 2, 2011
Messages
36
Motherboard
Dell 7020
CPU
i5-4590
Graphics
Quadro K600
Mac
MacBook Pro
Mobile Phone
iOS
Have you tried turning it off an on again ? :)

ps: a build description in your profile and Problem Reporting file attached would go a long way to get some help...
 

trs96

Moderator
Joined
Jul 31, 2012
Messages
12,866
Motherboard
GA-Z97X-UD3H-BK
CPU
i5-4690K
Graphics
HD4600 / RX 570
Mac
iMac, Mac mini
Mobile Phone
Android

trs96

Moderator
Joined
Jul 31, 2012
Messages
12,866
Motherboard
GA-Z97X-UD3H-BK
CPU
i5-4690K
Graphics
HD4600 / RX 570
Mac
iMac, Mac mini
Mobile Phone
Android
I dont know what I did wrong or what to do
 
Joined
May 9, 2019
Messages
53
Motherboard
GigaByte Z390 Aorus Pro Wifi
CPU
i7-8700K
Graphics
RX 580
Mobile Phone
iOS
I added all my info to my profile! Thanks!

No my machine only turns on and back off again
and it has no power to the USBs

I can't even make it into the BIOS
 

trs96

Moderator
Joined
Jul 31, 2012
Messages
12,866
Motherboard
GA-Z97X-UD3H-BK
CPU
i5-4690K
Graphics
HD4600 / RX 570
Mac
iMac, Mac mini
Mobile Phone
Android
No my machine only turns on and back off again
and it has no power to the USBs

I can't even make it into the BIOS
Might be a good idea to consider an RMA.
 
Joined
May 9, 2019
Messages
53
Motherboard
GigaByte Z390 Aorus Pro Wifi
CPU
i7-8700K
Graphics
RX 580
Mobile Phone
iOS
I figured it out, It was 1 bad stick of RAM. Newegg is sending me a replacement set
 
Top