Contribute
Register

HP ProDesk 400 G2 MT, Sierra - setting up

Joined
Feb 28, 2018
Messages
13
Motherboard
HP ProDesk 400 G2
CPU
i3-4150
Graphics
HD 4400
Hello community,

I'm trying to install on the above mentioned PC macOS Sierra but stuck on the logo in the very beginning. Its going to be my first hackintosh, so Im a newbe here.. I wasnt able to find DSDT for this computer as well - how critical is this?
Please see attached Z-CPU report if needed.
I really need your support as I just don't wanna see windows on my PC anymore.

I appreciate you guys for your time, thank you!
Art.
 

Attachments

Joined
Jun 13, 2015
Messages
8
Motherboard
GA H87n-ITX
CPU
I5-4570S
Graphics
GTX 1050 TI
Mobile Phone
iOS
hi,
I just tested HP 400 G2 MT and it work with 10.13.6
- cpu 4170
- vga Msi R460 4G

Sorry I did not have time to test with vga onboard but it work on other (HP Prodesk 600 G1)
 
Joined
Feb 28, 2018
Messages
13
Motherboard
HP ProDesk 400 G2
CPU
i3-4150
Graphics
HD 4400
Hi thuy-nam,
Thanks for your reply!
I managed to get till instalation by disablink USB3. But can't see my drives within destination drives...
Going to fight that now ;)
 
Joined
Feb 28, 2018
Messages
13
Motherboard
HP ProDesk 400 G2
CPU
i3-4150
Graphics
HD 4400
I have macOS installed. I had to use Powershell to remove all partitions from the drive and then to set a GUID partition on macOS to achieve it accessibility for installation.

Now, I face few problems:
1. I ran MultiBeast with VoodooHDA 2.9.1., RealtekRTL8111-v2.2.1, and Intel GPU fix but it seems like this is not really working. So I used Kext Utility to manually inject Voodoo and Realtek. But, while network works all the way ,Voodoo device is only there after first restart. Also, seems like Intel 4400 is not working properly as on some apps it shows banding/horizontal stripes particularly on full screen YouTube playback and in Google Chrome in general.
2. USB 3.0 ports are working as USB2.0

Any suggestions guys please?
Thank you!
 
Joined
Feb 28, 2018
Messages
13
Motherboard
HP ProDesk 400 G2
CPU
i3-4150
Graphics
HD 4400
Hi Guys,
After applying Multibeast there is no changes in config.plst on EFI partition with CLOVER. Is it the way it supposed to be?
Thank you!
 
Joined
Feb 28, 2018
Messages
13
Motherboard
HP ProDesk 400 G2
CPU
i3-4150
Graphics
HD 4400
I feel like a system (Clover or MacOS) is not picking up the kexts.. Tried to move them to Clover kexts folder and use Clover Configurator for USB3.0 support by adding following:
  • Sierra 10.12.x:
    • Name*: AppleUSBXHCIPCI
    • Find* [Hex]: 83bd74ff ffff10
    • Replace* [Hex] : 83bd74ff ffff1b
    • Comment: change 15 port limit to 26
    • MatchOS: 10.12.x
No results. audio seems to work only after first restart after applying Multibeast, but not every time..
Any suggestion please?
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,691
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
I feel like a system (Clover or MacOS) is not picking up the kexts.. Tried to move them to Clover kexts folder and use Clover Configurator for USB3.0 support by adding following:
  • Sierra 10.12.x:
    • Name*: AppleUSBXHCIPCI
    • Find* [Hex]: 83bd74ff ffff10
    • Replace* [Hex] : 83bd74ff ffff1b
    • Comment: change 15 port limit to 26
    • MatchOS: 10.12.x
No results. audio seems to work only after first restart after applying Multibeast, but not every time..
Any suggestion please?
https://www.tonymacx86.com/threads/guide-creating-a-custom-ssdt-for-usbinjectall-kext.211311/
 
Joined
Jun 13, 2015
Messages
8
Motherboard
GA H87n-ITX
CPU
I5-4570S
Graphics
GTX 1050 TI
Mobile Phone
iOS
Hi, sorry for late reply
for Audio, best with Voodoo 8.7
for Lan, don't need RealtekRTL8111-v2.2.1

I did installed Mojave with internal GPU 4600 (Cinbench ~21.9fps)
then adding vga card after that, both vga card: GT740 (~50.5fps) and RX460 (~78fps) are normal using
 
Last edited:
Joined
Feb 28, 2018
Messages
13
Motherboard
HP ProDesk 400 G2
CPU
i3-4150
Graphics
HD 4400
Thank you guys for suggestions,

I'm reading through forums for 2 days now. I feel like should do:
1) A clean install of macOS
2) Put network, graphics and audio kexts in Clover.
3) Apply DSDT changes for USB ports routing
4) Fight graphics issues which is most unclear for me at the moment as I can't find guides on Intell 4400 just lots of bits of different tweaks everywhere..
 

BreBo

Moderator
Joined
Oct 17, 2011
Messages
9,679
Motherboard
Gigabyte GA-Z87X-OC
CPU
i7-4770K
Graphics
GTX 970
4) Fight graphics issues which is most unclear for me at the moment as I can't find guides on Intell 4400 just lots of bits of different tweaks everywhere..
Desktop HD4400 requirements:
- config.plist/Graphics/Inject/Intel=true
- config.plist/Graphics/ig-platform-id=0x0d220003
- config.plist/Devices/FakeID/IntelGFX=0x04128086
- BIOS DVMT-prealloc 64mb
- digital connection to your monitor (VGA not supported)
- VT-d disabled or use dart=0
- FakePCIID.kext + FakePCIID_Intel_HD_Graphics.kext
or
- Lilu.kext and WhateverGreen.kext (preferred)
 
Top