How To Make a Generic Driver For Any Card Reader

Discussion in 'Customization' started by Rakif, Oct 1, 2012.

  1. bgkoss

    bgkoss

    Joined:
    Dec 27, 2015
    Messages:
    1
    Dec 26, 2016 at 7:33 PM #41
    bgkoss

    bgkoss

    Joined:
    Dec 27, 2015
    Messages:
    1
    Hi All and Merry Christmas!

    Thanks for this good guide.
    I have a question about T410 NVS 3100 + Ricoh SD/MMC cardreader on El Capitan 10.11.6:

    Code (Text):

    <key>idProduct</key>
    <integer>59426</integer>
    <key>idVendor</key>
    <integer>4480</integer>
     
    I'm attaching my Info.plist from AppleUSBCardReader.kext with converted and replaced all vendor and dev_id strings. There is no SD reader in USB devices at all.
    So far no luck but maybe I am missing something?

    Thanks in advance!
     

    Attached Files:

  2. carpentryplus25

    carpentryplus25

    Joined:
    Jan 26, 2014
    Messages:
    1,336
    Mobo:
    Asus P5LP-LE
    CPU:
    Core 2 Duo
    Graphics:
    Nvidia GeForce GT 640
    Mac:
    Mac Pro
    Mobile Phone:
    iOS
    Dec 26, 2016 at 7:44 PM #42
    carpentryplus25

    carpentryplus25

    Joined:
    Jan 26, 2014
    Messages:
    1,336
    Mobo:
    Asus P5LP-LE
    CPU:
    Core 2 Duo
    Graphics:
    Nvidia GeForce GT 640
    Mac:
    Mac Pro
    Mobile Phone:
    iOS
    You may have one of the PCI sd card readers which I have been working on getting it to work to check if it is a PCI card reader open DPCIManger and if its in the list it is and this method won't work for you if its not in the list then you have some usb problems still and this method will work for you once you fix the usb problems. If it is a PCI card reader I'd like you to try this method here and report back
     
  3. JohnnyHobbz

    JohnnyHobbz

    Joined:
    Oct 25, 2012
    Messages:
    1
    Mobo:
    GA-Z77X-UD5H
    CPU:
    Intel i7 2600k
    Graphics:
    GeForce 650 Ti
    Mac:
    MacBook Pro
    Mobile Phone:
    iOS
    Feb 5, 2017 at 8:58 PM #43
    JohnnyHobbz

    JohnnyHobbz

    Joined:
    Oct 25, 2012
    Messages:
    1
    Mobo:
    GA-Z77X-UD5H
    CPU:
    Intel i7 2600k
    Graphics:
    GeForce 650 Ti
    Mac:
    MacBook Pro
    Mobile Phone:
    iOS
    Has anyone been able to get this to work in Sierra? I was able to get it working up through Yosemite, but when I updated to Sierra and edited the plist, it didn't work. I've read that it is better to make an injector kext for it, but how would one go about that? The card reader works and shows up as a USB device, but I want it to be recognized in the Card Reader section as well like I was able to do in Mountain Lion, Mavericks, and Yosemite.
     
  4. cihusss

    cihusss

    Joined:
    Jun 24, 2016
    Messages:
    4
    Mobo:
    Gigabyte GA-Z170N-WIFI Motherboard (rev 1.0)
    CPU:
    Intel BX80662I36100 Core i3-6100 3M Cache, 3.70 GHz Processor
    Graphics:
    ASUS GeForce GTX 950 MINI-GTX950-2G 2GB 128-Bit GDDR5 PCI Express 3.0
    May 4, 2017 at 4:21 PM #44
    cihusss

    cihusss

    Joined:
    Jun 24, 2016
    Messages:
    4
    Mobo:
    Gigabyte GA-Z170N-WIFI Motherboard (rev 1.0)
    CPU:
    Intel BX80662I36100 Core i3-6100 3M Cache, 3.70 GHz Processor
    Graphics:
    ASUS GeForce GTX 950 MINI-GTX950-2G 2GB 128-Bit GDDR5 PCI Express 3.0
    Same here guys, any luck on Sierra?
     
  5. Sudeepduhoon

    Sudeepduhoon

    Joined:
    Jan 20, 2017
    Messages:
    66
    Mobo:
    Dell Vostro 3546(clover)
    CPU:
    Intel core i3-4005u;Dell 09XY3N;INTEL LYNX POINT-LP(MAINSTREAM)
    Graphics:
    Intel integrated 4400 graphics only,1366*768
    Mobile Phone:
    Android
    Jul 1, 2017 at 2:14 PM #45
    Sudeepduhoon

    Sudeepduhoon

    Joined:
    Jan 20, 2017
    Messages:
    66
    Mobo:
    Dell Vostro 3546(clover)
    CPU:
    Intel core i3-4005u;Dell 09XY3N;INTEL LYNX POINT-LP(MAINSTREAM)
    Graphics:
    Intel integrated 4400 graphics only,1366*768
    Mobile Phone:
    Android
    Are
    Do you able to use your card reader,here i am not.Its listed in Usb as generic in profiler but not available in finder.Mine one is RTS5129
     
  6. jasperlevi

    jasperlevi

    Joined:
    Aug 22, 2011
    Messages:
    145
    Mobo:
    Gigabyte X99 UD4 BIOS rev. F.23
    CPU:
    Intel i7 5820K @4.3 GHz (OC)
    Graphics:
    ASUS STRIX GeForce GTX 960 Overclocked 4 GB DDR5
    Mobile Phone:
    iOS
    Dec 2, 2017 at 12:27 PM #46
    jasperlevi

    jasperlevi

    Joined:
    Aug 22, 2011
    Messages:
    145
    Mobo:
    Gigabyte X99 UD4 BIOS rev. F.23
    CPU:
    Intel i7 5820K @4.3 GHz (OC)
    Graphics:
    ASUS STRIX GeForce GTX 960 Overclocked 4 GB DDR5
    Mobile Phone:
    iOS
    Does this still work? I am trying to make a Sabrent USB3.0 card reader work. The USB 3 port on the unit works without any problems. It has a Genesys Logic vendor id.

    If I plug the USB cable into the motherboard once the computer has booted up, it comes to life and works without any problems. but only till the next sleep/wake.

    It is not showing up under System Properties anywhere.
     
  7. BreBo

    BreBo Moderator

    Joined:
    Oct 17, 2011
    Messages:
    5,652
    Mobo:
    Gigabyte GA-Z87X-OC
    CPU:
    Intel Core i7-4770K
    Graphics:
    Asus Strix GTX 970
    Dec 4, 2017 at 9:23 PM #47
    BreBo

    BreBo Moderator

    Joined:
    Oct 17, 2011
    Messages:
    5,652
    Mobo:
    Gigabyte GA-Z87X-OC
    CPU:
    Intel Core i7-4770K
    Graphics:
    Asus Strix GTX 970
    jasperlevi likes this.
  8. jasperlevi

    jasperlevi

    Joined:
    Aug 22, 2011
    Messages:
    145
    Mobo:
    Gigabyte X99 UD4 BIOS rev. F.23
    CPU:
    Intel i7 5820K @4.3 GHz (OC)
    Graphics:
    ASUS STRIX GeForce GTX 960 Overclocked 4 GB DDR5
    Mobile Phone:
    iOS
    Dec 5, 2017 at 3:33 PM #48
    jasperlevi

    jasperlevi

    Joined:
    Aug 22, 2011
    Messages:
    145
    Mobo:
    Gigabyte X99 UD4 BIOS rev. F.23
    CPU:
    Intel i7 5820K @4.3 GHz (OC)
    Graphics:
    ASUS STRIX GeForce GTX 960 Overclocked 4 GB DDR5
    Mobile Phone:
    iOS
    Thanks, but my problem is not that the Card Reader disappears after sleep/wake. It is not detected on system boot, and only when I plug it into the internal USB3 header on the motherboard, when the computer is up and running - something that I think is dangerous, and not sustainable in the long run.

    The bigger issue is that it is not detected even when I boot linux on the same machine, something that tells me that there is nothing wrong with the USB port mapping that I did following @RehabMan's guide here - https://www.tonymacx86.com/threads/guide-creating-a-custom-ssdt-for-usbinjectall-kext.211311/

    The hardware is probably incompatible.
     

Share This Page