Contribute
Register

How to Create a macOS Mojave Public Beta Installation USB

Status
Not open for further replies.

Stork

Admin
Staff member
Joined
Sep 21, 2010
Messages
12,950
Motherboard
ASUS ROG MAXIMUS X HERO Z370
CPU
i7-8700K
Graphics
RX 580
Mac
MacBook Pro, Mac mini, Mac Pro
Classic Mac
Power Mac, PowerBook
Mobile Phone
iOS
Successfully installed Mojave using a created USB stick with this guide.

Sadly, I can't get my graphics (GTX 970) to work. System reverted back to the default MacOS drivers after the update, after which I had to use Nvidia-update.sh (with the -f flag) to reinstall the web drivers.
System now outputs 4K correctly, but with many glitches and lag. Dock and menu bar are opaque rather than transparent. I tried Lilu + NvidiaGraphicsFixup, to no avail.

On a side note: I can't seem to find the High Sierra Installer in the App Store, so I can't downgrade quite yet.
Did you use the keyboard combination Option + Click on Purchases in App Store app?
 
Joined
Jan 3, 2013
Messages
10
Motherboard
GA-Z77M-D3H
CPU
i5 3570T
Graphics
GTX 970
Mac
MacBook Air
Mobile Phone
iOS
Did you use the keyboard combination Option + Click on Purchases in App Store app?
There is no purchases tab in the new Mac App Store, what with the whole redesigned App Store in Mojave. I can see previous purchases by clicking on my account (profile at the bottom left), but none of the older releases of MacOS show up. I think I'm missing a bunch of 32-bit applications, too, so that might have something to do with it.

Funny side note: the one old MacOS release that *does* show up, is 'OS X El Capitan GM Candidate'.
 
Joined
May 2, 2014
Messages
4
Motherboard
GA-Z87M-D3H
CPU
i5-4670k
Graphics
EVGA GeForce GTX760 SuperClocked 2GB
Mac
iMac
Classic Mac
iMac
Mobile Phone
iOS
Is there/will there be a way to install this on an older Mac by editing a .plist or something? I have a Late 2009 iMac that runs HS just fine. No reason that it shouldn't be able to run Mohave other than Apple excluding it.
 
Joined
May 15, 2016
Messages
4,588
Motherboard
GIGABYTE Z170M D3H
CPU
i5-6500
Graphics
RX 480
Mac
iMac
Is there/will there be a way to install this on an older Mac by editing a .plist or something? I have a Late 2009 iMac that runs HS just fine. No reason that it shouldn't be able to run Mohave other than Apple excluding it.
ApplePlatformSupportkext, edit info.plist. Add you model number and platform ID #.

Does your CPU have SSE 4.2 instruction set? It may kernel panic if not.
 
Joined
Dec 31, 2013
Messages
6
Motherboard
HP Z420 Workstation
CPU
Xeon E5-1650 v0
Graphics
RX 580
Does someone know if we can use our own FakeSMC.kext? I got a working High Sierra install (along with kexts and everything) but I do not know if we must use the FakeSMC.kext provided in the first post.
 

Stork

Admin
Staff member
Joined
Sep 21, 2010
Messages
12,950
Motherboard
ASUS ROG MAXIMUS X HERO Z370
CPU
i7-8700K
Graphics
RX 580
Mac
MacBook Pro, Mac mini, Mac Pro
Classic Mac
Power Mac, PowerBook
Mobile Phone
iOS
Does someone know if we can use our own FakeSMC.kext? I got a working High Sierra install (along with kexts and everything) but I do not know if we must use the FakeSMC.kext provided in the first post.
Yes.
 
Joined
May 2, 2014
Messages
4
Motherboard
GA-Z87M-D3H
CPU
i5-4670k
Graphics
EVGA GeForce GTX760 SuperClocked 2GB
Mac
iMac
Classic Mac
iMac
Mobile Phone
iOS
Joined
Sep 15, 2017
Messages
24
Motherboard
ASUS b250ma prime
CPU
G4560
Graphics
Rx 460
My G3258 which I normally use fake ID 0x0306A0 required fake ID 0x0106E0 to install Mojave. After install 0x0306A0 works fine, but I had kernel panic during the upgrade.
can I have your config plist please
 
Joined
Sep 5, 2016
Messages
22
Motherboard
Gigabyte Z170-D3H
CPU
i5 6600k
Graphics
GTX 1060
Mac
MacBook Pro
Mobile Phone
Android, iOS
guys i have a little issue here with creating the usb drive. I run the command and is says:
Code:
Alexs-iMac:~ alex$ sudo /Applications/Install\ macOS\ Mojave\ Beta.app/Contents/Resources/createinstallmedia --volume /Volumes/Untitled --nointeraction --downloadassets
To use this tool, you must download the macOS installer application on a Mac with 10.12.5 or later, or El Capitan 10.11.6. For more information, please see the following: https://support.apple.com/kb/HT201372.
This is on my high sierra hackintosh. Didn't have any issues with the hack itself tho
 
Status
Not open for further replies.
Top