Contribute
Register

[HELP] time delayed bios

Status
Not open for further replies.
Joined
Apr 10, 2013
Messages
23
Motherboard
Gigabyte GA-Z87X-UD3H
CPU
i5-4570S
Graphics
HD 4600
Mac
  1. MacBook
Mobile Phone
  1. Android
Hello friends!
I have a problem that is driving me crazy ...
It turns out that when the BIOS is delayed two hours with the actual time difference. Mavericks shows me the correct time, but not the BIOS.
I have discovered that this being so, TimeMachine shows me ERROR when trying to create a copy.
And all because of the time difference with the BIOS.
I dont have dualboot, only Mavericks.
Is there any way to meet the schedule of the BIOS with the Hackintosh?
The motherboard is a Gigabyte GA-Z87-HD3 had previously used this badge and others to Hackintosh and never gave me this problem, or the dualboot.
I hope you can help me, thanks for your time!
 
Joined
Apr 10, 2013
Messages
23
Motherboard
Gigabyte GA-Z87X-UD3H
CPU
i5-4570S
Graphics
HD 4600
Mac
  1. MacBook
Mobile Phone
  1. Android

P1LGRIM

Moderator
Joined
Mar 2, 2012
Messages
25,974
Motherboard
Lenovo ThinkStation p700
CPU
2x E5-2620 V3
Graphics
RX 560
Mac
  1. MacBook Pro
  2. Mac mini
Classic Mac
  1. Power Mac
Mobile Phone
  1. iOS
This is probably because of the different methods that Windows and OSX use for time.
To fix it you need to add a key to your Windows system registry.

1. Boot Windows

2. Click Start --> Run and type regedit. Click OK

3. The Windows Registry Editor should pop up. Navigate within the explorer to:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\TimeZoneInformation

4. Click on the TimeZoneInformation "folder" from the navigation pane if you haven't already done so.

5. This assumes the correct key doesn't exist. If it does, you will just change the existing key's value: Right click on the white space within the folder . Select new --> DWORD Value. Title the key "RealTimeIsUniversal" (No quotes). Set the value to "1" (No quotes again). Hexadecimal should be fine.

6. Either reboot and set the clock in MacOS or set the clock in Windows. You should now be able to reboot into either OS and have a correct clock.


Good Luck
 
Joined
Apr 10, 2013
Messages
23
Motherboard
Gigabyte GA-Z87X-UD3H
CPU
i5-4570S
Graphics
HD 4600
Mac
  1. MacBook
Mobile Phone
  1. Android
This is probably because of the different methods that Windows and OSX use for time.
To fix it you need to add a key to your Windows system registry.

1. Boot Windows

2. Click Start --> Run and type regedit. Click OK

3. The Windows Registry Editor should pop up. Navigate within the explorer to:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\TimeZoneInformation

4. Click on the TimeZoneInformation "folder" from the navigation pane if you haven't already done so.

5. This assumes the correct key doesn't exist. If it does, you will just change the existing key's value: Right click on the white space within the folder . Select new --> DWORD Value. Title the key "RealTimeIsUniversal" (No quotes). Set the value to "1" (No quotes again). Hexadecimal should be fine.

6. Either reboot and set the clock in MacOS or set the clock in Windows. You should now be able to reboot into either OS and have a correct clock.


Good Luck

Hello friend, first of all thanks for answering my question.
But do not use DualBoot
Only use OSX on a ssd hard drive, I have not installed Windows.
So my question, how to change the time zone of the BIOS either in the BIOS or from OSX modifying any system file.
 

P1LGRIM

Moderator
Joined
Mar 2, 2012
Messages
25,974
Motherboard
Lenovo ThinkStation p700
CPU
2x E5-2620 V3
Graphics
RX 560
Mac
  1. MacBook Pro
  2. Mac mini
Classic Mac
  1. Power Mac
Mobile Phone
  1. iOS
Hello friend, first of all thanks for answering my question.
But do not use DualBoot
Only use OSX on a ssd hard drive, I have not installed Windows.
So my question, how to change the time zone of the BIOS either in the BIOS or from OSX modifying any system file.

Sorry, I assumed when you wrote "I have dualboot" that you used Windows too - My bad.

Good Luck
 
Joined
Apr 10, 2013
Messages
23
Motherboard
Gigabyte GA-Z87X-UD3H
CPU
i5-4570S
Graphics
HD 4600
Mac
  1. MacBook
Mobile Phone
  1. Android
This is working as intended, because OS X sets the BIOS time to UTC.

But in my other hackintosh, I like nothing ever happened.
 
Joined
Nov 1, 2010
Messages
980
Motherboard
ASUS Maximus VIII Hero
CPU
i7-6700k
Graphics
GTX1060
Mobile Phone
  1. iOS
If you're not dual booting, and the time is displayed correctly in OSX, then to quote whoever came up with the famous phrase,

"if it ain't broke, don't fix it!". :)

tinix said it right 2 replies previous. Works the same on my system.

ps...this is not the reason you are having TimeMachine problems.
 
Joined
Apr 10, 2013
Messages
23
Motherboard
Gigabyte GA-Z87X-UD3H
CPU
i5-4570S
Graphics
HD 4600
Mac
  1. MacBook
Mobile Phone
  1. Android
If you're not dual booting, and the time is displayed correctly in OSX, then to quote whoever came up with the famous phrase,

"if it ain't broke, don't fix it!". :)

tinix said it right 2 replies previous. Works the same on my system.

ps...this is not the reason you are having TimeMachine problems.

Hello there!
if this is the reason why I was timemachine error because hackintosh went back to reinstall from scratch, but this time uncheck the automatic date and time online.
leave when the bios two hours delayed
in osx gave me good time and if time machine now let me make copies
 
Status
Not open for further replies.
Top