Help: Plain grey screen with working cursor after 10.9.5 update.

Not open for further replies.
Dec 26, 2011
ASUS Prime Z270-A
R9 280X

I have an HP z800 workstation that has been running OS X Mountain Lion (10.8.5) without any issues specific to the OS for a couple of years, however, the system's primary function is to run Pro Tools HD for audio work / recording and I have had stability issues with that software under this OS.

In an attempt to test stability under a newer OS I am trying to create a working install of Mavericks 10.9.5 (newer OS X versions are likely to cause more issues than they would fix with regard to Pro Tools).
Thus far I have managed to: create the USB installer with Unibeast, install OS X 10.9, run Muiltibeast and get the HDD bootable without USB, and install the 10.9.5 update.

The issue: after the 10.9.5 update was installed, the system rebooted went past the Apple logo screen and then stopped indefinitely at a plain grey screen with a working mouse cursor.

I can boot into the OS if i use -x, but other combinations of boot flags, re-running Multibeast and attempts at kext manipulation have thus far been unsuccessful, and a lot of google-ing and search attempt on this forum have also not yielded a solution.

Any advice regarding what may need attention/cause issues after the 10.9.5 update or which things might be specific to this issue would be greatly appreciated.


I won't have access to the system again until later tonight/tomorrow but the basic specs are:

HP Z800 Workstation
Dual Xeon x5670 6-core processors @2.93GHz
48GB ECC Registered DDR3 1333 RAM installed (12 x 4GB sticks)
nVidia Quadro FX380 PCIe Graphics Card w/ 2 connected Displays
OS Drive: 1TB SATA HDD @7200RPM
1 Optical Combo Drive
PCI Firewire Card
Connected Peripherals: USB Mouse/Keyboard, iLoks, FW interface. (mostly disconnected during install/troubleshooting)
So, after a few more days of research, I have yet to arrive at a solution. I have, however, managed to glean a few more relevant details.

Looking at the boot log for an attempted regular boot (that stops at the plain screen with cursor) I get these messages during the hang:

NVDA(OpenGL): Channel exception! exception type = 0x8 = DMA Engine Error (FIFO Error 8)
NDDA(OpenGL): Channel timeout!

This seems to confirm my suspicion that the issue was related to graphics / graphics drivers in some way, but searching for those errors hasn't yielded a definitive fix.

1) Some of the discussions (which all seem to be related to Mountain Lion) suggest different system definitions in Multibeast. Right now I am using the default / easybeast definition of MacPro3,1. Is there a definition that would better suit my hardware listed above? (Certain posts referenced a kext that needs removing for the MacPro5,1 definition, but also seemed to indicate that having ECC Ram required that kext?)

2) Would this error be fixed by editing / changing any kexts I might not be thinking of?

3) I have an msi 1GB GTX 750 that I have never installed.. Might a different card fix the issue or simply introduce new ones? (I also don't want to break my Mountain Lion system drive in case I need to swap back and forth).

4) Both this Mavericks install and my Mountain Lion install have used easybeast installs and have no custom editing of DSDTs or anything of that sort since I am still not too clear on that process (despite this being my 3rd or 4th install) and I could never find anything for the z800 in the database. Any advice regarding that (resource, recommendations, etc) or the fact that both installs have mis-identified by processor speed as 3.06GHz rather than the correct 2.93GHz would be appreciated as well.

EDIT: Further digging explained that I can use the MacPro5,1 smbios definition without removing anything because I have ECC RAM, however, changing this did nothing for the issue.

I have, however, discovered that I am able to boot without -x if i use nv_disable=1.
It isn't a solve yet, but it's something.
Last edited:
For the GT9600 have you tried with boot-arg


? - pay attention to the caps - command is case sensitive
For the GT9600 have you tried with boot-arg


? - pay attention to the caps - command is case sensitive

Hi, thanks for the response.

The system I am working on actually has the nVidia Quadro FX380 from my initial post installed.
This card requires the GraphicsEnabler=Yes argument in order to see anything as without it I would get a black screen / no display at all.

With that argument, the operating system was able to boot fine before the update, but is now experiencing the issue described above after the 10.9.5 update. I have no idea what would have changed.

That said, I tried installing a Sapphire Dual-X R9 270x 2G D5 card in an attempt to eliminate the specific card as the issue.
After a few hiccups, the system first gave me a Kernel Panic with VoodooHDA 2.7.3 so I just removed it for now to focus on the primary issue and now this card will boot exactly the same as the nVidia Quadro FX380: the Apple loading screen goes away and then I am left with a plain grey screen and a moveable mouse cursor that never changes and never shows the login screen.

Edit: Checking the boot log (using -x).. the Sapphire 270x card gives this error rather than the OpenGL error above:

WindowServer[88]: void __IOHIDEventQueueuRegister(): Timeout waiting for IOKit to be quiet

There are also Sandbox cache error 3850 and Sandbox cache error 11 database disk image is malformed errors immediately preceding the Timeout waiting for IOKit to be quiet error.

Different error but with the same symptom.
Also, swapping in my Mountain Lion 10.8.5 boot drive in place of the Mavericks drive -> Sapphire card causes the same kernel panic in VoodooHDA 2.7.3
Any help would be greatly appreciated as I have no idea where to go from here.
Last edited:
Can you get past the grey screen is you use boot-args

-v -f -x GraphicsEnabler=Yes or -v -f -x nv_disable=1

using the nVidia card?

Have you tried updating the Quadro drivers from nVidia for your version of OS X? They are version specific.
Can you get past the grey screen is you use boot-args

-v -f -x GraphicsEnabler=Yes or -v -f -x nv_disable=1

using the nVidia card?

Have you tried updating the Quadro drivers from nVidia for your version of OS X? They are version specific.

I can get past the grey screen / to the login screen with either card using safe boot (-x), but that still renders the system unusable for working as responsiveness is slow and audio is disabled.

GraphicsEnabler=Yes is required for the Quadro card or I get a blank/black display instead of the Apple loading screen.
GraphicsEnabler=Yes or No seems to make no difference with the Sapphire card.

nv_disable=1 works in place of -x with the Quadro card, but functions/looks terrible. (worse than with safe boot).
nv_disable=1 seems to have no effect with the Sapphire card.

There are no drivers from nVidia for my specific Quadro card / the Sapphire card would actually be preferable if it could work as it's performance would be far far better.

Without any boot arguments I simply get stuck at the grey screen (console messages listed in previous posts) forever.
Quadro drivers are for all Quadro cards across the nVidia model numbers for Mac OS X. See for a list of nVidia drivers and match the OS X version/build to what you have and download the appropriate driver.

the GE=Y/N and nv_xxx commands are for nVidia cards only and have no effect on ATI/AMD cards.

According to the compatibility chart at the R9 270X should be OOB if it is a reference card.
Not open for further replies.