Contribute
Register

Help needed to fix older install

Joined
Aug 5, 2013
Messages
9
Motherboard
Gigabyte GA-Z77X-UD5H
CPU
i7-3770
Graphics
Intel HD4000
I have an older hackintosh that I've been running for 4+ years (it's been great).

Now it is broken and I would like to recover without doing a full OS re-install. I feel like I've fallen down a rabbit hole here and could use some direction. I think the system can be recovered OK if I do the right thing now (unlike my previous several mistakes...).

OS is 10.9.5. Running on an SSD with a separate data drive containing time machine backups. Original build was pre-clover, using unibeast and multibeast and chimera?

I tried to modify my plist (smbios.plist I think) to change the system definition, to allow OS upgrade to current. This caused a kernel panic error when rebooted. I did make a copy of the plist file to the desktop first.

I booted from the USB and decided to do a time machine restore as the easiest way to return the system to the previous state. When rebooted, it gave the boot0: error. Reading up on that, I was able to unmount the volume and use the command - dd if=/usr/standalone/i386/boot1h of=/dev/disk0s2. This seemed to work and looked like it was booting ok, but - I'm now stuck on the grey screen after the apple logo.

I've found some threads about re-installing the boot loader, but I'm not clear on exactly how to do that. Maybe it would be better to upgrade to clover now? Anyway, it wouldn't be a disaster if I had to reformat and install, but there is some data on there I would like to keep if possible. Thanks in advance for helping an old-noob,

DE
 

P1LGRIM

Moderator
Joined
Mar 2, 2012
Messages
23,254
Motherboard
Lenovo ThinkStation p300 ⌘
CPU
i7-4790K
Graphics
HD 4600
Mac
MacBook Pro, Mac mini
Classic Mac
Power Mac
Mobile Phone
iOS
You should read the rules, in particular the one about profiles.
 
Top