Contribute
Register

HD630 Fix For High Sierra Beta

Status
Not open for further replies.
Joined
Feb 5, 2017
Messages
161
Motherboard
Dell Latitude 7390
CPU
i5-8350U
Graphics
UHD 620, 1920x1080
Mac
  1. MacBook Air
Mobile Phone
  1. Android
Default ig-platform-id is 0x59160000 when not specified.
Also, keep in mind that Clover will inject SKL FakeID and ig-platform-id if you don't tell it not to...

Should not that ig-platform-id show up in the ioreg? Because there's no ig-platform-id in my ioreg unless I explicitly inject it .

Also the system will try to load the KabyLake drivers anyway .

kextstat |grep -y appleintelskl
kextstat |grep -y appleintelkbl

91 0 0xffffff7f831b7000 0x1d1000 0x1d1000 com.apple.driver.AppleIntelKBLGraphicsFramebuffer (10.2.8) 5E487B49-8CA5-37CC-AA19-9BF3D0D9DA12 <90 89 86 21 12 11 7 6 5 4 3 1>

112 0 0xffffff7f82ac0000 0xf1000 0xf1000 com.apple.driver.AppleIntelKBLGraphics (10.2.8) 934B4773-B887-3829-AF9A-EEF373ACB111 <89 88 86 12 7 6 5 4 3 1>
 

Attachments

  • ioreg.zip
    1.1 MB · Views: 224
Joined
Aug 17, 2016
Messages
92
Motherboard
MSI GS73VR 7RF
CPU
i7 7700hq
Graphics
Nvidia GTX1060 6gb
Mobile Phone
  1. Android
Don't use SKL FakeID (set config.plist/Devices/FakeID/IntelGFX=native-id). Your native ID is likely 0x59168086 or 0x59128086.
Use KBL ig-platform-id, such as 0x59120000.
@Rahabman I have just checked the native boot of KBL. And guess what its worked without any patches . OOB. I haven't used any fake ids
Please have a look at my config file attached
 

Attachments

  • config.plist
    6.7 KB · Views: 874
  • Untitled.jpeg
    Untitled.jpeg
    78.2 KB · Views: 1,518

RehabMan

Moderator
Joined
May 2, 2012
Messages
183,827
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Should not that ig-platform-id show up in the ioreg? Because there's no ig-platform-id in my ioreg unless I explicitly inject it .

No. It won't show in ioreg, even though that is what is being used...
(it is a default in the code and is used when AAPL,ig-platform-id is not found in ioreg)

Also the system will try to load the KabyLake drivers anyway .

As long as an SKL fake device-id is not injected, of course...

@Rahabman I have just checked the native boot of KBL. And guess what its worked without any patches . OOB. I haven't used any fake ids
Please have a look at my config file attached

As should be expected.
Native support for native KBL device-id.
And default ig-platform-id 0x59160000 assumed by kext when not specified.
And since you're using Inject/Intel=false, you don't have to worry about Clover injecting an incorrect fake device-id.
 
Joined
May 17, 2017
Messages
9
Motherboard
MSI H270 Gaming M3
CPU
i5-7500
Graphics
HD 630
Mac
  1. iMac
  2. MacBook Air
Mobile Phone
  1. iOS
@Rahabman I have just checked the native boot of KBL. And guess what its worked without any patches . OOB. I haven't used any fake ids
Please have a look at my config file attached
You config.plist works just great. The only problem I got is the over-HDMI audio. I can see all the Audio outputs, though HDMI doesn't work. I didn't find any way to solve, I tried VoodooHDA 2.8.8. 2.8.9 and 2.9.0, and none worked. I tried them with FakePCIID_Intel_HDMI_Audio.kext, FakePCIID_Intel_HD_Graphics.kext and FakePCIID.kext. Still no way
 

RehabMan

Moderator
Joined
May 2, 2012
Messages
183,827
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
You config.plist works just great. The only problem I got is the over-HDMI audio. I can see all the Audio outputs, though HDMI doesn't work. I didn't find any way to solve, I tried VoodooHDA 2.8.8. 2.8.9 and 2.9.0, and none worked. I tried them with FakePCIID_Intel_HDMI_Audio.kext, FakePCIID_Intel_HD_Graphics.kext and FakePCIID.kext. Still no way

Did you have the required framebuffer patches in your config.plist to change the connector-type to HDMI?
All the external connectors in 0x59160000 are DP, not HDMI.
Also need to inject "hda-gfx"="onboard-1" on HDEF and IGPU.
 
Joined
Apr 5, 2016
Messages
55
Motherboard
Asus PRIME b250m-k
CPU
i3-7100
Graphics
HD 630
Don't use SKL FakeID (set config.plist/Devices/FakeID/IntelGFX=native-id). Your native ID is likely 0x59168086 or 0x59128086.
Use KBL ig-platform-id, such as 0x59120000.

Thank you very much ! I had a lot of trouble trying to install macOS High Sierra (10.13.2). I took the dedicated graphics (GTS 450) and tried the IGPU HD 630 and thanks to you - succeeded. File system is APFS (SSD Kingstone 120 GB). I did not use a MultiBeast (kernel panic). I have problems with Youtube. I play video but play does not work, it only works on refresh Safari browser. If you have some suggestion :)
 
Last edited by a moderator:
Joined
Dec 10, 2017
Messages
3
Motherboard
HP pavilion15 BC219TX
CPU
Intel i7-7700HQ
Graphics
HD630+GTX1050
Mobile Phone
  1. iOS
My graphics is same as you. But I tried all way,but no one is work.Could you give me one copy of your EFI files,please.:banghead:
 

Attachments

  • IMG_5517.JPG
    IMG_5517.JPG
    1.1 MB · Views: 423
Joined
Dec 13, 2017
Messages
2
CPU
i7-7700
Graphics
Intel 630 + GT 1050 Ti
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. iOS
My graphics is same as you. But I tried all way,but no one is work.Could you give me one copy of your EFI files,please.:banghead:

I literally have the same screen as you, as well as the same setup. I cannot get past that screen. If I do not set -v I get a spinning wheel that goes nowhere.

I've tried everything suggested so far, and nothing is working. Could it be a missing kext, even though I believe I've updated everything? I currently run 10.12.6 with no issues at all.

*UPDATE*
I fixed this issue by installing the spoof.aml for my duel-gpu, after 2 days.. this fix was 5mins of work. Installing HS on my HP Omen, while typing this on my wifes MacBook Air. :D
Guide here : https://www.tonymacx86.com/threads/...-only-ran-for-0-seconds-with-dual-gpu.233092/
 
Last edited:
Joined
Dec 25, 2017
Messages
7
Motherboard
Dell Q270
CPU
Intel i7-7700T
Graphics
Intel HD 630
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
@Rahabman I have just checked the native boot of KBL. And guess what its worked without any patches . OOB. I haven't used any fake ids
Please have a look at my config file attached
Would you mind to upload the EFI file here?
It would be very nice if HD630 can run natively without any fakeID or Injection :D

Edmund
 
Joined
Aug 17, 2016
Messages
92
Motherboard
MSI GS73VR 7RF
CPU
i7 7700hq
Graphics
Nvidia GTX1060 6gb
Mobile Phone
  1. Android
Would you mind to upload the EFI file here?
It would be very nice if HD630 can run natively without any fakeID or Injection :D

Edmund
You don't have to inject any graphics, and boot. Then you can see how it will boot without any injection, Coz 7th gen have native support
 
Status
Not open for further replies.
Top