Contribute
Register

[Guide] Lenovo Yoga 2 13" High Sierra 10.13.5

Joined
Jan 11, 2016
Messages
45
Motherboard
Lenovo Yoga 2 13" (Clover v3330)
CPU
Intel i5 4210U / 8 Series Chipset
Graphics
Intel HD 4400 / 1920x1080
Mac
Classic Mac
Mobile Phone
Android
This guide assumes you have High Sierra already installed on your Yoga and you can boot into it (default installation guide should work https://www.tonymacx86.com/threads/guide-booting-the-os-x-installer-on-laptops-with-clover.148093/ ).
I installed High Sierra with NO APFS conversion option.
https://www.tonymacx86.com/threads/guide-avoid-apfs-conversion-on-high-sierra-update-or-fresh-install.232855/

The guide is about solving problems after the install.

My hardware:
  • CPU: Intel Core i5-4200U
  • GPU: Intel HD Graphics 4400
  • Wi-Fi: Broadcom BCM4352
  • Audio: Realtec ALC235
  • Storage: M2 SSD (Samsung MZNTE512HMJH)

Working:
  • CPU (including native power management)
  • GPU (with no glithes and lags after boot)
  • WiFi and Bluetooth
  • Audio
  • USB ports (USB 3.0 too)
  • Battery indication
  • Brightness and brightness buttons
  • Touchscreen
  • Webcam
  • Sleep
Not tested:
  • HDMI out
  • HDMI audio

First of all you will need to install/update Clover to this version: https://www.tonymacx86.com/resources/clover-uefi-boot-mode-v2-4k-r4522.393/
After the install, mount EFI partition and replace /EFI/CLOVER/config.plist with RehabMan's one for HD4400.
https://github.com/RehabMan/OS-X-Clover-Laptop-Config/blob/master/config_HD4600_4400_4200.plist

GPU problems
inject device-id=0x0412 is already present and activated in RehabMan's config plist. You just have to install the latest FakePCIID.kext and FakePCIID_Intel_HD_Graphics.kext which can be found here:
https://bitbucket.org/RehabMan/os-x-fake-pci-id/downloads

Lag shortly after boot
In config.plist/KernelAndKextPatches/KextsToPatch disable (by setting Disabled to true) "Enable 9MB cursor bytes, 0x0a260006" patch.
Add these two patches:
9MB cursor bytes (vbo), 2 ports only (RehabMan)
disable 0204 port, change 0105 DP port to 0204 HDMI (RehabMan)

Can be found in attached config.plist or here.

Graphics boot glitch (garbled screen)
In config.plist/KernelAndKextPatches/KextsToPatch add patch:
Boot graphics glitch, 10.13 beta (based on denskop patch)

Can be found in attached config.plist or here.

Wi-Fi and Bluetooth problems
If you have Broadcom Wi-Fi just follow this guide:
https://www.tonymacx86.com/threads/broadcom-wifi-bluetooth-guide.242423/#post-1664577

Battery indication problems
Battery indication should work without DSDT patching by only installing ACPIBatteryManager.kext available here:
https://bitbucket.org/RehabMan/os-x-acpi-battery-driver/downloads/

Advice: If after any sort of experiments your battery indication is behaving unexpectedly (drops battery level from xx% to 0%, showing not charging or slow charging status, even under Windows) you will have to reset your EC by opening notebook's case, physically detaching the battery and pressing power button for 30 seconds.

Pathcing laptop DSDT (MUST READ)
All the solutions above are fully or partially based on patching laptop DSDT. Here is a link to the guide:
https://www.tonymacx86.com/threads/guide-patching-laptop-dsdt-ssdts.152573/
For Lenovo Yoga 2 13, you should NOT use refs.txt while disassembling and should use the latest iasl and MaciASL from RehabMan.
Patches I applied to DSDT:
"Fix _WAK Arg0 v2"
"HPET Fix"
"SMBUS Fix"
"IRQ Fix"
"RTC Fix"
"OS Check Fix (Linux)"
"Fix Mutex with non-zero SyncLevel"
"Audio layout 28" (see Audio problems below)
Brightness buttons patch (see Brightness problems below)
"USB3 _PRW 0x0D (instant wake)" (see Sleep problems below)

Audio problems
To get ALC235 working there is a solution from vit9696. Download the latest AppleALC.kext and Lilu.kext and put them CLOVER/kexts/Other folder. The reason to put them there is because AppleALC should load earlier than AppleHDA. AppleALC requires Lilu to work.
AppleALC.kext: https://github.com/vit9696/AppleALC/releases
Lilu.kext: https://github.com/vit9696/Lilu/releases
You will also need to apply DSDT "Audio Layout" patch. layout-id should be set to 28. Here is a DSDT patch for this:
Code:
into method label _DSM parent_label HDEF remove_entry;
into device label HDEF insert
begin
Method (_DSM, 4, NotSerialized)\n
{\n
    If (LEqual (Arg2, Zero)) { Return (Buffer() { 0x03 } ) }\n
    Return (Package()\n
    {\n
        "layout-id", Buffer() { 28, 0x00, 0x00, 0x00 },\n
        "hda-gfx", Buffer() { "onboard-1" },\n
        "PinConfigurations", Buffer() { },\n
        //"MaximumBootBeepVolume", 77,\n
    })\n
}\n
end;

into method label _DSM parent_label HDAS remove_entry;
into device label HDAS insert
begin
Method (_DSM, 4, NotSerialized)\n
{\n
    If (LEqual (Arg2, Zero)) { Return (Buffer() { 0x03 } ) }\n
    Return (Package()\n
    {\n
        "layout-id", Buffer() { 28, 0x00, 0x00, 0x00 },\n
        "hda-gfx", Buffer() { "onboard-1" },\n
        "PinConfigurations", Buffer() { },\n
        //"MaximumBootBeepVolume", 77,\n
    })\n
}\n
end;

Brightness problems
To fix brightness controls use this guide: https://www.tonymacx86.com/threads/guide-laptop-backlight-control-using-applebacklightinjector-kext.218222/
Then, for F11 (_Q11) and F12 (_Q12) keyboard buttons to work as brightness controllers you will have to edit your DSDT. Apply this patch:
Code:
into method label _Q11 replace_content
begin
// Brightness Down\n
    Notify(\_SB.PCI0.LPCB.PS2K, 0x0405)\n
end;
into method label _Q12 replace_content
begin
// Brightness Up\n
    Notify(\_SB.PCI0.LPCB.PS2K, 0x0406)\n
end;
Sleep problems
To fix sleep problems I had to only apply "USB3 _PRW 0x0D (instant wake)" patch, because that was the only wake reason (EH02 XHC) in my case. If your laptop will have instant wake problem you can search the wake reason using: log show | grep -i "Wake reason". I also advise you to change SMBIOS to MacBookAir6,2 in config.plist.

Big thanks to RehabMan for all the guides and solutions!
 

Attachments

Joined
Apr 20, 2015
Messages
16
Motherboard
Lenovo Yoga 2 13"
CPU
i3 4030U
Graphics
Intel HD4400
Mac
Classic Mac
Mobile Phone
Hi, I have the same computer and for the audio I used the id 3 layout and it works perfectly
 
Joined
Feb 2, 2013
Messages
8
Motherboard
Lenovo Yoga 2 13
CPU
Core i5-4210U
Graphics
Intel HD 4400
Mobile Phone
Android
Hi man, in your guide you said that we have to look at the Rehab's guide to install High Sierra on this Laptop.
I have garbled screen when i reach macOS install (It works, but i can't see sh*t)
I did everything in post #1 on the guide:
1) using latestRehab's Clover v2.4k_r4444 in UEFI Mode and checking only what was written
2) latest FakeSMC, VoodooPS2Controller as kexts
3) config.plist (first i tried HD5000 version, then 4400, then yours attached)

I also tried to insert FakePCID kexts in EFI/Clover/Kexts/Other but nothing...i still have the garbled screen.

OFC..i use Lenovo Yoga 2 13, and i've installed Clover to USB (and using macOS High Sierra 10.13.5 Build 17F77)

Have any suggest? thank you :)

PS: I saw there is a patch for garbled screen, but as you said you included it in your Config.plist, and it still doesn't work
 
Last edited:

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,122
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Hi man, in your guide you said that we have to look at the Rehab's guide to install High Sierra on this Laptop.
I have garbled screen when i reach macOS install (It works, but i can't see sh*t)
I did everything in post #1 on the guide:
1) using latestRehab's Clover v2.4k_r4444 in UEFI Mode and checking only what was written
2) latest FakeSMC, VoodooPS2Controller as kexts
3) config.plist (first i tried HD5000 version, then 4400, then yours attached)

I also tried to insert FakePCID kexts in EFI/Clover/Kexts/Other but nothing...i still have the garbled screen.

OFC..i use Lenovo Yoga 2 13, and i've installed Clover to USB (and using macOS High Sierra 10.13.5 Build 17F77)

Have any suggest? thank you :)

PS: I saw there is a patch for garbled screen, but as you said you included it in your Config.plist, and it still doesn't work
Show image of garbled screen....
Your profile is not filled out as per FAQ. Please fix.
https://www.tonymacx86.com/threads/faq-read-first-laptop-frequent-questions.164990/
 
Joined
Feb 2, 2013
Messages
8
Motherboard
Lenovo Yoga 2 13
CPU
Core i5-4210U
Graphics
Intel HD 4400
Mobile Phone
Android
Show image of garbled screen....
Your profile is not filled out as per FAQ. Please fix.
https://www.tonymacx86.com/threads/faq-read-first-laptop-frequent-questions.164990/
Thank you Rehab, i filled profile (but i don't know Motherboard model) and i attached the garbled screen photo.

I got news: If i let the screen go off, when i wake it up there are no glitchs. BUT...if i click something, everything disappears except then grey background and the cursor (that still works)
15303818473844023295590965922412.jpg
 
Last edited:

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,122
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Thank you Rehab, i filled profile (but i don't know Motherboard model) and i attached the garbled screen photo.

I got news: If i let the screen go off, when i wake it up there are no glitchs. BUT...if i click something, everything disappears except then grey background and the cursor (that still works)
View attachment 338456
Make sure you have CSM/legacy boot enabled in BIOS.
As is mentioned in the guide:
https://www.tonymacx86.com/threads/guide-booting-the-os-x-installer-on-laptops-with-clover.148093/
 
Joined
Feb 2, 2013
Messages
8
Motherboard
Lenovo Yoga 2 13
CPU
Core i5-4210U
Graphics
Intel HD 4400
Mobile Phone
Android
Well, I apologize...i understood that UEFI was recommended if i had it.

But i still have troubles
As mentioned in the guide, i partitioned in GPT/OS Extended, installed macOS but i don't reach "About 1 minute remaining": system reboots soon once progress reachs "About 2 minutes remaining".

Maybe installmedia are corrupted? Or I insterted something i shouldn't have in Clover's EFI that creates conflicts?

PS. There are ~5.36GB used in install target and it shows "Install macOS from High Sierra(My partition Name)" in Clover

Thanks a lot man, while you're helping me im trying to get confident using your topics.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,122
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Well, I apologize...i understood that UEFI was recommended if i had it.
Of course... UEFI should be enabled as well as CSM/legacy.
You will continue to boot Clover in UEFI.

But i still have troubles
As mentioned in the guide, i partitioned in GPT/OS Extended, installed macOS but i don't reach "About 1 minute remaining": system reboots soon once progress reachs "About 2 minutes remaining".

Maybe installmedia are corrupted? Or I insterted something i shouldn't have in Clover's EFI that creates conflicts?

PS. There are ~5.36GB used in install target and it shows "Install macOS from High Sierra(My partition Name)" in Clover

Thanks a lot man, while you're helping me im trying to get confident using your topics.
Keep in mind that the install process is multi-phase with reboots in between.
 
Joined
Feb 2, 2013
Messages
8
Motherboard
Lenovo Yoga 2 13
CPU
Core i5-4210U
Graphics
Intel HD 4400
Mobile Phone
Android
Yesterday i tried many times again, still rebooting during "About 2 minutes remaining..." Today tried to re-create "install_osx" as written in the guide, with config.plist (HD4400), FakeSMC and VoodooPS2Controller, default drivers64UEFI plus HFSPlus and nothing else, now it rebooted as before (2 minutes remaining) but i dont understand something in the guide:

"5. Clover bootloader screen shows up. For versions prior to 10.12, select "install_osx" as you did in step #2 (your OS X Installer partition, not your install target partition). Note that macOS Sierra is a bit different in that you will see an "Boot macOS Install from ..." entry in Clover on your target partition at this stage. For 10.12, boot that entry instead of install_osx on the USB"

I'm using 10.13, which partition should I start now? "install_osx" or the install target? Yesterday when i tried to boot install target partition it was showing "installing ~~~~~ xx minutes remaining" under white apple logo and then rebooted.

I know i'm boring, but i have no idea where is the problem: config.plist? kexts? drivers64uefi? Corrupted installmedia? If you have any idea i can go for it.

PS: I actually have 10.12 Sierra (badly) working (with no post-install) with UniBeast
 
Last edited:

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,122
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
I'm using 10.13, which partition should I start now? "install_osx" o the install target?
It depends on what you see as boot targets within Clover.
If you see an option to boot the installer from the partition you started installing to, pick that one.
 
Top