Contribute
Register

[Guide] HP ProBook 430 G6 (Whiskey Lake)

Joined
Dec 23, 2011
Messages
174
Motherboard
HP ProBook 430 G6
CPU
i5-8265U
Graphics
UHD 620, 1920x1080
Mac
MacBook Pro
Mobile Phone
iOS
c06195389_1750x1285.jpg



Finally I managed to make a pure EFI build (without adding anything to /L/E or /S/L/E). Here is How I did this

Hardware

CPU
: Intel Core i5 3.9GHz
RAM: 32Gb 2133 MHz DDR4
GPU: Intel UHD Graphics 620 / PCI [8086:3ea0] - requires Lilu.kext + WhateverGreen.kext, device-id=a53e0000, AAPL,ig-platform-id=0900a53e; HDMI work, but require patching (see notes below), USB Type-C works with glitches (see notes below)
SSD: OCZ-AGILITY3 240 Gb (SATA)
Ethernet: Build-in Realtek RTL8168H / PCI [10ec:8168] - requires RealtekRTL8111.kext
WiFi: HP 915622-001 (chipset Realtek RTL8822BE) - known to be unsupported, replaced with Dell DW1560 (chipset Broadcom BCM94352Z) which needs AirportBrcmFixup.kext + Lilu.kext
Bluetooth: same as above, but requires BrcmFirmwareData.kext v2.2.12 + BrcmPatchRAM2.kext v 2.2.12 + BrcmBluetoothInjector.kext v2.2.12, depends on USB (see notes below). More details are available here
Audio: Intel HD Audio (Realtek ALC236, Intel Kabylake HDMI) / PCI [8086:9dc8] - requires Lilu.kext + AppleALC.kext, layout=3; build-in speakers work, build-in microphone works, headphones socket works
Fingerprint reader: Synaptics / Validity Sensors, Inc. / USB [138a:00ab] - doesn't work
Camera: HP HD Camera / USB [04ca:7095] - works, depends on USB (see notes below)
SD Card Reader: Intel SD Host / PCI [8086:9df5] - doesn't work
LCD: 1920x1080 - backlight requires SSDT-PNLFCFL.aml + WhateverGreen.kext + Lilu.kext; The brightness patch will only enable the slider in SysPrefs->Displays. Keyboard control is a separate issue, as the keyboard driver must generate ACPI events.
Battery Indicator: works, but does not show time remaining.
Sleep: works (USBInjectAll.kext breaks it)
Keyboard: works, requires VoodooPS2Controller.kext (see keyboard & trackpad notes below)
TouchPad: ELAN2514 (compatible with PNP0C50) - works (including gestures), requires VoodooI2C.kext, VoodooI2CHID.kext
FAN: doesn't work
Lid: open and close is detected
Continuity: AirDrop works, HandOff not tested, InstantHotspot works
CPU Power Management: requires SMCProcessor.kext; provides temperature and voltage values
FileVault: works, requires AppleGenericInput.efi & AppleUiSupport.efi

Code:
$ sysctl -n machdep.cpu.brand_string
Intel(R) Core(TM) i5-8265U CPU @ 1.60GHz
Before you start

1) Update BIOS. As of 08/16/2019 the latest version is 1.8.3.Rev.A
2) Set video memory size to at least 64Mb in BIOS

Installation Instructions

2) Get USB stick. Format it using GUID partition table and Mac OS Extended (Journaled) filesystem. Volume label should be "USB"
3) Copy macOS files from Terminal.app
Code:
sudo /Applications/Install\ macOS\ Catalina\ Beta.app/Contents/Resources/createinstallmedia --volume /Volumes/USB
4) Get Clover UEFI Boot Mode
5) Install Clover using USB as the target
6) Copy VirtualSMC.kext, RealtekRTL8111.kext, VoodooPS2Controller.kext, config.plist (this one)
7) Remove SMCHelper-64.efi
8) Prepare USB mouse because touchpad does not work out of the box. USB port on the left side doesn't work out of the box either
9) Copy SSDT-EC.aml to EFI/CLOVER/ACPI/Patched(Catalina won't boot without it)

Now you should be able to boot your ProBook using this USB stick and install macOS. Note: it may reboot several times before installation completes, this is fine, this is by design.

When done, use USB stick to boot your masOS.

Post Installation Instructions

TBD


Notes on Graphics

For testing I had two external LCDs 1920x1080 both. Both have HDMI interface, but no one has USB Type-C interface. For this reason I had to use a hub and attache HDMI cable to the hub, then attach the hub to laptop's USB Type-C port.

Hub #1 identifies as follows:
Code:
  Product ID:    0x2817
  Vendor ID:    0x2109  (VIA Labs, Inc.)
  Version:    3.a3
  Speed:    Up to 480 Mb/sec
  Manufacturer:    VIA Labs, Inc.
  Location ID:    0x14600000 / 5
  Current Available (mA):    500
  Current Required (mA):    0
  Extra Operating Current (mA):    0
USB Billboard Device   :
  Product ID:    0x8888
  Vendor ID:    0x2109  (VIA Labs, Inc.)
  Version:    0.01
  Serial Number:    0000000000000001
  Speed:    Up to 480 Mb/sec
  Manufacturer:    VIA Labs, Inc.
  Location ID:    0x14650000 / 6
  Current Available (mA):    500
  Current Required (mA):    100
  Extra Operating Current (mA):    0
Hub #2 identifies as follows:
Code:
USB2.0 Hub:
Product ID:    0x2813
  Vendor ID:    0x2109  (VIA Labs, Inc.)
  Version:    90.11
  Speed:    Up to 480 Mb/sec
  Manufacturer:    VIA Labs, Inc.
  Location ID:    0x14600000 / 7
  Current Available (mA):    500
  Current Required (mA):    0
  Extra Operating Current (mA):    0
USB 2.0 BILLBOARD             :
  Product ID:    0x0100
  Vendor ID:    0x2109  (VIA Labs, Inc.)
  Version:    1.22
  Serial Number:    0000000000000001
  Speed:    Up to 480 Mb/sec
  Manufacturer:    VIA Technologies Inc.
  Location ID:    0x14610000 / 8
  Current Available (mA):    500
  Current Required (mA):    100
  Extra Operating Current (mA):    0
By default HDMI port produce no output, and the following patch (config.plist) is needed to enable this port:
Code:
...
    <key>Devices</key>
    <dict>
        <key>Properties</key>
        <dict>
            <key>PciRoot(0x0)/Pci(0x2,0x0)</key>
            <dict>
                <key>AAPL,ig-platform-id</key>
                <data>CQClPg==</data>
                <key>device-id</key>
                <data>pT4AAA==</data>
                <key>framebuffer-patch-enable</key>
                <data>AQAAAA==</data>
                <key>framebuffer-con1-busid</key>
                <data>AQAAAA==</data>
                <key>framebuffer-con1-enable</key>
                <data>AQAAAA==</data>
                <key>framebuffer-con1-type</key>
                <data>AAgAAA==</data>
            </dict>
        </dict>
...
Same hardware operates under Windows 10 with no troubles.

Actually AAPL,ig-platform-id=0900A53E is the only one that enables video output thought USB Type-C port. However it works with glitches which makes it almost unusable.

USB Notes
  1. Place the USBInjectAll.kext (for port discovery) into EFI/CLOVER/kexts/Other
  2. Reboot
  3. Run Hackintool then go to General->Installed to check USBInjectAll is installed correctly
    • Eg. USBInjectAll: Yes (Release-0.7.1)
  4. Go to the General->USB tab
    • Plug and unplug a USB 3.0 device into all ports on your system
    • Plug and unplug a TypeC device into all ports (in both orientations)
    • The ports that are active will remain highlighted green
    • Delete all ports that are not highlighted green
  5. Set each port to the appropriate Connector using the drop down list
    • USB ports with devices permanently attached (eg. M.2 Bluetooth card) should be set to “Internal”
    • HSxx ports connected to USB3 ports should be set to USB3
    • TypeC:
      • If it uses the same HSxx/SSxx in both orientations, then it has an internal switch (use “TypeC+Sw”)
      • If it uses a different HSxx/SSxx in each orientation, then it has no switch (use “TypeC”)
  6. Use the “Export” button to generate files to your Desktop
  7. Copy SSDT-UIAC.aml and SSDT-USBX.aml (if created) to EFI/CLOVER/ACPI/patched
  8. You can now perform a clean up and remove USBInjectAll.kext
  9. Reboot
usb.png

Keyboard

Requires VoodooPS2Controller.kext, see below.

In BIOS you may "Swap Fn and Ctrl (Keys)" - this makes keyboard layout closer to Mac.


Trackpad

By default Trackpad is only available for Windows 10. For this reason we'll have to patch DSDT. Boot to Clover, press F4 to save DSDT.aml to EFI partition. Copy this file from original to patched directory. Use MaciASL to apply patches shown at the picture below:
Screen Shot 2019-08-23 at 08.42.28.png


I use VoodooPS2Controller.kext for keyboard. It contains keyboard, mouse and trackpad plugins. Last two of them have to be removed.

Now, when ACPI is patched, you may use VoodooI2C.

Enable hiDPI

1920x1080 is too much for 13" build-in display. It would be safer for your eyes to enable hiDPI

hiDPI.gif

This could be achieved using one-key-hidpi:

Code:
$ ./hidpi.sh
  _    _   _____   _____    _____    _____
| |  | | |_   _| |  __ \  |  __ \  |_   _|
| |__| |   | |   | |  | | | |__) |   | |
|  __  |   | |   | |  | | |  ___/    | |
| |  | |  _| |_  | |__| | | |       _| |_
|_|  |_| |_____| |_____/  |_|      |_____|
                    
============================================

                      Monitors
--------------------------------------------------------
   Index   |   VendorID   |   ProductID   |   MonitorName
--------------------------------------------------------
    1    |    09e5    |     4608    |
    2    |    410c    |     aac0    |  227E4QH
--------------------------------------------------------
Choose the display: 1
Backing up...

(1) Enable HIDPI
(2) Enable HIDPI (with EDID)
(3) Disable HIDPI

Enter your choice [1~3]: 1

-------------------------------------
|********** Display Icon ***********|
-------------------------------------

(1) iMac
(2) MacBook
(3) MacBook Pro
(4) LG Display
(5) Pro Display XDR
(6) Do not change

Enter your choice [1~6]: 6

------------------------------------------
|********** resolution config ***********|
------------------------------------------

(1) 1080P Display
(2) 1080P Display (use 1424x802, fix underscaled after sleep)
(3) 2K Display
(4) Manual input resolution

Enter your choice: 1
Enabled, please reboot.
Rebooting the logo for the first time will become huge, then it will not be.
Result:
Screen Shot 2019-08-21 at 2.25.47 PM.png


Press "like" to let others know that it works for you.

See also:
[Guide] How to Create a macOS Catalina Public Beta Installation USB
[Guide] Broadcom WiFi/Bluetooth
[Guide] Intel Framebuffer patching using WhateverGreen
[Guide] Acer Swift 5 SF514-53t whiskey lake MacOS10.14.5
[Guide] Dell Inspiron 7586 / I7-8565U /Intel UHD 620
[Guide] Patching DSDT/SSDT for LAPTOP backlight control
 

Attachments

Last edited:
Joined
Aug 25, 2019
Messages
4
Motherboard
HP ProBook 440 G6
CPU
i7 -8565U
Graphics
UHD 620
Mac
Mac Pro
Mobile Phone
Android
HI @antonio765, I have a laptop just like yours, maybe you could do me the favor of helping me with a copy of your EFI partition, I have had many problems with the video interface, constant kernel panic and reboot of the equipment.
 
Joined
Dec 23, 2011
Messages
174
Motherboard
HP ProBook 430 G6
CPU
i5-8265U
Graphics
UHD 620, 1920x1080
Mac
MacBook Pro
Mobile Phone
iOS
HI @antonio765, I have a laptop just like yours, maybe you could do me the favor of helping me with a copy of your EFI partition, I have had many problems with the video interface, constant kernel panic and reboot of the equipment.
Even if I was able to make every piece of hardware work, I was not able to make them work all together. It seems there are some conflicts. For this reason I don't ant to publish buggy solution. But I still can help you by guiding through all the process. And may be you will help me to find mistakes in my installation.

In case it works for you, please let me know which BIOS firmware version do you have and if you was able to make a bootable installation USB stick.
 
Joined
Aug 25, 2019
Messages
4
Motherboard
HP ProBook 440 G6
CPU
i7 -8565U
Graphics
UHD 620
Mac
Mac Pro
Mobile Phone
Android
Hi Antonio,
Thanks for your response, trying to do the installation UBS when using the config.plist with the modifications of recommendations to make for the HD620 graphical interface I get this error when starting and the computer restarts,
 

Attachments

Joined
Dec 23, 2011
Messages
174
Motherboard
HP ProBook 430 G6
CPU
i5-8265U
Graphics
UHD 620, 1920x1080
Mac
MacBook Pro
Mobile Phone
iOS
Hi Antonio,
Thanks for your response, trying to do the installation UBS when using the config.plist with the modifications of recommendations to make for the HD620 graphical interface I get this error when starting and the computer restarts,
As far as I can see, your config.plist is different to what I described in "Installation Instructions" section. And as a result you get kernel panic. Building hackintosh is like walking mine field. And devil is in details. So please follow "Installation Instructions" and send us a photo of your installer running, please.
 
Joined
Aug 25, 2019
Messages
4
Motherboard
HP ProBook 440 G6
CPU
i7 -8565U
Graphics
UHD 620
Mac
Mac Pro
Mobile Phone
Android
Hello, the first thing I want to tell you is to update the bios to version 01.08.03, as you recommend.
I made the installer according to the instructions in the "Installation Instructions" session, install clover from link, copy the kext you mention in folder kext/Other/, delete the file SMCHelper-64.efi from folder drivers64UEFI and add the file SSDT-EC.aml to ACPI/patched/
I attached the images of how I have configured the bios, the content of my EFI folder and the image in which the process stays, stays there and does not advance, even try to start in verbose mode and does not show more information.
In what you can help me thank you very much.

pantalla.jpeg
 

Attachments

Joined
Dec 23, 2011
Messages
174
Motherboard
HP ProBook 430 G6
CPU
i5-8265U
Graphics
UHD 620, 1920x1080
Mac
MacBook Pro
Mobile Phone
iOS
Hello, the first thing I want to tell you is to update the bios to version 01.08.03, as you recommend.
I made the installer according to the instructions in the "Installation Instructions" session, install clover from link, copy the kext you mention in folder kext/Other/, delete the file SMCHelper-64.efi from folder drivers64UEFI and add the file SSDT-EC.aml to ACPI/patched/
I attached the images of how I have configured the bios, the content of my EFI folder and the image in which the process stays, stays there and does not advance, even try to start in verbose mode and does not show more information.
In what you can help me thank you very much.
I can see that you actually have HP ProBook 440 G6. So this is not exactly the same that I have. In particular SSDT-EC.aml doesn't work for you.

From the following picture I can see that bootloader does not start the kernel. It meanks that kexts are not the reason.

start-verbose.jpeg


I also can see in log that your BIOS is not up-to-date:
Code:
13:326  0:020  BiosReleaseDate: 04/16/2019
Most probably the reason is incorrect BIOS/ACPI/SSDT.
 
Joined
Dec 23, 2011
Messages
174
Motherboard
HP ProBook 430 G6
CPU
i5-8265U
Graphics
UHD 620, 1920x1080
Mac
MacBook Pro
Mobile Phone
iOS
Hello, the first thing I want to tell you is to update the bios to version 01.08.03, as you recommend.
I made the installer according to the instructions in the "Installation Instructions" session, install clover from link, copy the kext you mention in folder kext/Other/, delete the file SMCHelper-64.efi from folder drivers64UEFI and add the file SSDT-EC.aml to ACPI/patched/
I attached the images of how I have configured the bios, the content of my EFI folder and the image in which the process stays, stays there and does not advance, even try to start in verbose mode and does not show more information.
In what you can help me thank you very much.
I gave it a thought. If you just remove SSDT-EC.aml it should work for you.
 
Joined
Sep 4, 2019
Messages
9
Motherboard
HP Probook 450 G6
CPU
i5-8265U
Graphics
UHD 620 + GTX MX130
Mac
iMac
Classic Mac
iMac
Hi guys,

I'm trying to get my probook 450 G6 to work with Mojave, and it has the same i5-8265 and UHD 620 than yours @antonio765 .

Do you think your config will also work on my laptop ?

Current state of my machine :

Screen is not black any more, but no brightness control : "System Pref>Monitor" is empty
UHD 620 with 3Mo @ 1024x768
Ethernet is working
Sound is working
No idea of MX130 state
Battery management : looks ok
Integrated keyboard is ok
Trackpad has no right-click and has some spasm from time to time, but still usable.

Regards
 
Joined
Dec 23, 2011
Messages
174
Motherboard
HP ProBook 430 G6
CPU
i5-8265U
Graphics
UHD 620, 1920x1080
Mac
MacBook Pro
Mobile Phone
iOS
Hi guys,

I'm trying to get my probook 450 G6 to work with Mojave, and it has the same i5-8265 and UHD 620 than yours @antonio765 .

Do you think your config will also work on my laptop ?

Current state of my machine :

Screen is not black any more, but no brightness control : "System Pref>Monitor" is empty
UHD 620 with 3Mo @ 1024x768
Ethernet is working
Sound is working
No idea of MX130 state
Battery management : looks ok
Integrated keyboard is ok
Trackpad has no right-click and has some spasm from time to time, but still usable.

Regards
As for graphics, it should work because it is build-into CPU. But as for peripheral, it may be quite different comparing to my laptop. Use linux live USB stick to collect data about PCI and USB devices. You may compare your hardware to mine (see attached files).
 

Attachments

Top