Contribute
Register

[Guide] HP Elite X2 1012 G1 - The ultimate OS X tablet? Pretty close....

Joined
Jan 3, 2013
Messages
92
Motherboard
Lenovo ThinkPad P50
CPU
E3-1505M v5
Graphics
P530 + M2000M
I have a Huawei Matebook e, can you please help me?! I cannot get it too install.... It is stuck on the apple logo (progress bar = 1/10)
Not related, please open a new thread.
 
Joined
Oct 12, 2019
Messages
1
Motherboard
HP Elite X2 G1
CPU
M57-6Y75
Graphics
HD 515
Mac
  1. MacBook
  2. Mac mini
  3. Mac Pro
Mobile Phone
  1. Android
  2. iOS
hi, I Have a HP elite X1 G1. everything was ok with Mojave.
after upgrade to Catalina touch screen was lost and every solution found on the Internet have been, at now, not successful....
do you have any suggestions?
 
Joined
Dec 14, 2019
Messages
2
Motherboard
Alienware 17 - 2013
CPU
i7-4900MQ
Graphics
HD 4600 + GTX 780M
hi, I Have a HP elite X1 G1. everything was ok with Mojave.
after upgrade to Catalina touch screen was lost and every solution found on the Internet have been, at now, not successful....
do you have any suggestions?

Hi @fabrical128, I have the same Elite X2 G1 model with an m7-CY75 CPU I'm having trouble installing Mojave, can you post your Clover configuration if possible ?
 
Joined
Jan 21, 2020
Messages
1
Hi all, i'm a owner of a Sinar Digital Back that i'm using with a 2006 Macbook, but i wanted a tablet to be able to bring that beast outside to do some shooting without bringing a laptop around and i noticed this tablet. The main problem, that i don't understand if it has been solved, is that the thunderbolt 3 port doesn't work still, and i need it to connect my firewire 400 digital back to the tablet using a firewire 400 to Firewire 800 Cable --> Firewire 800 to Thunderbolt 2 adapter --> Thunderbolt 2 to Thunderbolt 3 adapter. Can you help solving this mistery before pressing the buy button on this tablet? Thanks in advance.
 
Joined
Feb 8, 2020
Messages
18
Motherboard
hp elite x2G1
CPU
M7
Graphics
515.1000-2000
Mac
  1. iMac
Classic Mac
  1. 128K
Mobile Phone
  1. Android
  2. iOS
sir,my device is G1,bios version is 1.44,i find something wrong when i do ACPI patching of ssdt-16.you can see the alarming on third picture . so i find something different in the beginning of ssdt-16.the first picture is mine,the second is yours.my picture don't have the word psk2 xxxx.


i have a question, you say ,For the volume keys to function, in Method _Q30 ONLY,Search for VBPS, 0x02 and add the following after the if statement bracket:Notify (\_SB.PCI0.LPCB.PS2K, 0x0430).
the volume keys here you say,is the keys on the keyboard or the keys near the battery key?


i attach my aml dsl and patches from you first article.

and at last i want to know how to fix my volume keys near the battery key.thank you very much.
 

Attachments

  • IMG_20200218_003215.jpg
    IMG_20200218_003215.jpg
    7.9 MB · Views: 81
  • IMG_20200218_003221.jpg
    IMG_20200218_003221.jpg
    7.6 MB · Views: 79
  • IMG_20200218_004241.jpg
    IMG_20200218_004241.jpg
    8.5 MB · Views: 86
  • aml.zip
    70.2 KB · Views: 72
  • dsl.zip
    136.2 KB · Views: 65
  • patches form you article G1.zip
    7.1 KB · Views: 99
Joined
Aug 21, 2017
Messages
24
Motherboard
Dell Latitude 5591
CPU
i3-10110U
Graphics
Intel UHD Graphics
Mac
  1. MacBook Air
Mobile Phone
  1. Android
Hello ! Sold all the desktops to stay with hp elite x2 m7-6y75 8/256 - installed win10 / chromeos and osx 10.14.6 triple boot - but wanted to use osx most of time... But noticed that geekbench 5 ( multicore) on windows 10 shows 1750 and only 950 in cromeos 80 and OSX ( ... what could be the reason for that ? osx installation according to this guide - only aded rt2870usb and ax8817 kexts ... Maybe i should correct frequencies in clover somehow?
 
Joined
Jan 13, 2021
Messages
1
Motherboard
HP X2 1012 G1
CPU
M7-6Y75
Graphics
HD 515
Hello ! Sold all the desktops to stay with hp elite x2 m7-6y75 8/256 - installed win10 / chromeos and osx 10.14.6 triple boot - but wanted to use osx most of time... But noticed that geekbench 5 ( multicore) on windows 10 shows 1750 and only 950 in cromeos 80 and OSX ( ... what could be the reason for that ? osx installation according to this guide - only aded rt2870usb and ax8817 kexts ... Maybe i should correct frequencies in clover somehow?
please help me with full EFI folder for my device


HP Elite x2 1012 G1
m7-6y75 CPU 1.10
8GB ram
256 SSD
 
Top