GA-X79-UP4--i74930K-GA-GTX770 4GB, skipping video and audio dropping

Not open for further replies.
Sep 18, 2013
ASUS Z9PE-D8 WS Clover 10.11.1
XEON 2x2650 v2
2X Gigabyte GTX 980 Ti 6G, PNY 780 Ti
  1. MacBook Pro
  2. Mac Pro
Classic Mac
  1. Power Mac
Mobile Phone
  1. Android
I have been through a number of posts for the last week and haven't come to any diagnosis as to what is causing this. Specs are:

Board: GA-X79-UP4 Bios:F4
CPU: i7-4930K
GPU: GA-GTX770 4GB O.C edition
O.S.: 10.9.2

It doesn't matter if it's a video file, or video in a browser the results are the same. The video freezes and then continues and only about the first 6 secs of audio plays and then I loose it completely. Funny enough I also can only listen to about 6secs of audio from an MP3 as well. This is through the on-board audio through the headphone jack. That has also been a headache but I thought I would clear this up first. I will be using this build for video editing and some audio work so I'm banging my head trying to figure out where the problems is coming from.

NVIDA's newest March release drivers are installed and in use and I have the newest CUDA drivers installed as well. There's no difference between using the OS's drivers versus NVIDIA's. Any kind of benching score does fine, i.e. Cinebench, Unigine, etc, they all run amazingly.

Here's my boot list
<?xml version="1.0" encoding="UTF-8"?><!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "">
<plist version="1.0">
    <key>Instant Menu</key>
    <key>Kernel Flags</key>
    <string> npci=0x2000 PCIRootUID=1 nvda_drv=1</string>
    <key>Legacy Logo</key>

I connect to my monitor through HDMI and tried using DVI but with the same results. Something that I haven't been able to see for sure if this makes a difference is I'm still booting off my Unibeast because I haven't fixed my Boot=0 problem. Didn't want to do that yet because I've been doing the reinstall a couple of times to make sure I have covered any potential problems. Was tempted to install Clover for the EFI booting but I don't think that will fix the video issue.

Anyone with the magic answer:D?

Edit: Oh yeah and the desktop experience is fluid with no issues. CUDA-Z also reports the correct information as well as About This Mac.
Yeah I've actually been researching that one and quite a few others. I even stumbled across your thread about using an R280X for the purposes of FCPX. I even tempted to switch to that if I could find a model that I know would work with this build.

Anyways, here are some interesting results that I came up with. I decided that I would try and fix the boot 0 error problem first so that I could boot directly to the drive without having to use the Unibeast stick all the time and also thinking that that might be the issue. I used this link for that which worked wonderfully. However it created more weirdness but made me realize something. The wierdness is that it took way longer to load everything and get into the desktop than normal. Once it got into the desktop everything was in slow motion. I have my clock set up to display the seconds as well and even that was running slow, so slow that over the past 30 mins of looking at stuff in that mode the clock only progressed about 6 mins! Using the hardware monitor I noticed a couple of things. First time I booted from the drive it didn't even show a GPU temp or anything, but in About This Mac it showed the correct video card, memory etc. The second time I booted directly from the hard drive, I had installed the NVIDIA drivers and the GPU did show up in the HWmonitor list but it never came out of it's low clock state. Now that being said, operating in the desktop it shouldn't have to.

Next I use verbose mode on boot up to follow what might be going on and to my surprise I figured out a correlation of when it goes into slow mo, when I load off the Unibeast stick, it boots fast! I mean fast. I caught my eye on something that 'posted' if you will that didn't show up booting directly from the hard drive. It said something like GeForce sensors loading and then GeForce sensors loaded. It was quick but I was able to gather that much. When I boot directly from the hard drive, it was really slow. And I definitely noticed that the sensor thing didn't pop up in the log at all.

Unfortunately, I can see any direct correlation to the video freezing and audio skipping problem. But while looking at my verbose log I saw "Failed to load kext" and it said something about library dependencies. I tried reinstalling the right audio driver kext through Unibeast and the same result. Skipping audio and then it disappears. If I play a video through Quicktime it freezes at random times and then keeps playing and the audio drops off. VLC will actually play the video smoothly but looses the audio after about 5-6 secs.

I ran some tests booting from Unibeast and monitoring HWmonitor, my card speeds up to it's clock state and performs really well in Unigine and in LuxMark. I get a consistent score of 831.

Sadly, I'm not any close to figuring this out. Anyone have more ideas, even bios settings to check?
So I've continued to try a couple of different things that might be nit picky but I'm running out of options. I did a normal boot to hard drive and and noticed that it shows the CPU incorrectly in the HW monitor. This is with the windows and computer in general being slow.


And when booted form the Unibeast drive:


The CPU clocks down right and goes up when needed and the same with the GPU when booted from Unibeast.:crazy:

I tried reinstalling the ALC892 driver from different versions of mulitbeast for Mavericks and fixing permissions each time and audio still behaves the same way. Although I think that this is linked to the graphics problem still. So, efforts here might be fruitless until that is fixed and then I can judge what happens. Unfortunately I don't really know what else to try and fix. The OS has been installed at least 3 times following almost the exact same guidance from at least 3 different X79-UP4 builds.

I've queried kextstat from terminal and I see a number of NVIDIA kexts that loaded including the CUDA one. What baffles me is all the render tests run fine: LuxMark, Unigine, etc and score correctly according to the card capes but I still can't play a video or audio file.:banghead:


I followed this guide:

when setting up my GTX 770 4GB along side a 3930k. Not sure if it's any help to you and your issues, as you're using the 4930k.

What were your BIOS settings and could you watch video files?

Ok a little better progress. I double checked my BIOS settings and saw that my hard drive was set to boot as a UEFI type boot. Fixed that and I booted up really fast and with no lag in animation or running anything. Unfortunately it didn't fix the audio or video problem. But hey it's better.:p

Ok a little better progress. I double checked my BIOS settings and saw that my hard drive was set to boot as a UEFI type boot. Fixed that and I booted up really fast and with no lag in animation or running anything. Unfortunately it didn't fix the audio or video problem. But hey it's better.:p


Have you tried changing system definitions? i.e 5,1 etc. This sometimes fixes video issues.
You could try installing Chameleon 2.2
You could try installing Chameleon 2.2

Do you think installing another bootloader might fix the video issue? I know I'm not as familiar with Chameleon so could you explain why that might work? I would still be going off the same kexts to load the system, right?
So, I've changed the system definition and that didn't have any effect. Although I did have to change my drivers back to NVIDIA or OS X drivers in order for the GPU temps and freqs could be recognized. But it's the wrong display for the mac type:?: I'm not sure that's a big deal right now. But it didn't have any effect on the video problem.


I know that you've had luck getting the 770 up, which brand do you have? I've also been following your discussion about trying to get the 280X working with your setup, have you had any luck on that so far? There should be one of the brands that work with this board. I have been considering moving to an AMD card for better CL performance in FCP, but after following your thread I'm not sure there is a 280X that would work and/or fix this video issue. Do you think you could post your BIOS settings?

I have the Gigabyte 770 4GB. Works perfect with FCPX, but it would be nice to have the 280x working. I've done everything to try and get it working with FCPX, but it's crashing on certain tasks, which makes it unusable. I still don't know if its an issue with the XFX brand of card or the X79/280x combination problem.
i can't seem to find anyone who is using this Gigabyte/280x combo and has got it working, which is crazy when you think about all the video editors out there who want the best GPU's for their Hackistoshes.

My motherboard bios is set at defaults.
Not open for further replies.