Contribute
Register

[FIX] Coffee Lake Intel UHD Graphics 630 on macOS Mojave: Kernel panic due to divide-by-zero

Joined
Sep 27, 2016
Messages
82
Motherboard
Dell Inspiron 7559-Clover
CPU
i7-6700HQ
Graphics
HD530, 960M, 3840x2160
Mac
iMac, MacBook Pro, Mac Pro
Mobile Phone
Android
Ive been looking into this fix and I'm hoping that it may help with laptop I've been trying to get rolling for awhile now. This one uses a 8550u with the UHD 620, And for the life of me I've never been able to get QE/CI working on it. Im seeing in my panic logs the "0=divide error". Im using Lilu and whatevergreen method, with platformID 59160000 and device ID 5916. And It always locks at the same place in verbose. "IOScreenLockState" If I remove the device ID in Clover/Devices/Properties I can boot but with no acceleration. Device ID show 5917 in system Profiler. Any help would be greatly appreciated. Debug attached
 

Attachments

Joined
Nov 5, 2018
Messages
6
Motherboard
Dell XPS 9570
CPU
i5-8300H
Graphics
UHD 630, 1920x1080
Finally got rid of the divide by zero panic on my XPS 9570 1080p by using this custom patch
Code:
Info: ALT: Set the maximum link rate in DPCD buffer to 0x0A (HBR) for laptops with 1080p or below display (by FireWolf)
Name: AppleIntelCFLGraphicsFramebuffer
Find: 4883C304 4883FB08 72D0
Repl: 807DC100 7504C645 C10A
@Austere.J please add this patch to the original post too (right now only the alternative 4k patch is listed)
This patch already exists!
And this patch is also available for xps 9570 i5-8300h 1080p

Code:
<key>KextsToPatch</key>
<array>
    <dict>
        <key>Comment</key>
        <string>Set the maximum link rate in DPCD buffer to 0x0A (HBR) for laptops with 1080p or below display (by FireWolf)</string>
        <key>Disabled</key>
        <false/>
        <key>Find</key>
        <data>
        6AAAAABIg8MESIP7CHLQ
        </data>
        <key>InfoPlistPatch</key>
        <false/>
        <key>Name</key>
        <string>AppleIntelCFLGraphicsFramebuffer</string>
        <key>Replace</key>
        <data>
        QYO8JNwBAAAAdQTGRcEK
        </data>
    </dict>
</array>
 
Last edited:

trs96

Moderator
Joined
Jul 31, 2012
Messages
14,389
Motherboard
GA-Z97X-UD3H-BK
CPU
i5-4690K
Graphics
HD4600 / RX 570
Mac
iMac, Mac mini
Mobile Phone
Android
[QUOTE =“userpakal,post:1888762,member:1702256”]终于通过使用这个自定义补丁摆脱了我的XPS 9570 1080p上的零恐慌
[码]
信息:ALT:将显示1080p或以下的笔记本电脑的DPCD缓冲区中的最大链接速率设置为0x0A(HBR)(由FireWolf提供)
名称:AppleIntelCFLGraphicsFramebuffer
发现:4883C304 4883FB08 72D0
Repl:807DC100 7504C645 C10A
[/码]
[USER = 1307694] @ Austere.J [/ USER]请将此补丁添加到原始帖子中(现在只列出替代的4k补丁)[/ QUOTE]

这个补丁已经存在!
此补丁也适用于xps 9570 i5-8300h 1080p。
只需要这些(Plist):

Code:
 <dict>
        <键>注释</键>
        <string>将显示1080p或以下的笔记本电脑的DPCD缓冲区中的最大链接速率设置为0x0A(HBR)(由FireWolf提供)</ string>
        <键>禁用</键>
        <假/>
        <键>查找</键>
        <数据>
        6AAAAABIg8MESIP7CHLQ
        </数据>
        <键> InfoPlistPatch </键>
        <假/>
        <键>名称</键>
        <字符串> AppleIntelCFLGraphicsFramebuffer </字符串>
        <键>替换</键>
        <数据>
        QYO8JNwBAAAAdQTGRcEK
        </数据>
    </字典> [/ CODE]
Please post in English only. Thank you.
 
Joined
Nov 5, 2018
Messages
6
Motherboard
Dell XPS 9570
CPU
i5-8300H
Graphics
UHD 630, 1920x1080
need to do:
Code:
sudo kextcache -i /
reboot
 
Last edited:
Joined
Nov 5, 2018
Messages
6
Motherboard
Dell XPS 9570
CPU
i5-8300H
Graphics
UHD 630, 1920x1080
Please post in English only. Thank you.
Sorry about that.
Would you help me to delete #33 QUOTE that not in English and useless.
I should got to abide by the Rules .
Thanks a lot.
 
Last edited:

Feartech

Moderator
Joined
Aug 3, 2013
Messages
12,850
Motherboard
Asus N752VX-Clover
CPU
i7-6700HQ / HM170
Graphics
HD530 + GTX 950m 1920 x 1080
Mac
iMac
Mobile Phone
iOS
Joined
Aug 30, 2015
Messages
96
Motherboard
MSI B85m Gaming
CPU
i3-4170
Graphics
GTX 970
Mac
iMac, MacBook Pro
Classic Mac
iMac
Mobile Phone
iOS
Hi guys, I am running into a problem where spoofing to UHD 630 is the only way to get my display to be accelerated and lit up.

full story here: https://www.tonymacx86.com/threads/black-screen-on-login.264213/page-3

TLDR, when booting with HD 620 device settings, internal screen doesn't light up, but external display works. But when spoofing UHD 630, internal and external displays work but brightness and sleep doesn't. PR files are in the link, post #23.

Thanks!

P.S. @slipanot I have same issues as you. lets figure this out.
 
Last edited:
Joined
Sep 27, 2016
Messages
82
Motherboard
Dell Inspiron 7559-Clover
CPU
i7-6700HQ
Graphics
HD530, 960M, 3840x2160
Mac
iMac, MacBook Pro, Mac Pro
Mobile Phone
Android
Hi guys, I am running into a problem where spoofing to UHD 630 is the only way to get my display to be accelerated and lit up.

full story here: https://www.tonymacx86.com/threads/black-screen-on-login.264213/page-3

TLDR, when booting with HD 620 device settings, internal screen doesn't light up, but external display works. But when spoofing UHD 630, internal and external displays work but brightness and sleep doesn't. PR files are in the link, post #23.

Thanks!

P.S. @slipanot I have same issues as you. lets figure this out.
I've yet to try spoofing uhd620 to 630. But tonight I will give it a shot. I've fought this laptop for some time and just gave up. Looks like there may be some light at this tunnel :)
 
Joined
Aug 30, 2015
Messages
96
Motherboard
MSI B85m Gaming
CPU
i3-4170
Graphics
GTX 970
Mac
iMac, MacBook Pro
Classic Mac
iMac
Mobile Phone
iOS
This patch works for me, but the ALT patch also works. What is different about your patch? How does it work?
It seems like the patch I’m using is similar to the alt patch that @Austere.J has. It is in the same line when you open the cflFramebuffer in hexfiend. I would imagine that they do similar functions but when I use the actual alt patch it’s no good, nor the the real patch. Right now I want to figure out what te patch does by translating it to readable code, but haven’t had any luck.
 
Top