Contribute
Register

felbo's Build: Gigabyte Z690 Gaming X DDR4 - i7 12700K - AMD RX 580

Joined
Feb 18, 2022
Messages
34
Motherboard
Gigabyte Z690 Gaming X DDR4
CPU
i7-12700K
Graphics
RX 580
Mac
  1. Mac Pro
Mobile Phone
  1. iOS
felbo's Build:
Gigabyte Z690 Gaming X DDR4 - i7-12700K - AMD RX 580



IMG_3546 2.jpeg
Components

Gigabyte Z690 Gaming X DDR 4
https://www.amazon.com/dp/B09J5TC4F8

Intel i7-12700K Processor
https://www.amazon.com/dp/B09FXNVDBJ

Noctua NM-i17xx-MP83 chromax.Black, Mounting Kit CPU Coolers on Intel's LGA1700 Platform (Black)
https://www.amazon.com/dp/B09FSV5H72


Already Owned

Sapphire Pulse RX 580
https://www.amazon.com/dp/B07RVCM8K7

EVGA 850 GQ, 80+ GOLD 850W, Se Power Supply (210-GQ-0850-V1)
https://www.amazon.com/dp/B017HA3SO0

Noctua NH-D15S CPU cooler
https://www.amazon.com/dp/B00XUVGLEU

Crucial 2666MHZ DDR4 (4x16GB) Memory
https://www.newegg.com/p/N82E16820164182

NVME WD Black SN750 500GB NVMe M.2 SSD
https://www.amazon.com/dp/B07RQ9K8HH

Fenvi T919 PCI-E WiFi Adapter Continuity Handoff BCM94360CD WiFi Card
https://www.amazon.com/dp/B07VCCZS54

Very old simple Fractal Design ATX Case



Comments

Thanks to the guys in the most exiting thread I have read for long time.

Most components are from my previous build, a Coffee Lake with 64 GB DDR4 RAM
For the new build I bought only new motherboard, CPU and new mounting kit for the old Noctua cooler
Sorry for my English, it`s not my first language.

Installation

BIOS
last BIOS F7
load optimized defaults

Gigabyte made it simple:
Internal Graphic - disable
Apple VTD - enable
Above 4G Decoding - enable

Cannot find serial port option
No meaning using XMP1 here since RAM is 2666MHz

Hyperthreading-enable
CPU Cores Enabling Mode - Selectable mode
Enable all P and E cores

I didn't use Thunderbolt stuff, perhaps later.

IMG_3544.jpeg



Summary

My previous Coffee Lake 8700K & Z370 have been stable for 2 years. I´m using my build for Photography, and Lightroom/Photoshop runs without any hitch.

I think upgrading to Comet Lake would had been too little value for money, but Alder Lake is a big performence step up.
I have used this build for 2 months now, and I can only say its fantastic.

Three (small) problems:
1) these red USB ports, specially the left one, gave kernel panic. I tried several ways of mapping at vain. Perhaps somebody else with same board can help me out? In the end I didn't map them at all. I have 14 port total, all other HS SS ports works (exept red port). (there is enough USB ports anyway.)
2) needed two keyboard presses waking from sleep, one for waking computer and one for waking display. The solution was making SSDT-USBW.aml, methode 2 from here. After it`s working fine with just one keyboard press.
3) Sleep deos not work if Bluetooth device (my hearing aid) is connected. I have to turn off Bluetooth before sleep. Its no problem with Bluetooth mouse pairing, but with Bluetooth hearing aid which I use, it doesn't work. Tried everything. Was the same with previous build also, so I assume its the hearing aid Bluetooth chip which gives the issues. I'm not using Bluetooth mouse now, but Logitech G603 with small USB-thingy plugged into USB keyboard.


Screenshot 2022-03-02 at 16.22.12.png



Screenshot 2022-03-02 at 16.53.58.png

USB

Here are ports as ioreg sees it. USBToolbox in Windows found 25 ports. If using XHCIport limit patch + USBinjectall.kext 7.7 we also probably find 25 ports. Hackintool will see 19 active ports after populate all ports with usb2 + 3 devices. In Hackintool remove ports to 15 port limit and finally export. Use UIAC or KEXT as you want (not both at same time). UIAC need USBinjectall.kext 7.7, KEXT needs nothing. XHCIport limit off in both
1000_2.jpg




skjermdump.jpg
 

Attachments

  • EFI.zip
    7.1 MB · Views: 462
  • EFI-080.zip
    7.2 MB · Views: 427
  • EFI-084.zip
    6.1 MB · Views: 186
Last edited:

FLP

Joined
Mar 18, 2011
Messages
127
Motherboard
Gigabyte Z690 Gaming X
CPU
i7-12700K
Graphics
RX 570
Mobile Phone
  1. Android
  2. iOS
Thanks for the EFI! After filling out serial #.. it testing it on my new system, Z90 Gaming X with Rx570 video. So far it works great. I could not find the Apple VTD - enable setting in the bios. Where is it? I seems to work just fine without changing that setting. I will try to see if I can get the red USB port working.

My Geekbench scores were 1812 single-core and 13245 Multi-core.

Frank
 

FLP

Joined
Mar 18, 2011
Messages
127
Motherboard
Gigabyte Z690 Gaming X
CPU
i7-12700K
Graphics
RX 570
Mobile Phone
  1. Android
  2. iOS
I can't get any Apple Arcade games to play. Trying to start them, the icon bounces a few times and then nothing. I thought it might have something to do with DRM. Anyone know what the issue might be?

Frank
 
Joined
Feb 18, 2022
Messages
34
Motherboard
Gigabyte Z690 Gaming X DDR4
CPU
i7-12700K
Graphics
RX 580
Mac
  1. Mac Pro
Mobile Phone
  1. iOS
Thanks for the EFI! After filling out serial #.. it testing it on my new system, Z90 Gaming X with Rx570 video. So far it works great. I could not find the Apple VTD - enable setting in the bios. Where is it? I seems to work just fine without changing that setting. I will try to see if I can get the red USB port working.

My Geekbench scores were 1812 single-core and 13245 Multi-core.

Frank
220303065359.jpg
 

FLP

Joined
Mar 18, 2011
Messages
127
Motherboard
Gigabyte Z690 Gaming X
CPU
i7-12700K
Graphics
RX 570
Mobile Phone
  1. Android
  2. iOS
Thanks. I am planning to look into the USB port problem you identified.
 
Joined
Feb 18, 2022
Messages
34
Motherboard
Gigabyte Z690 Gaming X DDR4
CPU
i7-12700K
Graphics
RX 580
Mac
  1. Mac Pro
Mobile Phone
  1. iOS
Thanks. I am planning to look into the USB port problem you identified.
I tried new mapping yesterday. The red port works, but if I use AJA or BlackMagic speedtest on Sandisk USB card reader plugged in, i get problem, screen flashing and have to restart. Not on the other port, C port works well also. Strange.
 

FLP

Joined
Mar 18, 2011
Messages
127
Motherboard
Gigabyte Z690 Gaming X
CPU
i7-12700K
Graphics
RX 570
Mobile Phone
  1. Android
  2. iOS
I tried mapping the USB ports, but for whatever reasons, most of the the USB 2 ports and combined USB and 3 ports do not work at USB 2 speeds. I just updated the Bios to version 7. Maybe 6 had an issue. When I would boot on Bios version 6, if I had my logitech keyboard and mouse dongle plugged into a usb 2 port it would not be detected by the bios or windows! After the update to 7 the dongle seems to work in a usb port. Maybe I'll give mapping another try.
 

NorthAmTransAm

Moderator
Joined
Jul 26, 2018
Messages
1,773
Motherboard
MSI Pro Z690-A DDR4
CPU
i7-12700k
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. iOS
A wealth of information for you over here. The builds are similar enough.

 
Joined
Feb 18, 2022
Messages
34
Motherboard
Gigabyte Z690 Gaming X DDR4
CPU
i7-12700K
Graphics
RX 580
Mac
  1. Mac Pro
Mobile Phone
  1. iOS
I tried mapping the USB ports, but for whatever reasons, most of the the USB 2 ports and combined USB and 3 ports do not work at USB 2 speeds. I just updated the Bios to version 7. Maybe 6 had an issue. When I would boot on Bios version 6, if I had my logitech keyboard and mouse dongle plugged into a usb 2 port it would not be detected by the bios or windows! After the update to 7 the dongle seems to work in a usb port. Maybe I'll give mapping another try.
please see USB stuff above in my thread, posted new mapping info
 
Joined
Feb 18, 2022
Messages
34
Motherboard
Gigabyte Z690 Gaming X DDR4
CPU
i7-12700K
Graphics
RX 580
Mac
  1. Mac Pro
Mobile Phone
  1. iOS
Thanks. I am planning to look into the USB port problem you identified.
Thanks for the EFI! After filling out serial #.. it testing it on my new system, Z90 Gaming X with Rx570 video. So far it works great. I could not find the Apple VTD - enable setting in the bios. Where is it? I seems to work just fine without changing that setting. I will try to see if I can get the red USB port working.

My Geekbench scores were 1812 single-core and 13245 Multi-core.

Frank
VT-D = Thunderbolt stuff
 
Top