Contribute
Register

End RandomSeed shows up during every boot

Status
Not open for further replies.
Joined
Apr 20, 2017
Messages
11
Motherboard
Dell 0KRC95
CPU
i5-3550 3.3GHz
Graphics
MSI RX 560
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
I've stuck. Whenever I try to boot anything related to MacOS. I see "End RandomSeed". I see this when I try to boot off a USB installer, the internal Fusion Drive, the Recovery Partition and external HD's with MacOS Mojave on them. Everything results in End RandomSeed. I've tried downloading the Clover EFI bootloader and selecting all the AptioMemoryFix (I probably didn't type that right). I also have a Windows 10 drive in my hackintosh and that boots up just fine. My dad is the IT Director for our city, I told him that with researching, it's a memory issue, so he told me to take an unused #2 pencil with an eraser and erase the gold pins on the Ram, then I wiped off the excess eraser bits with my shirt. I put it back in, booted it up and still the same issue. I've also tried taking the USB Installer, putting it in my iMac, opening up clover configurator, mounting the efi, and adding my Ram specs in the SMBIOS. I've spent all day and 4 hours last night trying anything I could imagine to fix it, I've even installed Mojave on an external HD, and tried booting from it, but it didn't work (It worked on the iMac though). Is there something I haven't tried that would fix it?
 
A verbal description usually isn't good enough, and, meaning no offense, you don't know enough about the boot process to quote one line and expect that to be the relevant one. Please:
  1. Ensure you have all the recommended BIOS settings in place
  2. Zip up the EFI folder on the drive you're attempting to boot from, and post the ZIP
  3. Boot in verbose mode from that drive (so, using that EFI folder), take a photo of where it stops, and post that as well
  4. Update your profile with the SPECIFIC CPU model in your machine. If you can figure it out, it would also help to know the brand of your video card, as some are known to be harder to get working than others.
Finally, it's somewhat implausible that Windows works fine yet there's a hardware defect such as bad memory. You may have hardware incompatible with Mojave, but more likely that you just haven't hit on the correct configuration settings yet.
 
I have a dell optiplex 7010 motherboard, so I googled recommended settings for a dell motherboard for Hackintosh. I don't know the exact model CPU I have because I actually got this computer for $100 at my local university's surplus store. But after changing the bios settings the system now boots to recovery (it didn't before, yay!) The graphics card I have is the MSI Radeon RX 560, so I shouldn't have to include the info for it in clover.
 

Attachments

  • EFI Mojave.zip
    4.3 MB · Views: 54
  • IMG_4433.jpg
    IMG_4433.jpg
    1.7 MB · Views: 75
OK, your latest screenshot shows the well-known "Still waiting for root device" problem. This happens when macOS tries to read your install drive and can't. Normally that means you're using a USB3 device, and your boot drive isn't set up to support USB3 on your board (commonly only USB2 is supported without customizing things). So you can either work out how to configured your flash drive to enable USB3, or just use a USB2 flash drive. Of the two, using a USB2 drive is typically much easier.
 
Status
Not open for further replies.
Back
Top