Contribute
Register

El Capitan and Asus P5W DH no sound via HDMI (Nvidia GT 740)

Status
Not open for further replies.
Joined
Jan 26, 2016
Messages
127
Motherboard
ASUS P5WDH
CPU
Q9650/QX6800
Graphics
Nvidia GT 740 SC/4GB DDR5
Mac
Classic Mac
Mobile Phone
  1. Android
SOLVED: El Capitan and Asus P5W DH no sound to HDMI (GT 740)

I did a vanilla install of El Capitan, and overall the system works very well. I have a 4K Samsung and have connected the Nvidia GT 740 HDMI out to the TV. Picture is great and adjustable. This board uses ALC882M High Definition, and Multibeast has no specific drivers for that item.

I can get sound in (mic) and out via a USB Plantronics headset without any need for additional drivers. It works OOB.

I've read quite a few how to solve sound for this motherboard, but all largely on Mavericks, from editing DSDT's, to Voodoo drivers, changing the Apple kexts out, installing other kexts, but not of these years old ideas appear to fit for El Capitan.

My skills/knowledge base is still very basic, and I do not want to screwup my setup and have to reinstall the OS. On the Windows side, HDMI should works perfectly.

Is there a P5W user who has the solution for El Capitan and the sound?

Thank you.
 
Last edited:
Joined
Jan 26, 2016
Messages
127
Motherboard
ASUS P5WDH
CPU
Q9650/QX6800
Graphics
Nvidia GT 740 SC/4GB DDR5
Mac
Classic Mac
Mobile Phone
  1. Android
Joined
Oct 8, 2010
Messages
570
Motherboard
Z77E-ITX
CPU
Intel® Core™ i7-3770
Graphics
GTX650Ti
Mac
  1. iMac
Classic Mac
Mobile Phone
  1. iOS
There are many way to achieve HDMI, I prefer to use a DSDT injection.
To extract it hit F4 some times at the clover boot screen, wait some seconds before booting, you see nothing happen, but now you find your clean DSDT in EFI/CLOVER/ACPI/origin.
In the meantime try this config
 

Attachments

  • config.plist 2.zip
    2.1 KB · Views: 36
Joined
Jan 26, 2016
Messages
127
Motherboard
ASUS P5WDH
CPU
Q9650/QX6800
Graphics
Nvidia GT 740 SC/4GB DDR5
Mac
Classic Mac
Mobile Phone
  1. Android
Thank you, I will give it a go!
 
Joined
Jan 26, 2016
Messages
127
Motherboard
ASUS P5WDH
CPU
Q9650/QX6800
Graphics
Nvidia GT 740 SC/4GB DDR5
Mac
Classic Mac
Mobile Phone
  1. Android
Flicka,

Update. I put your config.plist into the EFI/Clover directory and rebooted.

I'm not able to tell any difference with any sound settings, etc. I can still see the USB Plantronics, and it will unplug if I remove the USB dongle, but no new sound options and no sound over HDMI to the TV.

I created a DTST.aml file in the Windows side of my computer, and copied that to the Mackintosh side, and ran MACiASl, then compiled. There are quite a number of errors/warnings, so I did not use it.

I took a DTST.aml file from a P5W running Mavericks from years ago, another user's, ran a compile and it had one error, so I put that into Clover/ACPI/Origin, and that made no difference.

I made a directory EFI/EXTRA and put the 'Mavericks" DSDT.aml file in there, and after boot checked Preferences/Sound and no sound hardware shows. The USB Plantronics still works fine.

Back to being stumped.

**********

update:

Used Clover to install Voodoo 2.7.3 drivers. Upon boot there were 3 Digital HDMI output sources. No input sources. One of the HDMI outputs works!

Great.

Flickr, thank you for your time here. I appreciate it.
 
Status
Not open for further replies.
Top