Contribute
Register

El Cap App Store Failing to Login

Status
Not open for further replies.
Joined
Jan 25, 2012
Messages
20
Motherboard
Z390 Designare
CPU
9900K
Graphics
RTX 2080 Ti + Vega 64
Mac
  1. iMac
  2. MacBook Pro
Hey all,

I just updated to El Cap, but for some reason everything except the App Store works. iTunes works, iCloud works, iMessage works, Facetime... etc, but anytime I login to the App Store I get an error message like:

An unexpected error occurred while signing in. AMD-Action:authenticate?guid=<some random string>:SP

I've got ethernet working fine on en0, and a proper airport card on en1. It used to work perfectly, just only stopped working today. Tried trashing all the network interfaces and re-creating them but nothing happened. En0 reports built-in, so it's fine, and I'm currently booting with Clover.

Anyone experience similar and/or figure out a fix?
 
Joined
Oct 1, 2015
Messages
1
Mac
Classic Mac
Mobile Phone
I'm seeing the same problem :banghead:

A few additional data points:
- I have been running El Cap since as soon as the beta was available and this only started last week for no apparent reason
- I am on a Mac Mini so this is not an x86-specific problem

I have contact Apple support and they have been useless so far... will keep trying and report what I find back... In the mean time, I'm also eager for suggestions.

Since this is App Store specific, I have tried zapping the preference plist but that did not help.
 
Joined
May 28, 2011
Messages
17
Motherboard
Gigabyte Z87x-UD3H
CPU
i7-4770k
Graphics
GTX 650TI Boost
Mac
Classic Mac
Mobile Phone
Never mind. Figured out what the problem was for me: my ethernet was not listed as en0 (it was showing as en1)

Steps to fix for my issue
1. delete all interfaces in the Network Pane of the Control Panel
2. delete Networkinterfaces.plist from /Library/preferences/systemconfiguration
3. restart
4. add Ethernet interface in the Network control panel pane

now my ethernet is registered as en0. App store is working. iCloud seems to be connecting. iMessage is logging in .. but not really working (i see activity, but messages won't actually receive or send...)
 
Joined
Dec 1, 2015
Messages
23
Motherboard
GA-Z170X-UD5 TH
CPU
i7-6700K
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
Classic Mac
  1. SE
Mobile Phone
  1. iOS
Joined
Dec 2, 2013
Messages
7
Mac
Classic Mac
Mobile Phone
I know that this is an old thread, but I wanted to share what worked for me since none of the solutions above fixed the error message at start-up for me.

I have a SSD+regular Hard Drive setup, and my /Users directory is located on my large HDD (because that's where the available space is, right?). The essential System OS X files are kept on the SSD for speed/performance.

The problem is - you need to have the /Users/Shared folder located on the same drive as the OS X files for some reason. You cannot relocate them to another drive (along with the other /User subdirectories) using symlinks like I was doing.

Disclaimer: I don't know if this will work for everyone. Use at your own risk, because I am not suggesting that you use this. I am not responsible for any typos or errors because your setup might be different than my setup.

Strategy:

- Back up your files! Back up your files!

- WHILE LOGGED IN AS ANOTHER ADMIN USER (important), remove the /Users symlink on the SSD that points to the REAL /Users folder on your HDD

- Create a new /Users folder on your SSD (System OS X drive)

- Cut/Paste the old /Users/Shared folder to the SSD /Users folder

- RECREATE a symlink on the SSD /Users folder to point/redirect to all of the user accounts still on the HDD (including your's)

- Reboot and Test

Steps - This is what worked for me:

0. BACK UP ALL OF YOUR FILES and DIRECTORIES. Do not skip this step.

1. Create another Admin-level user (do not use your regular account). Set the Admin level for this new account in System Preferences/Users and Groups

2. Log in as this new Admin user

3. Look on the new SSD if you have a symlink (this is like a shortcut or detour sign that redirects you to the real location. Google it) for the /Users folder. Is it a symlink? Then proceed.

Important Note: If you do not have a symlink or know what that is, DO NOT PROCEED. This solution does not apply to you.

4. Delete the symlink - DO NOT DELETE ANY REAL /Users FOLDERS. (I really hope you backed up your entire system)

5. Create a /Users folder on your SSD drive in Terminal using:

mkdir /Volumes/<enter your SSD drive name>/Users

6. Move the HDD version of /Users/Shared to the SSD volume's /User folder:

mv -Rv /Volumes/<HDD drive name>/Users/Shared /Volumes/<SSD drive name>/Users

7. Very Important - Recreate a symlink for all of your users (especially you) to point to the older location by:

ln -s /Volumes/<HDD drive>/Users/<username> /Volumes/<SSD drive>/Users

Command Line Tip: Use Double-Quotes to surround the sections that may have a space in the name (e.g. use ln -s "/Volumes/My Drive/Users" )

8. Since you didn't touch the original /Users folder directories and they're still located on the /Volumes/<HDD drive>/Users/ folder, you shouldn't have to worry about ownership and permissions.

9. Reboot and see if the AMD:Action:Authenticate:SP error still appears. It was fixed for me after this.


I hope this works for anyone who might be having the error and can't find a solution. Good luck!
 
Joined
Nov 3, 2011
Messages
2
Motherboard
GA-170N-Wifi
CPU
i5-6600k
Graphics
GTX 760
Mac
  1. iMac
Mobile Phone
  1. Android
  2. iOS
Moving the Shared folder back to my main hard drive worked for me. I also changed the ethernet back to en0, since for some reason it went to en2, so both steps may be needed.

I had a lot of data on my Shared drive, so I moved it away to do the test. I may need to add symlinks to anything that was under the Shared folder, inconvenient, but a simple script will do.
 
Joined
Feb 2, 2012
Messages
10
Motherboard
GA-H55M-UD2H
CPU
Intel Core i7-860 @ 2.93 GHz
Graphics
NVidia GeForce GTS 250 1024 MB
Mac
  1. MacBook Air
  2. Mac Pro
Classic Mac
  1. iBook
Mobile Phone
  1. iOS
...my ethernet was not listed as en0 (it was showing as en1)

Steps to fix for my issue
1. delete all interfaces in the Network Pane of the Control Panel
2. delete Networkinterfaces.plist from /Library/preferences/systemconfiguration
3. restart
4. add Ethernet interface in the Network control panel pane

now [..] ethernet is registered as en0. App store is working...

Many thanks... this was helpful in my instance as well!
 
Status
Not open for further replies.
Top