Contribute
Register

<< Solved >> Catalina 10.15 - Working TP-Link WN722N v2.1

Joined
Aug 19, 2019
Messages
3
Motherboard
H81M-D
CPU
i7-4770
Graphics
Radeon RX580
Hi All,

Not sure if useful but I managed to get the TP-Link WN722N v2.1 Working (As the official installer doesn't work) in Catalina 10.15 (v5)

I've extracted the kext files from the original installer TP-Link_Installer_Mac 10.14_beta using Pacifist

Copied the kexts from the "Deployment109110x64" Folder to /Library/Extensions/ using terminal (sudo cp -rf *.kext /Library/Extensions) and rebuild the kext cache (kextcache -I /)

Then installed the Wireless USB adapter Clover V7 Tool and rebooted.
 

Attachments

  • RtWlanDisk.kext.zip
    18.2 KB · Views: 2,021
  • RtWlanU.kext.zip
    3.6 MB · Views: 2,976
  • RtWlanU1827.kext.zip
    1.4 MB · Views: 2,693
  • Wireless.USB.Adapter.Clover-V7.zip
    6.7 MB · Views: 2,770
Joined
Sep 4, 2019
Messages
2
Motherboard
Hewlett Packet 18FE
CPU
Intel Core i5 3317U
Graphics
Intel 4000HD
Is it posible to make kexts for TP-Link WN722N v1?
 
Joined
Jun 6, 2019
Messages
2
Motherboard
Asus Prime Z390-A
CPU
3.6 GHz 8-Core Intel Core I7 (9700k)
Graphics
vega 56
Mac
  1. Mac Pro
Mobile Phone
  1. iOS
This worked perfectly for my wusb6300 after months of not finding a solution. Thank you!
 
Last edited:
Joined
Oct 2, 2013
Messages
50
Motherboard
Gigabyte z490 ua
CPU
Intel Core i7 10700K
Graphics
Amd Radeon 590
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
works for me too!!
what I did was...

first download and copy kexts, then rebuild cache
then install clover USB tool
then reboot

thank you very much
 
Joined
Jan 16, 2013
Messages
23
Motherboard
HP 8770w QM77 Motherboard
CPU
i7-3840q
Graphics
K5100m
Mobile Phone
  1. Android
with the dropping of atheros support in caralina this was the only thing that worked for me getting wireless support.thanks so much.
 
Joined
May 21, 2020
Messages
1
Motherboard
intel
CPU
intel i3
Graphics
Radeon 6670
works for me too!!
what I did was...

first download and copy kexts, then rebuild cache
then install clover USB tool
then reboot

thank you very much
Me too!!! Thank you very much!
 
Joined
May 2, 2021
Messages
1
Motherboard
motherboard OR system make and model # > See Rules!
CPU
i7 > Need full model # > See Rules!
Graphics
GTX 1050 Ti
Dell xps 15 9570 here with Big Sur. Im really new here.
I have copied the kexts to /Library/Extensions, run the kext cache rebuild and tried to run the pkg, but it says Installation Failed. It does not describe why.
Could you please help me?
 
Top