Contribute
Register

Catalina 10.15.2 + Sapphire 5700 Xt Still With A Blank Screen

Joined
Jan 21, 2020
Messages
8
Motherboard
GA-Z370N-Wifi
CPU
i5-8600K
Graphics
RX 5700 XT
I've tried so many things and I'm still coming up empty. I'm hoping someone here can help. Please & thank you!

I'm running Catalina 10.15.2 (clean USB install but did not format drive) and everything boots up fine with the 5700 card installed except there's no display. I know this is somewhat common and I think I've tried all of the workarounds and various boot flags (radpg=15, shikigva=16, -wegoff). I can login to the computer and run commands so I know its not crashing or hanging. What else should I try?

Motherboard: Gigabyte Z370N Wifi
CPU: i5-8600k
Video card: Sapphire Radeon 5700 Xt

I can boot with the iGPU enabled and the 5700 physically removed. When I disable the iGPU, reinstall the 5700, the 5700 still has a blank display. I'm running WhateverGreen version 1.3.6 and Lilu version 1.4.1 booting with Clover version r5103. I can also dual boot into my older nVidia system running High Sierra by just swapping dGPU cards. Here is what I think are the relevant boot error messages:

Code:
AGDCC: Unauthorized client 'PerfPowerService' (IOService:/AppleACPIPlatformExpert/PCI0@0/AppleACPIPCI/PEG0@1/IOPP/PEGP@0/IOPP/pci-bridge@0/IOPP/GFX0@0/AMDRadeonX6000_AmdGpuWrangler)AGDCC: Unauthorized client 'PerfPowerService' (IOService:/AppleACPIPlatformExpert/PCI0@0/AppleACPIPCI/PEG0@1/IOPP/PEGP@0/IOPP/pci-bridge@0/IOPP/GFX0@0/AMDRadeonX6000_AmdAgdcServices)ALF, old data swfs_pid_entry <ptr>, updaterules_msg <ptr>, updaterules_state <ptr>ALF, hash_free: found kext_info <ptr> ALF, old data swfs_pid_entry <ptr>, updaterules_msg <ptr>, updaterules_state <ptr>ALF, hash_free: found kext_info <ptr> Sandbox: 1 duplicate report for com.apple.Ambien deny(1) mach-lookup com.apple.windowserverSandbox: distnoted(402) deny(1) file-read-metadata /usr/sbin/distnotedAMD Error: TODO:  To implement support for request power
AMD Error: TODO:  To implement support for request power
AMD Error: TODO:  To implement support for request power
I attached my EFI folder, a screenshot of the extra kexts I put in /L/E, and the full dmesg output.
 

Attachments

Joined
Jan 23, 2011
Messages
666
Motherboard
Acer SF314-52
CPU
i5-7200U
Graphics
HD 620
Mac
MacBook
Mobile Phone
iOS
add kext-dev-mode=1 to your boot flags
 
Joined
Jan 21, 2020
Messages
8
Motherboard
GA-Z370N-Wifi
CPU
i5-8600K
Graphics
RX 5700 XT
Thanks for the reply! I tried the kext-dev-mode=1 boot flag and didn't see any difference. I'll attach the bdmesg and dmesg boot logs in case they're helpful. I did take a closer look at some of the GPU related errors, and it appears to detect the card correctly, but is not able to finish the initialization: "Controller is NOT enabled so SKIP". Any other thoughts?

Code:
[3:0:0][GPUCAP] refresh() --- Family: 143, Device: 0x731f, revNo: 2, pciRevNo: c1, emuRevNo: 3.
[3:0:0][GPUCAP] refresh() --- Mem Size: FB: 8176 MB, Aper: 256 MB, Reg Aper: 512 KB.
[3:0:0][GPUCAP] refresh() --- Mem Config: Width: 256, Type: GDDR6.
[3:0:0][GPUCAP] refresh() --- FB Base: 0x8000000000, Top: 0x81ffffffff.
[3:0:0][GPUCAP] refresh() --- Branding - family: "Radeon RX"; device: "5700 XT"; model: "Radeon RX 5700 XT".
[3:0:0] [PPLIB] AppleMcilRegisterInterrupt() !!! SKELETON - irq:4278190124.
[3:0:0] [PPLIB] AppleMcilRegisterInterrupt() !!! SKELETON - irq:4278190125.
[3:0:0] [PPLIB] AppleMcilRegisterInterrupt() !!! SKELETON - irq:4278190158.
[3:0:0] [AGDC] AMDRadeonX6000_AmdAgdcServices::vendor_doDeviceAttribute() ??? Controller is NOT enabled so SKIP. cmd:[       3].
[3:0:0] [AGDC] AMDRadeonX6000_AmdAgdcServices::waitForAGDCReady() ??? AGDC failed to register with controller!
[3:0:0] [AGDC] AMDRadeonX6000_AmdAgdcServices::waitForAGDCReady() ??? AGDC failed to register with controller!
ALF, old data swfs_pid_entry <ptr>, updaterules_msg <ptr>, updaterules_state <ptr>ALF, hash_free: found kext_info <ptr>
[3:0:0] [AGDC] AMDRadeonX6000_AmdAgdcServices::waitForAGDCReady() ??? AGDC failed to register with controller!
[3:0:0] [AGDC] AMDRadeonX6000_AmdAgdcServices::waitForAGDCReady() ??? AGDC failed to register with controller!
[3:0:0] [FB:0] AmdRadeonFramebuffer::setCursorImage() !!! Driver is offline.
[3:0:0] [FB:1] AmdRadeonFramebuffer::setCursorImage() !!! Driver is offline.
[3:0:0] [FB:2] AmdRadeonFramebuffer::setCursorImage() !!! Driver is offline.
[3:0:0] [FB:3] AmdRadeonFramebuffer::setCursorImage() !!! Driver is offline.
ALF, old data swfs_pid_entry <ptr>, updaterules_msg <ptr>, updaterules_state <ptr>ALF, hash_free: found kext_info <ptr>
Sandbox: 1 duplicate report for com.apple.Ambien deny(1) mach-lookup com.apple.windowserverSandbox: distnoted(391) deny(1) file-read-metadata /usr/sbin/distnoted
AMD Error: TODO:  To implement support for request power
AMD Error: TODO:  To implement support for request power
AMD Error: TODO:  To implement support for request power
AGDCC: Unauthorized client 'PerfPowerService' (IOService:/AppleACPIPlatformExpert/PCI0@0/AppleACPIPCI/PEG0@1/IOPP/PEGP@0/IOPP/pci-bridge@0/IOPP/GFX0@0/AMDRadeonX6000_AmdGpuWrangler)
AGDCC: Unauthorized client 'PerfPowerService' (IOService:/AppleACPIPlatformExpert/PCI0@0/AppleACPIPCI/PEG0@1/IOPP/PEGP@0/IOPP/pci-bridge@0/IOPP/GFX0@0/AMDRadeonX6000_AmdAgdcServices)
ALF, old data swfs_pid_entry <ptr>, updaterules_msg <ptr>, updaterules_state <ptr>ALF, hash_free: found kext_info <ptr>
Sandbox: appleeventsd(384) deny(1) ipc-posix-shm-write-create com.apple.AppleDatabaseChanged
Sandbox: PAH_Extension(403) deny(1) file-write-data /System/Library/Caches/com.apple.IntlDataCache.le
Sandbox: 2 duplicate reports for PAH_Extension deny(1) file-write-data /System/Library/Caches/com.apple.IntlDataCache.le
Sandbox: PAH_Extension(403) allow mach-register com.apple.PressAndHold_Connection
Sandbox: bluetoothd(169) deny(1) mach-lookup com.apple.server.bluetooth
ALF, old data swfs_pid_entry <ptr>, updaterules_msg <ptr>, updaterules_state <ptr>ALF, hash_free: found kext_info <ptr>
GTrace synchronization point 9d
AMD Error: TODO:  To implement support for request power
 

Attachments

Joined
Jan 21, 2020
Messages
8
Motherboard
GA-Z370N-Wifi
CPU
i5-8600K
Graphics
RX 5700 XT
I tried several more things and I'm still in the same state. Everything boots up just fine, remote access is good, but nothing is displayed (i.e. black screen). I tried the three different AGDP WhateverGreen flags (i.e. vit9696, pikera, and ignore) with no luck. I'm really not sure what else to try and would love to hear any suggestions.

Motherboard: Gigabyte Z370N Wifi (BIOS version F10)
CPU: i5-8600k
Video card: PowerColor Red Dragon Radeon 5700 Xt

I made a few changes during my debugging process:
  • I swapped by video card to a PowerColor Red Dragon Radeon 5700 XT (thinking the Sapphire was the problem). That was apparently not the case.
  • I moved all of my kexts to the Clover/kexts/other directory. This was suggested elsewhere for Catalina and it feels more organized. I set Inject to Yes. This had no effect.
  • I'm still running WEG version 1.3.6, Lilu version 1.4.1, and Clover version 5103.
  • I can boot with the included config-iGPU.plist file using the iGPU. I can do this while the dGPU card is installed and powered on. I figured that was a good sign.
  • I upgraded to 10.15.3 with no problems but also no change with the display issue.
I've read that a few people have had luck with a reinstall. I've tried this a few times without success. And given the log messages I'm not sure this is the problem. If this is worth trying, could someone explain the details for this process?

Here's a snippet of the boot up log. I'll attach my full EFI partition as well as full boot logs. Any help is appreciated!

2020-01-30 08:16:05.540349-0600 0x71 Default 0x0 0 0 kernel: (AppleACPIPlatform) VFCT 0x00000000B944E578 00E884 (v01 ALASKA A M I 00000001 AMD 31504F47)
2020-01-30 08:16:05.540350-0600 0x71 Default 0x0 0 0 kernel: (AppleACPIPlatform) VFCT 0x00000000B944E578 00E884 (v01 ALASKA A M I 00000001 AMD 31504F47)
2020-01-30 08:16:21.966911-0600 0x647 Default 0x0 0 0 kernel: (AppleGFXHDA) [0x30001]AppleGFXHDAControler[0]::probe
2020-01-30 08:16:21.966929-0600 0x647 Default 0x0 0 0 kernel: (AppleGFXHDA) [0x30001]AppleGFXHDAController[0]::start
2020-01-30 08:16:22.004734-0600 0x664 Default 0x0 0 0 kernel: (AppleGFXHDA) Sound assertion in AppleGFXHDADriver at line 4838
2020-01-30 08:16:22.004738-0600 0x664 Default 0x0 0 0 kernel: (AppleGFXHDA) Sound assertion in AppleGFXHDAController at line 5073
2020-01-30 08:16:22.004763-0600 0x19c Default 0x0 0 0 kernel: (AppleGFXHDA) [0x30001]AppleGFXHDAController[0]::setPowerState from 0 to 2
2020-01-30 08:16:22.004875-0600 0x664 Default 0x0 0 0 kernel: (AppleGFXHDA) [0x30001]AppleGFXHDAControler[0]::handleOpen
2020-01-30 08:16:22.017254-0600 0x664 Default 0x0 0 0 kernel: (AppleGFXHDA) [0x30001]AppleGFXHDADriver[0]::start
2020-01-30 08:16:22.017475-0600 0x74 Default 0x0 0 0 kernel: PMRD: AppleGFXHDADriver tag flags 400
2020-01-30 08:16:22.036459-0600 0x643 Default 0x0 0 0 kernel: (AppleIntelCFLGraphicsFramebuffer) [IGFB][INFO ] [AGDC] Get GPU caps
2020-01-30 08:16:22.036709-0600 0x6b0 Default 0x0 0 0 kernel: (AppleIntelCFLGraphicsFramebuffer) [IGFB][INFO ] [AGDC] Get GPU caps
2020-01-30 08:16:22.036715-0600 0x6b0 Default 0x0 0 0 kernel: (AppleIntelCFLGraphicsFramebuffer) [IGFB][INFO ] [AGDC] Get GPU caps
2020-01-30 08:16:22.036716-0600 0x6b0 Default 0x0 0 0 kernel: (AppleIntelCFLGraphicsFramebuffer) [IGFB][INFO ] [AGDC] Get port caps
2020-01-30 08:16:22.223737-0600 0x68c Default 0x0 0 0 kernel: (AMDRadeonX6000Framebuffer) [3:0:0][ATOM][LIB] static AmdAsicInit *AmdAsicInit::createAsicInit(AmdAtomFwHelper *) --- tableIndex:0, V 2.1.
2020-01-30 08:16:22.223740-0600 0x68c Default 0x0 0 0 kernel: (AMDRadeonX6000Framebuffer) [3:0:0][ATOM][LIB] static AmdDisplayControllerInit *AmdDisplayControllerInit::createDisplayControllerInit(AmdAtomFwHelper *) --- tableIndex:0xd, V 2.1.
2020-01-30 08:16:22.223742-0600 0x68c Default 0x0 0 0 kernel: (AMDRadeonX6000Framebuffer) [3:0:0][ATOM][LIB] static AmdAtomFirmwareInfo *AmdAtomFirmwareInfo::createFirmwareInfo(AmdAtomFwHelper *, uint32_t) --- V 3.3.
2020-01-30 08:16:22.223743-0600 0x68c Default 0x0 0 0 kernel: (AMDRadeonX6000Framebuffer) [3:0:0][ATOM][LIB] static AmdAtomDcInfo *AmdAtomDcInfo::createDcInfo(AmdAtomFwHelper *, uint32_t) --- V 4.3.
2020-01-30 08:16:22.223745-0600 0x68c Default 0x0 0 0 kernel: (AMDRadeonX6000Framebuffer) [3:0:0][ATOM][LIB] static AmdAtomSmuInfo *AmdAtomSmuInfo::createSmuInfo(AmdAtomFwHelper *, uint32_t) --- V 3.4.
2020-01-30 08:16:22.223746-0600 0x68c Default 0x0 0 0 kernel: (AMDRadeonX6000Framebuffer) [3:0:0][ATOM][LIB] static AmdAtomVramInfo *AmdAtomVramInfo::createVramInfo(AmdAtomFwHelper *, uint32_t) --- V 2.4.
2020-01-30 08:16:22.223747-0600 0x68c Default 0x0 0 0 kernel: (AMDRadeonX6000Framebuffer) [3:0:0][ATOM][LIB] static AmdAtomObjectInfo *AmdAtomObjectInfo::createObjectInfo(AmdAtomFwHelper *, uint32_t) --- V 1.4.
2020-01-30 08:16:22.223749-0600 0x68c Default 0x0 0 0 kernel: (AMDRadeonX6000Framebuffer) [3:0:0][ATOM][LIB] static AmdAtomGpioPinLut *AmdAtomGpioPinLut::createGpioPinLutTable(AmdAtomFwHelper *, uint32_t) --- V 2.1.
2020-01-30 08:16:22.223762-0600 0x68c Default 0x0 0 0 kernel: (AMDRadeonX6000Framebuffer) [3:0:0][GPUCAP] refresh() --- Family: 143, Device: 0x731f, revNo: 2, pciRevNo: c1, emuRevNo: 3.
2020-01-30 08:16:22.223763-0600 0x68c Default 0x0 0 0 kernel: (AMDRadeonX6000Framebuffer) [3:0:0][GPUCAP] refresh() --- Mem Size: FB: 8176 MB, Aper: 256 MB, Reg Aper: 512 KB.
2020-01-30 08:16:22.223764-0600 0x68c Default 0x0 0 0 kernel: (AMDRadeonX6000Framebuffer) [3:0:0][GPUCAP] refresh() --- Mem Config: Width: 256, Type: GDDR6.
2020-01-30 08:16:22.223765-0600 0x68c Default 0x0 0 0 kernel: (AMDRadeonX6000Framebuffer) [3:0:0][GPUCAP] refresh() --- FB Base: 0x8000000000, Top: 0x81ffffffff.
2020-01-30 08:16:22.223767-0600 0x68c Default 0x0 0 0 kernel: (AMDRadeonX6000Framebuffer) [3:0:0][GPUCAP] refresh() --- Branding - family: "Radeon RX"; device: "5700 XT"; model: "Radeon RX 5700 XT".
2020-01-30 08:16:22.224458-0600 0x7bb Default 0x0 0 0 kernel: (AppleGraphicsPowerManagement) [AGPM][INFO ][CONTROLLER ][createAGPMClass ] gpuDict GFX0
2020-01-30 08:16:22.224462-0600 0x7bb Default 0x0 0 0 kernel: (AppleGraphicsPowerManagement) [AGPM][INFO ][CONTROLLER ][createAGPMClass ] build gpuDict by GPU GFX0.
2020-01-30 08:16:22.224464-0600 0x7bb Default 0x0 0 0 kernel: (AppleGraphicsPowerManagement) [AGPM][WARN ][CONTROLLER ][createAGPMClass ] GPU = GFX0 unknownPlatform (no matching vendor_id+device_id or GPU name); don't create AGPM class
2020-01-30 08:16:22.224558-0600 0x7be Default 0x0 0 0 kernel: (AppleGraphicsPowerManagement) [AGPM][INFO ][CONTROLLER ][createAGPMClass ] gpuDict GFX0
2020-01-30 08:16:22.224560-0600 0x7be Default 0x0 0 0 kernel: (AppleGraphicsPowerManagement) [AGPM][INFO ][CONTROLLER ][createAGPMClass ] build gpuDict by GPU GFX0.
2020-01-30 08:16:22.224563-0600 0x7be Default 0x0 0 0 kernel: (AppleGraphicsPowerManagement) [AGPM][WARN ][CONTROLLER ][createAGPMClass ] GPU = GFX0 unknownPlatform (no matching vendor_id+device_id or GPU name); don't create AGPM class
2020-01-30 08:16:22.224590-0600 0x7bb Default 0x0 0 0 kernel: (AppleGraphicsPowerManagement) [AGPM][INFO ][CONTROLLER ][start ] GPU = GFX0 Initialized, Control ID 17
2020-01-30 08:16:22.226073-0600 0x68c Default 0x0 0 0 kernel: (AMDRadeonX6000) [3:0:0] [Accel] --- Before TTL:initialize() - BootLoader POST Code=0xffffffff, Ready=0x80000000
2020-01-30 08:16:22.226074-0600 0x68c Default 0x0 0 0 kernel: (AMDRadeonX6000) [3:0:0] [Accel] >>> Calling TTL::initialize()
2020-01-30 08:16:22.226076-0600 0x68c Default 0x0 0 0 kernel: (AMDRadeonX6000) nonlocalMemSizeLimitBytes = 0x0000000040000000
2020-01-30 08:16:22.226082-0600 0x68c Default 0x0 0 0 kernel: (AMDRadeonX6000HWLibs) initialize normal
2020-01-30 08:16:22.364563-0600 0x68c Default 0x0 0 0 kernel: (AMDRadeonX6000) [3:0:0] [Accel] <<< TTL::initialize() Completed successfully.
2020-01-30 08:16:22.365433-0600 0x68c Default 0x0 0 0 kernel: (AMDRadeonX6000) ==== TTL =====
2020-01-30 08:16:22.365434-0600 0x68c Default 0x0 0 0 kernel: (AMDRadeonX6000) SE=2, SA/SE=2
2020-01-30 08:16:22.365435-0600 0x68c Default 0x0 0 0 kernel: (AMDRadeonX6000) numActiveRB=16, max=16
2020-01-30 08:16:22.365435-0600 0x68c Default 0x0 0 0 kernel: (AMDRadeonX6000) numActiveCU=10, max=10, total=40
2020-01-30 08:16:22.370052-0600 0x68c Default 0x0 0 0 kernel: (AMDRadeonX6000Framebuffer) Accelerator successfully registered with controller.
2020-01-30 08:16:26.429661-0600 0x49e Default 0x0 0 0 kernel: (AMDRadeonX6000Framebuffer) [3:0:0][GPUCAP] refresh() --- Family: 143, Device: 0x731f, revNo: 2, pciRevNo: c1, emuRevNo: 3.
2020-01-30 08:16:26.429662-0600 0x49e Default 0x0 0 0 kernel: (AMDRadeonX6000Framebuffer) [3:0:0][GPUCAP] refresh() --- Mem Size: FB: 8176 MB, Aper: 256 MB, Reg Aper: 512 KB.
2020-01-30 08:16:26.429663-0600 0x49e Default 0x0 0 0 kernel: (AMDRadeonX6000Framebuffer) [3:0:0][GPUCAP] refresh() --- Mem Config: Width: 256, Type: GDDR6.
2020-01-30 08:16:26.429664-0600 0x49e Default 0x0 0 0 kernel: (AMDRadeonX6000Framebuffer) [3:0:0][GPUCAP] refresh() --- FB Base: 0x8000000000, Top: 0x81ffffffff.
2020-01-30 08:16:26.429666-0600 0x49e Default 0x0 0 0 kernel: (AMDRadeonX6000Framebuffer) [3:0:0][GPUCAP] refresh() --- Branding - family: "Radeon RX"; device: "5700 XT"; model: "Radeon RX 5700 XT".
2020-01-30 08:16:26.453770-0600 0x49e Default 0x0 0 0 kernel: (AMDRadeonX6000Framebuffer) [3:0:0] [PPLIB] AppleMcilRegisterInterrupt() !!! SKELETON - irq:4278190124.
2020-01-30 08:16:26.453771-0600 0x49e Default 0x0 0 0 kernel: (AMDRadeonX6000Framebuffer) [3:0:0] [PPLIB] AppleMcilRegisterInterrupt() !!! SKELETON - irq:4278190125.
2020-01-30 08:16:26.453775-0600 0x49e Default 0x0 0 0 kernel: (AMDRadeonX6000Framebuffer) [3:0:0] [PPLIB] AppleMcilRegisterInterrupt() !!! SKELETON - irq:4278190158.
2020-01-30 08:16:26.453849-0600 0x49e Default 0x0 0 0 kernel: (AMDRadeonX6000HWLibs) call SW_SMUM_ReadSmuVersion return instance.dwSMC_uCode_Version = 0x2a2900
2020-01-30 08:16:26.483458-0600 0x49e Default 0x0 0 0 kernel: (AMDRadeonX6000) === PM4 engine start(): SUCCESS
2020-01-30 08:16:26.651632-0600 0x663 Default 0x0 0 0 kernel: (AMDRadeonX6000Framebuffer) [3:0:0] [AGDC] AMDRadeonX6000_AmdAgdcServices::vendor_doDeviceAttribute() ??? Controller is NOT enabled so SKIP. cmd:[ 3].
2020-01-30 08:16:28.030189-0600 0x49e Default 0x0 0 0 kernel: (AMDRadeonX6000Framebuffer) [3:0:0] [AGDC] AMDRadeonX6000_AmdAgdcServices::waitForAGDCReady() ??? AGDC failed to register with controller!
2020-01-30 08:16:28.595448-0600 0x49e Default 0x0 0 0 kernel: (AMDRadeonX6000Framebuffer) [3:0:0] [AGDC] AMDRadeonX6000_AmdAgdcServices::waitForAGDCReady() ??? AGDC failed to register with controller!
2020-01-30 08:16:29.168634-0600 0x49e Default 0x0 0 0 kernel: (AMDRadeonX6000Framebuffer) [3:0:0] [AGDC] AMDRadeonX6000_AmdAgdcServices::waitForAGDCReady() ??? AGDC failed to register with controller!
2020-01-30 08:16:29.730949-0600 0x49e Default 0x0 0 0 kernel: (AMDRadeonX6000Framebuffer) [3:0:0] [AGDC] AMDRadeonX6000_AmdAgdcServices::waitForAGDCReady() ??? AGDC failed to register with controller!
2020-01-30 08:16:29.731392-0600 0x49e Default 0x0 0 0 kernel: (AMDRadeonX6000Framebuffer) [3:0:0] [FB:0] AmdRadeonFramebuffer::setCursorImage() !!! Driver is offline.
2020-01-30 08:16:29.731395-0600 0x49e Default 0x0 0 0 kernel: (AMDRadeonX6000Framebuffer) [3:0:0] [FB:1] AmdRadeonFramebuffer::setCursorImage() !!! Driver is offline.
2020-01-30 08:16:29.731397-0600 0x49e Default 0x0 0 0 kernel: (AMDRadeonX6000Framebuffer) [3:0:0] [FB:2] AmdRadeonFramebuffer::setCursorImage() !!! Driver is offline.
2020-01-30 08:16:29.731399-0600 0x49e Default 0x0 0 0 kernel: (AMDRadeonX6000Framebuffer) [3:0:0] [FB:3] AmdRadeonFramebuffer::setCursorImage() !!! Driver is offline.
2020-01-30 08:16:29.740266-0600 0x49e Default 0x0 0 0 kernel: (AppleIntelCFLGraphicsFramebuffer) [IGFB][INFO ] [AGDC] Get GPU caps
2020-01-30 08:16:29.746940-0600 0x49e Default 0x0 0 0 kernel: (AppleIntelCFLGraphicsFramebuffer) [IGFB][INFO ] [AGDC] Get GPU caps
2020-01-30 08:16:29.750767-0600 0x49e Default 0x0 0 0 kernel: (AppleIntelCFLGraphicsFramebuffer) [IGFB][INFO ] [AGDC] Get GPU caps
2020-01-30 08:16:29.754638-0600 0x49e Default 0x0 0 0 kernel: (AppleIntelCFLGraphicsFramebuffer) [IGFB][INFO ] [AGDC] Get GPU caps
2020-01-30 08:16:29.774995-0600 0x49e Default 0x0 0 0 kernel: (AppleIntelCFLGraphicsFramebuffer) [IGFB][INFO ] [AGDC] Get GPU caps
2020-01-30 08:16:29.905756-0600 0x49e Default 0x0 0 0 kernel: (AppleGFXHDA) [0x30001]AppleGFXHDAController[0]::gfxTerminatedHandler Display connected = 0
2020-01-30 08:16:30.662153-0600 0xb34 Default 0x0 0 0 kernel: (AMDRadeonX6000HWLibs) AMD Error:
2020-01-30 08:16:30.662154-0600 0xb34 Default 0x0 0 0 kernel: (AMDRadeonX6000HWLibs) TODO: To implement support for request power
2020-01-30 08:16:30.666715-0600 0xb34 Default 0x0 0 0 kernel: (AMDRadeonX6000HWLibs) AMD Error:
2020-01-30 08:16:30.666716-0600 0xb34 Default 0x0 0 0 kernel: (AMDRadeonX6000HWLibs) TODO: To implement support for request power
2020-01-30 08:16:30.772583-0600 0xb34 Default 0x0 0 0 kernel: (AMDRadeonX6000HWLibs) AMD Error:
2020-01-30 08:16:30.772585-0600 0xb34 Default 0x0 0 0 kernel: (AMDRadeonX6000HWLibs) TODO: To implement support for request power
2020-01-30 08:16:31.555547-0600 0xb94 Default 0x0 0 0 kernel: (AppleGraphicsDeviceControl) AGDCC: Unauthorized client 'PerfPowerService' (IOService:/AppleACPIPlatformExpert/PCI0@0/AppleACPIPCI/PEG0@1/IOPP/PEGP@0/IOPP/pci-bridge@0/IOPP/GFX0@0/AMDRadeonX6000_AmdGpuWrangler)
2020-01-30 08:16:31.555588-0600 0xb94 Default 0x0 0 0 kernel: (AppleGraphicsDeviceControl) AGDCC: Unauthorized client 'PerfPowerService' (IOService:/AppleACPIPlatformExpert/PCI0@0/AppleACPIPCI/IGPU@2/AppleIntelFramebufferController/IntelFBClientControl)
2020-01-30 08:16:41.325071-0600 0xb34 Default 0x0 0 0 kernel: (AMDRadeonX6000HWLibs) AMD Error:
2020-01-30 08:16:41.325072-0600 0xb34 Default 0x0 0 0 kernel: (AMDRadeonX6000HWLibs) TODO: To implement support for request power
 

Attachments

Joined
Jul 21, 2019
Messages
4
Motherboard
ASUS MAXIMUS VIII HERO
CPU
Core i5 6600
Graphics
Sapphire Radeon 5700XT Nitro+
Mac
MacBook Pro
Mobile Phone
iOS
I have documented all steps I did with my Sapphire 5700XT to get it up and running. Maybe it helps you too?!
 
Joined
Jan 21, 2020
Messages
8
Motherboard
GA-Z370N-Wifi
CPU
i5-8600K
Graphics
RX 5700 XT
I have documented all steps I did with my Sapphire 5700XT to get it up and running. Maybe it helps you too?!
Thanks for the tip! I followed your guide and other similar ones pretty closely, but with no luck. The OS still boots fine but the displays do not initialize. Would you mind posting your EFI folder (and version of Clover) maybe on your original thread? I could try that exactly and see if there's something else that I'm missing. I do use VirtualSMC instead of FakeSMC. I'll try swapping that and see if that makes a difference.
Code:
(AMDRadeonX6000Framebuffer) Accelerator successfully registered with controller.
(AMDRadeonX6000Framebuffer) [3:0:0][GPUCAP] refresh() --- Family: 143, Device: 0x731f, revNo: 2, pciRevNo: c1, emuRevNo: 3.
(AMDRadeonX6000Framebuffer) [3:0:0][GPUCAP] refresh() --- Mem Size: FB: 8176 MB, Aper: 256 MB, Reg Aper: 512 KB.
(AMDRadeonX6000Framebuffer) [3:0:0][GPUCAP] refresh() --- Mem Config: Width: 256, Type: GDDR6.
(AMDRadeonX6000Framebuffer) [3:0:0][GPUCAP] refresh() --- FB Base: 0x8000000000, Top: 0x81ffffffff.
(AMDRadeonX6000Framebuffer) [3:0:0][GPUCAP] refresh() --- Branding - family: "Radeon RX"; device: "5700 XT"; model: "Radeon RX 5700 XT".
(AMDRadeonX6000Framebuffer) [3:0:0] [PPLIB] AppleMcilRegisterInterrupt() !!! SKELETON - irq:4278190124.
(AMDRadeonX6000Framebuffer) [3:0:0] [PPLIB] AppleMcilRegisterInterrupt() !!! SKELETON - irq:4278190125.
(AMDRadeonX6000Framebuffer) [3:0:0] [PPLIB] AppleMcilRegisterInterrupt() !!! SKELETON - irq:4278190158.
(AMDRadeonX6000HWLibs) call SW_SMUM_ReadSmuVersion return instance.dwSMC_uCode_Version = 0x2a2900
(AMDRadeonX6000) === PM4 engine start(): SUCCESS
(AMDRadeonX6000Framebuffer) [3:0:0] [AGDC] AMDRadeonX6000_AmdAgdcServices::vendor_doDeviceAttribute() ??? Controller is NOT enabled so SKIP. cmd:[       3].
(AppleGraphicsDevicePolicy) Adding AGDP mode validate property
(AMDRadeonX6000Framebuffer) [3:0:0] [FB:0] AmdRadeonFramebuffer::setCursorImage() !!! Driver is offline.
(AMDRadeonX6000Framebuffer) [3:0:0] [FB:1] AmdRadeonFramebuffer::setCursorImage() !!! Driver is offline.
(AMDRadeonX6000Framebuffer) [3:0:0] [FB:2] AmdRadeonFramebuffer::setCursorImage() !!! Driver is offline.
(AMDRadeonX6000Framebuffer) [3:0:0] [FB:3] AmdRadeonFramebuffer::setCursorImage() !!! Driver is offline.
(AppleGFXHDA) [0x30001]AppleGFXHDAController[0]::gfxTerminatedHandler Display connected = 0
(AppleGraphicsDeviceControl) AGDCC: Unauthorized client 'PerfPowerService' (IOService:/AppleACPIPlatformExpert/PCI0@0/AppleACPIPCI/PEG0@1/IOPP/PEGP@0/IOPP/pci-bridge@0/IOPP/GFX0@0/AMDRadeonX6000_AmdGpuWrangler)
(AppleGraphicsDeviceControl) AGDCC: Unauthorized client 'PerfPowerService' (IOService:/AppleACPIPlatformExpert/PCI0@0/AppleACPIPCI/PEG0@1/IOPP/PEGP@0/IOPP/pci-bridge@0/IOPP/GFX0@0/AMDRadeonX6000_AmdAgdcServices)
(AppleGraphicsDeviceControl) AGDCC: Unauthorized client 'PerfPowerService' (IOService:/AppleACPIPlatformExpert/PCI0@0/AppleACPIPCI/PEG0@1/IOPP/PEGP@0/IOPP/pci-bridge@0/IOPP/GFX0@0/AMDRadeonX6000_AmdAgdcServices/AppleGraphicsDevicePolicy/AGDPClientControl)
 
Joined
Jul 4, 2012
Messages
340
Motherboard
Gigabyte Aorus Z390 Ultra
CPU
i5-9600K
Graphics
Vega 56
Mac
iMac, MacBook Pro
Mobile Phone
iOS
Thanks for the tip! I followed your guide and other similar ones pretty closely, but with no luck. The OS still boots fine but the displays do not initialize. Would you mind posting your EFI folder (and version of Clover) maybe on your original thread? I could try that exactly and see if there's something else that I'm missing. I do use VirtualSMC instead of FakeSMC. I'll try swapping that and see if that makes a difference.
Code:
(AMDRadeonX6000Framebuffer) Accelerator successfully registered with controller.
(AMDRadeonX6000Framebuffer) [3:0:0][GPUCAP] refresh() --- Family: 143, Device: 0x731f, revNo: 2, pciRevNo: c1, emuRevNo: 3.
(AMDRadeonX6000Framebuffer) [3:0:0][GPUCAP] refresh() --- Mem Size: FB: 8176 MB, Aper: 256 MB, Reg Aper: 512 KB.
(AMDRadeonX6000Framebuffer) [3:0:0][GPUCAP] refresh() --- Mem Config: Width: 256, Type: GDDR6.
(AMDRadeonX6000Framebuffer) [3:0:0][GPUCAP] refresh() --- FB Base: 0x8000000000, Top: 0x81ffffffff.
(AMDRadeonX6000Framebuffer) [3:0:0][GPUCAP] refresh() --- Branding - family: "Radeon RX"; device: "5700 XT"; model: "Radeon RX 5700 XT".
(AMDRadeonX6000Framebuffer) [3:0:0] [PPLIB] AppleMcilRegisterInterrupt() !!! SKELETON - irq:4278190124.
(AMDRadeonX6000Framebuffer) [3:0:0] [PPLIB] AppleMcilRegisterInterrupt() !!! SKELETON - irq:4278190125.
(AMDRadeonX6000Framebuffer) [3:0:0] [PPLIB] AppleMcilRegisterInterrupt() !!! SKELETON - irq:4278190158.
(AMDRadeonX6000HWLibs) call SW_SMUM_ReadSmuVersion return instance.dwSMC_uCode_Version = 0x2a2900
(AMDRadeonX6000) === PM4 engine start(): SUCCESS
(AMDRadeonX6000Framebuffer) [3:0:0] [AGDC] AMDRadeonX6000_AmdAgdcServices::vendor_doDeviceAttribute() ??? Controller is NOT enabled so SKIP. cmd:[       3].
(AppleGraphicsDevicePolicy) Adding AGDP mode validate property
(AMDRadeonX6000Framebuffer) [3:0:0] [FB:0] AmdRadeonFramebuffer::setCursorImage() !!! Driver is offline.
(AMDRadeonX6000Framebuffer) [3:0:0] [FB:1] AmdRadeonFramebuffer::setCursorImage() !!! Driver is offline.
(AMDRadeonX6000Framebuffer) [3:0:0] [FB:2] AmdRadeonFramebuffer::setCursorImage() !!! Driver is offline.
(AMDRadeonX6000Framebuffer) [3:0:0] [FB:3] AmdRadeonFramebuffer::setCursorImage() !!! Driver is offline.
(AppleGFXHDA) [0x30001]AppleGFXHDAController[0]::gfxTerminatedHandler Display connected = 0
(AppleGraphicsDeviceControl) AGDCC: Unauthorized client 'PerfPowerService' (IOService:/AppleACPIPlatformExpert/PCI0@0/AppleACPIPCI/PEG0@1/IOPP/PEGP@0/IOPP/pci-bridge@0/IOPP/GFX0@0/AMDRadeonX6000_AmdGpuWrangler)
(AppleGraphicsDeviceControl) AGDCC: Unauthorized client 'PerfPowerService' (IOService:/AppleACPIPlatformExpert/PCI0@0/AppleACPIPCI/PEG0@1/IOPP/PEGP@0/IOPP/pci-bridge@0/IOPP/GFX0@0/AMDRadeonX6000_AmdAgdcServices)
(AppleGraphicsDeviceControl) AGDCC: Unauthorized client 'PerfPowerService' (IOService:/AppleACPIPlatformExpert/PCI0@0/AppleACPIPCI/PEG0@1/IOPP/PEGP@0/IOPP/pci-bridge@0/IOPP/GFX0@0/AMDRadeonX6000_AmdAgdcServices/AppleGraphicsDevicePolicy/AGDPClientControl)
I don't know if you ever solved this. I have this problem across three GPUs now and it seems to related to the monitor it self at this point since it is the only thing that is common between them. Interestingly the physical cable makes a difference. I bought a 8K display port cable that simply refused to ever light up the screen with an image in macOS but works fine in Windows. I do have some black screen issue in in Windows 10, though not as bad as macOS.

HDMI kind of works if you don't mind a red tint when you wake your computer. The free display port cable that came with the monitor works the best, though often requires a hard reboot because it won't light up the screen after being in sleep(not really sleep in that only the graphiucs is turned off since sleep is disabled).

The higher spec Display port cable is DOA in macOS which is really bizarre since it should just be connectors and wiring with what I would expect to be better shielding.

AMD is having this issue on Windows 10 and it may simply be an inherent problem with AMD basically face rolling and producing silicon with some sort of hardware bug they still haven't fixed. Less of an issue with real Macs since Apple does the testing and writes the firmware for everything and so can make sure it works.

It would be interesting to see people list the monitors for the 5700XTs that do and don't work, this may be the critical detail between a system that works and a system that doesn't. A poll on Hardware Unboxed pegs the AMD issue as affecting nearly half of all users.

To be clear this is not entirely a macOS issue since I've had this black screen problem in Windows 10 Clover and even the motherboard BIOS screen.
 
Joined
Oct 19, 2012
Messages
10
Motherboard
ASUS PRIME Z370A
CPU
i7 8700
Graphics
Radeon 5700 XT
Mac
MacBook Pro
Mobile Phone
iOS
I managed to get 5700 XT working on 10.15.3 via display port. In addition to agdpmod=pikera boot option I have set Product Name to MacPro6,1. If you set to 7,1 it will work too but will display memory misconfiguration error (that I understand is a known issue when non-ECC memory is used. If I set it to iMacPro1,1 then it only works via HDMI
 
Joined
Oct 10, 2014
Messages
18
Motherboard
Asus-H87M-Plus
CPU
i7-4790K
Graphics
RX 580
Mobile Phone
Android, iOS
Try the iMac Pro 1,1 smbios
also I had a probelm when I first update to catalina, I solved it after I deleted the lilu and wahtevergreen Kexts from the library extensions folder, and I use them only on the clover Kexts other folder.
i also disable the igpu in the bios after I use it to boot into the system to make the changes above.
 
Joined
Oct 19, 2012
Messages
10
Motherboard
ASUS PRIME Z370A
CPU
i7 8700
Graphics
Radeon 5700 XT
Mac
MacBook Pro
Mobile Phone
iOS
iMacPro1,1 only works via HDMI in my case
 
Top