Contribute
Register

Can Big Sur boot with Clover

Status
Not open for further replies.
Joined
Jun 29, 2016
Messages
66
Motherboard
Gigabyte Designare Z390
CPU
i9-9900K
Graphics
rx 5700xt
Mac
  1. MacBook Pro
Have anyone been able to get Big Sur to boot with Clover? My OpenCore installation seems unable to install Big Sur. So I'm thinking of trying Clover again instead.
 
Joined
Mar 9, 2012
Messages
2,592
Motherboard
Gigabyte Z390 AORUS Pro WFI
CPU
3.6 GHz 8-Core Intel Core i7
Graphics
RX 580
Mac
  1. iMac
  2. Mac Pro
Mobile Phone
  1. iOS
Have anyone been able to get Big Sur to boot with Clover? My OpenCore installation seems unable to install Big Sur. So I'm thinking of trying Clover again instead.
It is absolutely necessary that OC is the latest version and more important all kexts especially Lilu.kext and WhateverGreen.kext are the very latest to enable the installation.
 
Joined
Jun 29, 2016
Messages
66
Motherboard
Gigabyte Designare Z390
CPU
i9-9900K
Graphics
rx 5700xt
Mac
  1. MacBook Pro
It is absolutely necessary that OC is the latest version and more important all kexts especially Lilu.kext and WhateverGreen.kext are the very latest to enable the installation.
Yeah, I updated all my kexts and I used OC 0.6.0, but I get stuck at an Apple logo, both when updating and when trying a fresh install. Probably something wrong with my config. I updated the config.plist according to https://opencore.slowgeek.com, but that did not help
 
Joined
Mar 9, 2012
Messages
2,592
Motherboard
Gigabyte Z390 AORUS Pro WFI
CPU
3.6 GHz 8-Core Intel Core i7
Graphics
RX 580
Mac
  1. iMac
  2. Mac Pro
Mobile Phone
  1. iOS
Yeah, I updated all my kexts and I used OC 0.6.0, but I get stuck at an Apple logo, both when updating and when trying a fresh install. Probably something wrong with my config. I updated the config.plist according to https://opencore.slowgeek.com, but that did not help

I don't know if - https://opencore.slowgeek.com - has been updated to mirror the changes in the latest OC version as I am sure I read a warning on another site about the use of said Checker. Personally I don't or never have used it, I learnt to compile my own OC version, config.plist and kexts from source after using hand me down pre-builds when OC was offered up as an alternative to Clover.
 

tonymacx86

Administrator
Staff member
Joined
Nov 18, 2009
Messages
7,183
Motherboard
PRIME Z490-A
CPU
i5 10600K
Graphics
Vega 56
Mac
  1. MacBook Air
Classic Mac
  1. Apple
  2. PowerBook
Mobile Phone
  1. iOS
I have tried Clover 5120 with the Big Sur Public Beta, and unfortunately kext injection does not seem to be working yet. Also, Z490 support seems to be missing.

OpenCore works for Big Sur and Z490.
 
Joined
Jun 29, 2016
Messages
66
Motherboard
Gigabyte Designare Z390
CPU
i9-9900K
Graphics
rx 5700xt
Mac
  1. MacBook Pro
I don't know if - https://opencore.slowgeek.com - has been updated to mirror the changes in the latest OC version as I am sure I read a warning on another site about the use of said Checker. Personally I don't or never have used it, I learnt to compile my own OC version, config.plist and kexts from source after using hand me down pre-builds when OC was offered up as an alternative to Clover.

I'm pretty new to OC, and still working my way through learning to work with that after being spoon-fed for years by clover. Right now I'm still using pre-compiled kexts and OC. Maybe this is a good time to experiment.

I have tried Clover 5120 with the Big Sur Public Beta, and unfortunately kext injection does not seem to be working yet. Also, Z490 support seems to be missing.

OpenCore works for Big Sur and Z490.

Thanks, good to know. I won't spend time with clover then. How was your experience setting up Big Sur with OC? Did you make any major changes to config? I saw some posts on r/hackitosh recently suggesting that using the installer for fresh install and updates doesn't work, and instead one should install to a VM and clone the disk image to the physical disk. Has it been the same for you?
 
Joined
Mar 9, 2012
Messages
2,592
Motherboard
Gigabyte Z390 AORUS Pro WFI
CPU
3.6 GHz 8-Core Intel Core i7
Graphics
RX 580
Mac
  1. iMac
  2. Mac Pro
Mobile Phone
  1. iOS
I'm pretty new to OC, and still working my way through learning to work with that after being spoon-fed for years by clover. Right now I'm still using pre-compiled kexts and OC. Maybe this is a good time to experiment.



Thanks, good to know. I won't spend time with clover then. How was your experience setting up Big Sur with OC? Did you make any major changes to config? I saw some posts on r/hackitosh recently suggesting that using the installer for fresh install and updates doesn't work, and instead one should install to a VM and clone the disk image to the physical disk. Has it been the same for you?
That claim is false, fresh install does work as long as your EFI folder tree is setup as per the guide and the kexts are the latest versions.
 
Joined
Jul 13, 2016
Messages
2,940
Motherboard
Gigabyte Z370 Gaming 5
CPU
I9 9900k
Graphics
Vega 64
Mac
  1. Mac mini
  2. Mac Pro
Mobile Phone
  1. iOS
That claim is false, fresh install does work as long as your EFI folder tree is setup as per the guide and the kexts are the latest versions.

I used the exact same EFI two days ago trying to boot a cloned drive and it would hang at the apple logo. Then yesterday I used Public beta 4 and it went off without a hitch. According to someone I talked to the first two DB were wonky and not easy to get going.
 
Joined
Mar 9, 2012
Messages
2,592
Motherboard
Gigabyte Z390 AORUS Pro WFI
CPU
3.6 GHz 8-Core Intel Core i7
Graphics
RX 580
Mac
  1. iMac
  2. Mac Pro
Mobile Phone
  1. iOS
According to someone I talked to the first two DB were wonky and not easy to get going.
That is because new boot-args had to be added to the config.plist to enable installation and booting which were realised and implemented along with an OC update and updated kexts. These boot-args are no longer needed as I think the developers has altered OC to that effect in version 0.6.1. (Sorry correction - the alterations are in Lilu.kext and WhateverGreen.kext).
 
Last edited:
Joined
Jul 13, 2016
Messages
2,940
Motherboard
Gigabyte Z370 Gaming 5
CPU
I9 9900k
Graphics
Vega 64
Mac
  1. Mac mini
  2. Mac Pro
Mobile Phone
  1. iOS
That is because new boot-args had to be added to the config.plist to enable installation and booting which were realised and implemented along with an OC update and updated kexts. These boot-args are no longer needed as I think the developers has altered OC to that effect in version 0.6.1. (Sorry correction - the alterations are in Lilu.kext and WhateverGreen.kext).

My problem was not video it was something else was hanging more at the point of where end random seed woudl have been. I dont have 6.1 but 6.0 works fine with the new beta 4 just did not work with beta 1...
 
Status
Not open for further replies.
Top