Contribute
Register

Boot Times

Joined
Mar 3, 2014
Messages
775
Motherboard
Gigabyte Z390 I AORUS PRO WIFI
CPU
i9-9900K
Graphics
RX 580
Mac
MacBook Air
Classic Mac
Power Mac
My current computer (at left) running Mojave 10.14.6 (build 18G2022) takes 44 seconds to get to the desktop, the first 30 of which are black screen (except for my Clover 3-sec delay).

My "Mini ITX 3" computer, running High Sierra 10.13.6 (build 17G10021) only takes 31 seconds with no initial black screen. Is this difference due to the AMD Radeon RX 580 Nitro+ graphics controller (built-in) taking longer to "boot" the graphics than my Nvidia 1050 Ti OC controller (nVidia Web Driver) in my High Sierra computer? Or is it Mojave versus High Sierra OS? Or both? And is there anything I can do to reduce boot time on my Mojave computer?
 
Joined
Sep 23, 2016
Messages
5
Motherboard
MSI b360m gaming plus
CPU
i5-9400f
Graphics
Gigabyte RX560
Mobile Phone
iOS
What kind of hard drive are you using?
 
Joined
Mar 3, 2014
Messages
775
Motherboard
Gigabyte Z390 I AORUS PRO WIFI
CPU
i9-9900K
Graphics
RX 580
Mac
MacBook Air
Classic Mac
Power Mac
What kind of hard drive are you using?
The Mojave computer runs a Samsung 970 Pro M.2 NVMe 1 TB SSD. The High Sierra computer runs a Samsung 970 Pro M.2 NVMe 500 GB SSD.
 
Last edited:
Joined
Mar 3, 2014
Messages
775
Motherboard
Gigabyte Z390 I AORUS PRO WIFI
CPU
i9-9900K
Graphics
RX 580
Mac
MacBook Air
Classic Mac
Power Mac
Both are running on APFS?
No, the Mojave computer is, but the High Sierra computer is running the HFS+ file system. Is that the reason?

(Incidentally, I forgot I had added a 970 Pro M.2 500 GB NVMe SSD to the High Sierra computer... its Crucial SATA SSD is now a backup, so both computers boot from the same type storage device, except for storage capacity. I edited my post #3 to reflect that.)
 
Last edited:
Joined
Mar 3, 2014
Messages
775
Motherboard
Gigabyte Z390 I AORUS PRO WIFI
CPU
i9-9900K
Graphics
RX 580
Mac
MacBook Air
Classic Mac
Power Mac
Boot time on my Mojave computer has recently improved to 33 secs from pressing power switch to desktop display, after re-installing Mac OS 10.14.6 (build 18G103). I think it might be due to re-tweaking the graphics injection in the config.plist and/or the kext patches in Clover. (I haven't yet installed the latest security update.)
 
Top