Contribute
Register

boot drive goneduring Mojave installation

Joined
Jun 1, 2013
Messages
184
Motherboard
Gigabyte Z490 Vision D
CPU
I7-10700K
Graphics
5600XT & 6800 XT
Mac
  1. iMac
Mobile Phone
  1. iOS
Hi all,

I was installing Mojave when my boot drive disappeared. Here are the steps that I followed:
- update clover to the latest version
- check that all the necessary kexts were in EFI/CLOVER/kexts/Other
- from appstore, selected Mojave. then follow the prompt. Select my boot drive to install mojave to
- system rebooted. I selected "Mac Os install" to boot from as per the guide
- installation started. At about 25% (37 minutes remaining), system rebooted. I selected again "mac os install"
- system booted and continued the installation. Everything so far ok
- At about 70% (15 minutes left), system rebooted
- press a key to access clover option. I was expecting to see the mac os installation as well as my main boot disk and my HDD clone. The only thing I could see was my HDD clone and the "boot from recovery HD". Nothing else

I booted my HDD clone and once up and running I can see my main boot drive as being afps drive. I tried to rerun an installation hoping that it would let me choose my main boot drive but I can. Message says that the main boot drive has not been formatted in extended journaled format.

any idea or suggestion? I can finish the installation and can't boot from my main drive since it is not in clover boot list anymore
Thanks
 
Joined
Dec 28, 2016
Messages
61
Motherboard
Asus Z87-Plus
CPU
i5-4460
Graphics
GTX 960
I suspect you missed the APFSLoader from your Clover install. Happened to me too. Clover can see the drive up until it is HFS, and then the installer formats it to APFS and if you don't have the loader, Clover won't see the new drive.
 
Top