Contribute
Register

Big Success: Shuttle SX38Pro2 9550 ATI 5750

Status
Not open for further replies.

inc

Joined
Oct 26, 2010
Messages
153
Motherboard
Z97-Gryphon
CPU
4790K
Graphics
GTX 760
Mac
  1. iMac
  2. MacBook
  3. MacBook Air
  4. MacBook Pro
  5. Mac mini
  6. Mac Pro
Classic Mac
  1. 512K
  2. Centris
  3. iBook
  4. iMac
  5. Plus
  6. Power Mac
  7. PowerBook
  8. Quadra
  9. Workgroup Server
  10. Xserve
Mobile Phone
  1. iOS
Update: I have gotten this build working in a roundabout way and will post a follow-up.

I have a Shuttle XPC SX38Pro 2 based on the intel SX38:

http://global.shuttle.com/product_detai ... jsp?PI=638

My video card is a PCI-E ATI 5750 with two DVI slots, 1 HDMI, and one Display Port. I think it was a Sapphire?

dmesg on Linux says it's a 01:00.1 Audio device: ATI Technologies Inc Juniper HDMI Audio [Radeon HD 5700 Series]

I have 4GB of RAM and a new 500GB disk. I put my bios to AHCI on SATA, suspend to S3. I pulled all other devices except for the keyboard, mouse. I left on-board HD audio active.

This system currently runs Arch Linux and Windows 7, both 64bit. I have a retail Mac OS X Snow Leopard disc and have been trying both iBoot and iBoot ATI per the guide on LifeHacker today.

http://lifehacker.com/5672051/how-to-bu ... easy-steps

The boot disc boots to the bootloader, but crashes when I try to start the installer. It flashes a kernel panic, but I don't get a fancy multi-lingual "please power down" graphic like my iMac has when it kernel panics. It will stay up longer if I feed it a "-x -v" or just "-x" but the actual error/crash eventually comes before I get to a GUI. It will spray some errors, and then spray more errors on one line while subsequently making the screen get darker and darker and eventually it will just bounce itself or I can hit the power button to turn it off.

I don't know where to go from here. My goal would be to have this workstation replace my iMac core2duo system for everyday use and playing a couple of games without booting into Windows.

Is there a jedi willing to lend a hand and show me the ropes?

Attached is a photo of a typical kernel panic but I also have a 3 minute video that scrolls through things it's loading and then flies past whatever error it is too fast to see before it goes to a panic.

If it helps: the output from lspci:
00:00.0 Host bridge: Intel Corporation 82X38/X48 Express DRAM Controller (rev 01)
00:01.0 PCI bridge: Intel Corporation 82X38/X48 Express Host-Primary PCI Express Bridge (rev 01)
00:1a.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 (rev 02)
00:1a.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5 (rev 02)
00:1a.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #6 (rev 02)
00:1a.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2 (rev 02)
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 02)
00:1c.0 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 1 (rev 02)
00:1c.1 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 2 (rev 02)
00:1d.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 (rev 02)
00:1d.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev 92)
00:1f.0 ISA bridge: Intel Corporation 82801IR (ICH9R) LPC Interface Controller (rev 02)
00:1f.2 IDE interface: Intel Corporation 82801IR/IO/IH (ICH9R/DO/DH) 4 port SATA IDE Controller (rev 02)
00:1f.3 SMBus: Intel Corporation 82801I (ICH9 Family) SMBus Controller (rev 02)
00:1f.5 IDE interface: Intel Corporation 82801I (ICH9 Family) 2 port SATA IDE Controller (rev 02)
01:00.0 VGA compatible controller: ATI Technologies Inc Device 68be
01:00.1 Audio device: ATI Technologies Inc Juniper HDMI Audio [Radeon HD 5700 Series]
02:00.0 IDE interface: JMicron Technology Corp. JMB368 IDE controller
03:00.0 Ethernet controller: Marvell Technology Group Ltd. 88E8056 PCI-E Gigabit Ethernet Controller (rev 12)
04:0a.0 FireWire (IEEE 1394): Texas Instruments TSB43AB22/A IEEE-1394a-2000 Controller (PHY/Link)

and lsusb:
Bus 008 Device 002: ID 1307:1171 Transcend Information, Inc. Fingerprint Reader
Bus 008 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 003: ID 046d:c21c Logitech, Inc. G13 Advanced Gameboard
Bus 007 Device 002: ID 046d:c066 Logitech, Inc.
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 003: ID 0a12:0001 Cambridge Silicon Radio, Ltd Bluetooth Dongle (HCI mode)
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 006: ID 05ac:0220 Apple, Inc. Aluminum Keyboard (ANSI)
Bus 002 Device 005: ID 05ac:1006 Apple, Inc. Hub in Aluminum Keyboard
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 003: ID 05e3:0608 Genesys Logic, Inc. USB-2.0 4-Port HUB
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

I had been booting the OS X install without the Bluetooth USB adapter and Logitech G13 attached.
 

Attachments

  • web.png
    web.png
    1.1 MB · Views: 225

MacMan

Administrator
Staff member
Joined
Feb 2, 2010
Messages
8,022
Motherboard
ASUS TUF Z390-PRO GAMING - 2606 - UEFI
CPU
i9-9900K
Graphics
Vega 64
Mac
  1. MacBook Pro
  2. Mac Pro
Classic Mac
  1. Power Mac
  2. PowerBook
Mobile Phone
  1. iOS
Re: Install failing: Shuttle SX38Pro 2 core2quad 9550 ati 5750

inc said:
I have a Shuttle XPC SX38Pro 2 based on the intel SX38:

http://global.shuttle.com/product_detai ... jsp?PI=638

My video card is a PCI-E ATI 5750 with two DVI slots, 1 HDMI, and one Display Port. I think it was a Sapphire?

dmesg on Linux says it's a 01:00.1 Audio device: ATI Technologies Inc Juniper HDMI Audio [Radeon HD 5700 Series]

I have 4GB of RAM and a new 500GB disk. I put my bios to AHCI on SATA, suspend to S3. I pulled all other devices except for the keyboard, mouse. I left on-board HD audio active.

This system currently runs Arch Linux and Windows 7, both 64bit. I have a retail Mac OS X Snow Leopard disc and have been trying both iBoot and iBoot ATI per the guide on LifeHacker today.

http://lifehacker.com/5672051/how-to-bu ... easy-steps

The boot disc boots to the bootloader, but crashes when I try to start the installer. It flashes a kernel panic, but I don't get a fancy multi-lingual "please power down" graphic like my iMac has when it kernel panics. It will stay up longer if I feed it a "-x -v" or just "-x" but the actual error/crash eventually comes before I get to a GUI. It will spray some errors, and then spray more errors on one line while subsequently making the screen get darker and darker and eventually it will just bounce itself or I can hit the power button to turn it off.

I don't know where to go from here. My goal would be to have this workstation replace my iMac core2duo system for everyday use and playing a couple of games without booting into Windows.

Is there a jedi willing to lend a hand and show me the ropes?

Attached is a photo of a typical kernel panic but I also have a 3 minute video that scrolls through things it's loading and then flies past whatever error it is too fast to see before it goes to a panic.

If it helps: the output from lspci:
00:00.0 Host bridge: Intel Corporation 82X38/X48 Express DRAM Controller (rev 01)
00:01.0 PCI bridge: Intel Corporation 82X38/X48 Express Host-Primary PCI Express Bridge (rev 01)
00:1a.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 (rev 02)
00:1a.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5 (rev 02)
00:1a.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #6 (rev 02)
00:1a.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2 (rev 02)
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 02)
00:1c.0 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 1 (rev 02)
00:1c.1 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 2 (rev 02)
00:1d.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 (rev 02)
00:1d.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev 92)
00:1f.0 ISA bridge: Intel Corporation 82801IR (ICH9R) LPC Interface Controller (rev 02)
00:1f.2 IDE interface: Intel Corporation 82801IR/IO/IH (ICH9R/DO/DH) 4 port SATA IDE Controller (rev 02)
00:1f.3 SMBus: Intel Corporation 82801I (ICH9 Family) SMBus Controller (rev 02)
00:1f.5 IDE interface: Intel Corporation 82801I (ICH9 Family) 2 port SATA IDE Controller (rev 02)
01:00.0 VGA compatible controller: ATI Technologies Inc Device 68be
01:00.1 Audio device: ATI Technologies Inc Juniper HDMI Audio [Radeon HD 5700 Series]
02:00.0 IDE interface: JMicron Technology Corp. JMB368 IDE controller
03:00.0 Ethernet controller: Marvell Technology Group Ltd. 88E8056 PCI-E Gigabit Ethernet Controller (rev 12)
04:0a.0 FireWire (IEEE 1394): Texas Instruments TSB43AB22/A IEEE-1394a-2000 Controller (PHY/Link)

and lsusb:
Bus 008 Device 002: ID 1307:1171 Transcend Information, Inc. Fingerprint Reader
Bus 008 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 003: ID 046d:c21c Logitech, Inc. G13 Advanced Gameboard
Bus 007 Device 002: ID 046d:c066 Logitech, Inc.
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 003: ID 0a12:0001 Cambridge Silicon Radio, Ltd Bluetooth Dongle (HCI mode)
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 006: ID 05ac:0220 Apple, Inc. Aluminum Keyboard (ANSI)
Bus 002 Device 005: ID 05ac:1006 Apple, Inc. Hub in Aluminum Keyboard
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 003: ID 05e3:0608 Genesys Logic, Inc. USB-2.0 4-Port HUB
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

I had been booting the OS X install without the Bluetooth USB adapter and Logitech G13 attached.
For your video card you need to use iBoot ATI.
 

inc

Joined
Oct 26, 2010
Messages
153
Motherboard
Z97-Gryphon
CPU
4790K
Graphics
GTX 760
Mac
  1. iMac
  2. MacBook
  3. MacBook Air
  4. MacBook Pro
  5. Mac mini
  6. Mac Pro
Classic Mac
  1. 512K
  2. Centris
  3. iBook
  4. iMac
  5. Plus
  6. Power Mac
  7. PowerBook
  8. Quadra
  9. Workgroup Server
  10. Xserve
Mobile Phone
  1. iOS
Re: Install failing: Shuttle SX38Pro 2 core2quad 9550 ati 5750

For your video card you need to use iBoot ATI.

The photo may be from the vanilla attempt, but subsequent boots have been using iBoot ATI -- with a different type of panic. Using the ATI image when it panics it makes the screen get progressivly darker with each burst of output.
 

inc

Joined
Oct 26, 2010
Messages
153
Motherboard
Z97-Gryphon
CPU
4790K
Graphics
GTX 760
Mac
  1. iMac
  2. MacBook
  3. MacBook Air
  4. MacBook Pro
  5. Mac mini
  6. Mac Pro
Classic Mac
  1. 512K
  2. Centris
  3. iBook
  4. iMac
  5. Plus
  6. Power Mac
  7. PowerBook
  8. Quadra
  9. Workgroup Server
  10. Xserve
Mobile Phone
  1. iOS
Re: Install failing: Shuttle SX38Pro 2 core2quad 9550 ati 5750

I reviewed the video and can make out that the last thing it flashes before a kernel panic is:

Code:
(cut)...temizing SystemID with : (string)
(cut)..._inject_get_devprop_string NULL trying stringdata
(cut)...DT: Restart Fix applied!
(cut)...tarting Darwin x86
(cut)...HCI controller [8086:2937] at 00:1a.0 base 7f?(ff01)
(cut)...HCI controller [8086:2938] at 00:1a.1 base 7f0(fe01)

A few more of these, 3-4 base then 1 DMA, 3-4 base then 1 more DMA and then it KPs and drops me.

Not sure how to proceed.
 

inc

Joined
Oct 26, 2010
Messages
153
Motherboard
Z97-Gryphon
CPU
4790K
Graphics
GTX 760
Mac
  1. iMac
  2. MacBook
  3. MacBook Air
  4. MacBook Pro
  5. Mac mini
  6. Mac Pro
Classic Mac
  1. 512K
  2. Centris
  3. iBook
  4. iMac
  5. Plus
  6. Power Mac
  7. PowerBook
  8. Quadra
  9. Workgroup Server
  10. Xserve
Mobile Phone
  1. iOS
Re: Install failing: Shuttle SX38Pro 2 core2quad 9550 ati 5750

The install process still kernel panics when using iBoot 2.5, still blocked, no idea how to proceed.
 

inc

Joined
Oct 26, 2010
Messages
153
Motherboard
Z97-Gryphon
CPU
4790K
Graphics
GTX 760
Mac
  1. iMac
  2. MacBook
  3. MacBook Air
  4. MacBook Pro
  5. Mac mini
  6. Mac Pro
Classic Mac
  1. 512K
  2. Centris
  3. iBook
  4. iMac
  5. Plus
  6. Power Mac
  7. PowerBook
  8. Quadra
  9. Workgroup Server
  10. Xserve
Mobile Phone
  1. iOS
Re: Install failing: Shuttle SX38Pro 2 core2quad 9550 ati 5750

Is there a place I can file a bug report or anything? The install doesn't work and as far as I can tell my system should be supported.
 

inc

Joined
Oct 26, 2010
Messages
153
Motherboard
Z97-Gryphon
CPU
4790K
Graphics
GTX 760
Mac
  1. iMac
  2. MacBook
  3. MacBook Air
  4. MacBook Pro
  5. Mac mini
  6. Mac Pro
Classic Mac
  1. 512K
  2. Centris
  3. iBook
  4. iMac
  5. Plus
  6. Power Mac
  7. PowerBook
  8. Quadra
  9. Workgroup Server
  10. Xserve
Mobile Phone
  1. iOS
Re: Install failing: Shuttle SX38Pro 2 core2quad 9550 ati 5750

Sorry, but I still don't know what my next steps should be. I don't mean to bump a post but what should I do?
 

inc

Joined
Oct 26, 2010
Messages
153
Motherboard
Z97-Gryphon
CPU
4790K
Graphics
GTX 760
Mac
  1. iMac
  2. MacBook
  3. MacBook Air
  4. MacBook Pro
  5. Mac mini
  6. Mac Pro
Classic Mac
  1. 512K
  2. Centris
  3. iBook
  4. iMac
  5. Plus
  6. Power Mac
  7. PowerBook
  8. Quadra
  9. Workgroup Server
  10. Xserve
Mobile Phone
  1. iOS
Re: Install failing: Shuttle SX38Pro 2 core2quad 9550 ati 5750

Using the latest iBoot and MultiBeast image I encounter the same errors as of 2011-02-07.

Some clarity on how to troubleshoot this issue and/or get it resolved would be appreciated.
 
Joined
Feb 3, 2011
Messages
56
Mac
Classic Mac
Mobile Phone
Re: Install failing: Shuttle SX38Pro 2 core2quad 9550 ati 5750

because of ATI card try:
-x -v graphicsenabler=no PCIRootUID=1

also look around other posts see you can also try setting the frame buffer mode? (Could be mistaken here)
 

inc

Joined
Oct 26, 2010
Messages
153
Motherboard
Z97-Gryphon
CPU
4790K
Graphics
GTX 760
Mac
  1. iMac
  2. MacBook
  3. MacBook Air
  4. MacBook Pro
  5. Mac mini
  6. Mac Pro
Classic Mac
  1. 512K
  2. Centris
  3. iBook
  4. iMac
  5. Plus
  6. Power Mac
  7. PowerBook
  8. Quadra
  9. Workgroup Server
  10. Xserve
Mobile Phone
  1. iOS
Re: Install failing: Shuttle SX38Pro 2 core2quad 9550 ati 5750

Using an iBoot disk I downloaded and recorded today, still having problems with -v and -x and have also tried setting the PCI Root ID as suggested and also specified graphicsenabler=no.

I still get a panic before the Installer starts and the Snow Leopard disk. Still blocked.
 
Status
Not open for further replies.
Top