Contribute
Register

Asus X99 - Catalina Support

Joined
Sep 21, 2013
Messages
23
Motherboard
Asus Sabertooth X99
CPU
i7-5820K
Graphics
RX Vega 56
Mac
MacBook Pro, Mac mini, Mac Pro
Classic Mac
iBook, iMac, Performa, Power Mac, PowerBook, Xserve
Mobile Phone
iOS
This thread is for Asus X99 support, which is a continuation of kgp X99 Mojave Guide. I managed to get Catalina Beta working on a Asus Sabertooth X99, but with some issues. PCI devices, especially the Wifi adapter which converts an Apple Wifi to PCIe (Broadcom BCM43xx) currently does not work. I am investigating this, but if someone can make it work, reply in this thread. Sidecar does not work either.
catalinax99.jpg


Wifi fixed with AirportBrcmFixup, BrcmFirmwareRepo.kext and BrcmPatchRAM2.kext. Not sure why these are required despite being an official Apple wifi card. It must be specific to the converter adapter I am using.

The changes I made as follows
  • Added Innie.kext so nvme drives are detected as internal
  • Updated Clover to build 5033
  • Updated Lilu, Whatevergreen, AppleALC to latest versions
  • Enabled E0 -> EC ACPI patch and added SSDT-EC.dsl so Catalina can boot
The EFI folder can boot Mojave as well if you plan to dual boot.
Remember to update your system specs and upload a copy of your EFI folder, BIOS settings, and a copy of your IOREG in order to receive support
 

Attachments

Last edited:
Joined
Mar 9, 2011
Messages
11
Motherboard
Asus Rampage V Extreme
CPU
i7-6950X
Graphics
Vega 64
Mac
MacBook Pro, Mac Pro
Mobile Phone
iOS
This thread is for Asus X99 support, which is a continuation of kgp X99 Mojave Guide. I managed to get Catalina Beta working on a Asus Sabertooth X99, but with some issues. PCI devices, especially the Wifi adapter which converts an Apple Wifi to PCIe (Broadcom BCM43xx) currently does not work. I am investigating this, but if someone can make it work, reply in this thread. Also, the Realtek Ethernet does not work as well since there is no driver loaded. Sidecar does not work either.
View attachment 414617

Wifi fixed with AirportBrcmFixup, BrcmFirmwareRepo.kext and BrcmPatchRAM2.kext. Not sure why these are required despite being an official Apple wifi card. It must be specific to the converter adapter I am using.

The changes I made as follows
  • Updated Clover to build 4979
  • Updated Lilu to 1.3.7 and Whatevergreen to 1.3.0
Remember to update your system specs and upload a copy of your EFI folder, BIOS settings, and a copy of your IOREG in order to receive support


Yes, everything is perfectly working after update to Catalina Public Beta 2. KPG `s Mojave with iMac Pro 1.1 SMBIOS installation guide and only updated Clover Bootloader whatever is up to date at the official site with attached kexts which KPG distributed in his x299 build discussion.
I wish and hope KPG release or update his x99 iMac pro Live discussion for Catalina when the final version of Catalina come out.
 

Attachments

Joined
Dec 4, 2015
Messages
2
Motherboard
ASUS X99-A II
CPU
i7-6850K
Graphics
Vega 56
Mac
iMac, MacBook Pro
Mobile Phone
iOS
Yes, everything is perfectly working after update to Catalina Public Beta 2. KPG `s Mojave with iMac Pro 1.1 SMBIOS installation guide and only updated Clover Bootloader whatever is up to date at the official site with attached kexts which KPG distributed in his x299 build discussion.
I wish and hope KPG release or update his x99 iMac pro Live discussion for Catalina when the final version of Catalina come out.
Does your power management work? I have to activate KernelXCPM to get it.
415724

It works both on Public betas, but I don't absolutely know why I have to do it.
My processor is identified wrong but I think is purely aesthetic.
415728

I've attached my EFI folder
 

Attachments

Joined
Mar 9, 2011
Messages
11
Motherboard
Asus Rampage V Extreme
CPU
i7-6950X
Graphics
Vega 64
Mac
MacBook Pro, Mac Pro
Mobile Phone
iOS
Does your power management work? I have to activate KernelXCPM to get it.
View attachment 415724
It works both on Public betas, but I don't absolutely know why I have to do it.
My processor is identified wrong but I think is purely aesthetic.
View attachment 415728
I've attached my EFI folder
Not sure why it's working I used CPU Type 0x0A01 in Clover config and Fake CPUID kept empty.
 
Joined
Dec 4, 2015
Messages
2
Motherboard
ASUS X99-A II
CPU
i7-6850K
Graphics
Vega 56
Mac
iMac, MacBook Pro
Mobile Phone
iOS
Not sure why it's working I used CPU Type 0x0A01 in Clover config and Fake CPUID kept empty.
I see from your detail that you have a Broadwell-E, is it right? Which KernelToPatch you have used? Because in order to boot I have used different patchs from @chikorita157
415807

In particular, I must disable _xcpm_cpuid and check KernelXCPM.
CPU Type for what I know is just an aesthetic trick for the About Your Mac. As you said I've tried to remove FakeCPUID but nothig changed.
If you could upload your efi I'll check without bother you too much :D.
 
Last edited:
Joined
Mar 9, 2011
Messages
11
Motherboard
Asus Rampage V Extreme
CPU
i7-6950X
Graphics
Vega 64
Mac
MacBook Pro, Mac Pro
Mobile Phone
iOS
Mine looks like this
415903
 
Joined
Mar 9, 2011
Messages
11
Motherboard
Asus Rampage V Extreme
CPU
i7-6950X
Graphics
Vega 64
Mac
MacBook Pro, Mac Pro
Mobile Phone
iOS
and cpu like this
415908
 
Joined
Aug 21, 2011
Messages
76
Motherboard
X99 Deluxe
CPU
5960X
Graphics
GTX 650 Ti
Mac
MacBook, MacBook Pro, Mac mini
Classic Mac
iMac, Power Mac
Mobile Phone
iOS
does this still require patching the BIOS?

I have an Asus X99 Pro.
 
Top