Contribute
Register

Asus G53/73 JW with GTX 460M graphics cannot boot to installer (black screen)

Status
Not open for further replies.
Joined
Mar 7, 2011
Messages
35
Motherboard
Razer Blade 2017 UHD (Laptop)
CPU
Intel i7-7700HQ
Graphics
NVIDIA GeForce GTX 1060
Hi everyone,

I am looking to install Yosemite into this laptop ASUS G53JW. Previously in a ML installation, I would use the boot flags

`PCIRootUID=0 GraphicsEnabler=Yes`

to boot into the installer. However, with Yosemite, the boot ends with a black screen at the point where the installer is supposed to show (past the Apple logo).

I've experimented with permutations of the following flags

PCIRootUID = 0/1
GraphicsEnabler = Yes/No
IGPEnabler=No
dart=0
npci=0x2000
maxmem=4096
-x
-v
-f

It always ends up with the same result, a black screen at the end of boot. I'm still suspecting its a graphics issue despite enablers being injected at the start of boot.

Here's a video of the entire boot sequence
https://plus.google.com/+SimKernChe...6071730703944955730&oid=107760848709765688911

I know this used to be a hot model for hackintoshing back in the SL/L/ML days
Any help will be greatly appreciated :)

Have a nice day!
 

RehabMan

Moderator
Joined
May 2, 2012
Messages
184,100
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Hi everyone,

I am looking to install Yosemite into this laptop ASUS G53JW. Previously in a ML installation, I would use the boot flags

`PCIRootUID=0 GraphicsEnabler=Yes`

to boot into the installer. However, with Yosemite, the boot ends with a black screen at the point where the installer is supposed to show (past the Apple logo).

I've experimented with permutations of the following flags

PCIRootUID = 0/1
GraphicsEnabler = Yes/No
IGPEnabler=No
dart=0
npci=0x2000
maxmem=4096
-x
-v
-f

It always ends up with the same result, a black screen at the end of boot. I'm still suspecting its a graphics issue despite enablers being injected at the start of boot.

Here's a video of the entire boot sequence
https://plus.google.com/+SimKernChe...6071730703944955730&oid=107760848709765688911

I know this used to be a hot model for hackintoshing back in the SL/L/ML days
Any help will be greatly appreciated :)

Have a nice day!

Nvidia only, right? What smbios are you using? Make sure you use one that has nvidia.
 
Joined
Mar 7, 2011
Messages
35
Motherboard
Razer Blade 2017 UHD (Laptop)
CPU
Intel i7-7700HQ
Graphics
NVIDIA GeForce GTX 1060
Hey RehabMan,

Thanks for the reply! I ended up using smbios for MacPro 3,1 and the installation went smooth.

Most of my existing kexts for Audio, Wi-Fi and battery didn't work but I followed through some of the patches and right now I'm very happy to say that Yosemite works perfect on this Asus G53JW. The most pleasant surprise I had was that HDMI audio worked OOTB, something which always troubled me in ML and Mavs.

Perhaps I'll do an updated guide soon.

Thanks again!
 
Joined
Jan 23, 2011
Messages
45
Motherboard
AlienBook Pro 17 - 10.10.5
CPU
i7 4700 QM
Graphics
NVIDIA GTX 770M
Mac
Classic Mac
Mobile Phone
  1. Android
  2. iOS
Hey RehabMan,

Thanks for the reply! I ended up using smbios for MacPro 3,1 and the installation went smooth.

Most of my existing kexts for Audio, Wi-Fi and battery didn't work but I followed through some of the patches and right now I'm very happy to say that Yosemite works perfect on this Asus G53JW. The most pleasant surprise I had was that HDMI audio worked OOTB, something which always troubled me in ML and Mavs.

Perhaps I'll do an updated guide soon.

Thanks again!

Hi,

your specs are actually similar like mine,

how do you get the GTX460M working?

may you share your smbios & org.chameleon.plist ? and maybe your specific kext?

i cant get the full resolution on my Alienware M15X with same graphic card
 
Joined
Nov 13, 2014
Messages
1
Motherboard
ASUS G53JW
CPU
i7-740QM
Graphics
NVIDIA GTX460M
Mac
Classic Mac
Mobile Phone
Hi All,

How are you ?
I am NetBoy From France. It's a pleasure for me to see that are people who are interesting to install apple in the G53JW.
I am trying to install YOSMITE in me laptop but i have the same problem as Rehabman. When I try to install i tried some codes but always i had the black screen and then it reboot by it self.

PLEASE Divinitus could you post or send me a guide to install yosmite in my laptop please. I have install maverick in it but i dont have audio and honestly if i could have the last iOS of apple i will apreciated.

Waiting for your help and answer Thanks a lot

NetBoyScript
 

RehabMan

Moderator
Joined
May 2, 2012
Messages
184,100
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Hi All,

How are you ?
I am NetBoy From France. It's a pleasure for me to see that are people who are interesting to install apple in the G53JW.
I am trying to install YOSMITE in me laptop but i have the same problem as Rehabman. When I try to install i tried some codes but always i had the black screen and then it reboot by it self.

PLEASE Divinitus could you post or send me a guide to install yosmite in my laptop please. I have install maverick in it but i dont have audio and honestly if i could have the last iOS of apple i will apreciated.

Waiting for your help and answer Thanks a lot

NetBoyScript

I'm assuming you're using Unibeast...

You should read here: http://www.tonymacx86.com/yosemite-...aller-laptops-unibeast-chimera-chameleon.html
 
Joined
Jul 24, 2017
Messages
1
Motherboard
ASUS G53SW CLOVER
CPU
I5 2410M2.30 GHZ
Graphics
NVIDIA GTX 460M 1,5GB,1080P
Mac
  1. MacBook Pro
Hey RehabMan,

Thanks for the reply! I ended up using smbios for MacPro 3,1 and the installation went smooth.

Most of my existing kexts for Audio, Wi-Fi and battery didn't work but I followed through some of the patches and right now I'm very happy to say that Yosemite works perfect on this Asus G53JW. The most pleasant surprise I had was that HDMI audio worked OOTB, something which always troubled me in ML and Mavs.

Perhaps I'll do an updated guide soon.

Thanks again!
Please do you have a guide for this laptop? asus g53s? I never installed hackintosh and would like some help!!
 

RehabMan

Moderator
Joined
May 2, 2012
Messages
184,100
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Please do you have a guide for this laptop? asus g53s? I never installed hackintosh and would like some help!!

Follow the Clover guide linked from the FAQ.
http://www.tonymacx86.com/el-capita...faq-read-first-laptop-frequent-questions.html

Although you should read the FAQ for an overview of issues, the Clover guide is linked from the first question: "Q. Where do I start?", just after the bold face "Clover Guide".
Here is a direct link, just to be clear:
https://www.tonymacx86.com/threads/guide-booting-the-os-x-installer-on-laptops-with-clover.148093/

Also, your profile must be filled out with complete details as requested in the FAQ, again under "Q. Where do I start?". All seven details requested are equally important.

And if you have an issue (after following the guide), or on any other problem, you must provide a detailed description of the problem including information that helps us understand what you're doing. Always attach "Problem Reporting" files as per FAQ.
http://www.tonymacx86.com/el-capita...faq-read-first-laptop-frequent-questions.html
The required files and data are fully detailed in the last question in the FAQ:
"Q. What are typical "Problem Reporting" files?"
 
Status
Not open for further replies.
Top