Contribute
Register

After 10.8.5 Supp Udt ... auto sleep is not working anymore

Status
Not open for further replies.
Joined
Aug 1, 2012
Messages
469
Motherboard
Asus Z490 Prime A
CPU
i9-10900K
Graphics
VEGA VII
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Everything has been working fine till now.

Now manual sleep is working (even if pc is "slow" in going to sleep), but auto sleep in not working anymore. It goes to sleep for a sec and wakes up immediately.

I have (and I've always had) darkwake=10 in org.chameleon.boot.plist

pmset -g does not return anything specific ...and computer's always worked like a charm till yesterday ...

I've just re-installed the audio drivers after the update as suggested.

Any hints? Thanks in advance!
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,061
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Everything has been working fine till now.

Now manual sleep is working (even if pc is "slow" in going to sleep), but auto sleep in not working anymore. It goes to sleep for a sec and wakes up immediately.

I have (and I've always had) darkwake=10 in org.chameleon.boot.plist

pmset -g does not return anything specific ...and computer's always worked like a charm till yesterday ...

I've just re-installed the audio drivers after the update as suggested.

Any hints? Thanks in advance!

Look in your system.log for "Wake Reason"
 
Joined
Aug 1, 2012
Messages
469
Motherboard
Asus Z490 Prime A
CPU
i9-10900K
Graphics
VEGA VII
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Look in your system.log for "Wake Reason"

thanks!

the reason displayed in Sytem.log is always the same:

"Oct 9 22:20:02 Hack-Pro kernel[0]: Wake reason: EHC2"

I have a loooong list made of these same messages from yesterday on (the day when I made the update to 10.8.5). what is EHC2?

with a little google search seems that EHC2 is related to USB ports, not sure if USB2 or USB3. The point is that I've never updated the USB3 kext, and the other USB2 ports are native. So I'm stuck... :think:
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,061
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
thanks!

the reason displayed in Sytem.log is always the same:

"Oct 9 22:20:02 Hack-Pro kernel[0]: Wake reason: EHC2"

I have a loooong list made of these same messages from yesterday on (the day when I made the update to 10.8.5). what is EHC2?

with a little google search seems that EHC2 is related to USB ports, not sure if USB2 or USB3. The point is that I've never updated the USB3 kext, and the other USB2 ports are native. So I'm stuck... :think:

EHC is USB2 (XHC is USB3). Does your BIOS have an option to disable "Wake on USB"?
 
Joined
Aug 1, 2012
Messages
469
Motherboard
Asus Z490 Prime A
CPU
i9-10900K
Graphics
VEGA VII
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
EHC is USB2 (XHC is USB3). Does your BIOS have an option to disable "Wake on USB"?

No, there is nothing with USB. There is:

wake on PCI
wake on PICe
wake on RTC

and all of them are disabled.

The only doubt is on USB configuration bios page... xHCI is set to AUTO at the moment, maybe it should be set to Enabled... :think:
 
Joined
Aug 1, 2012
Messages
469
Motherboard
Asus Z490 Prime A
CPU
i9-10900K
Graphics
VEGA VII
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
10/10/13 3:43:04 AM GMT+
Assertion status system-wide:
PreventUserIdleDisplaySleep 0
PreventSystemSleep 0
PreventUserIdleSystemSleep 0
ExternalMedia 0
UserIsActive 0
ApplePushServiceTask 0
BackgroundTask 0


Kernel Assertions: 0x0392
* Kernel Assertion ID = 500
Created At = 10/10/13 3:40:57 AM GMT+
Modified At = 1/1/70 1:00:00 AM GMT+01
Owner ID = 0xffffff803c48c000
Level = 0
Assertions Set = None (4)


* Kernel Assertion ID = 501
Created At = 10/10/13 3:41:57 AM GMT+
Modified At = 1/1/70 1:00:00 AM GMT+01
Owner ID = 0xffffff803c48e000
Level = 0
Assertions Set = None (4)


* Kernel Assertion ID = 502
Created At = 10/10/13 3:47:50 AM GMT+
Modified At = 1/1/70 1:00:00 AM GMT+01
Owner ID = 0xffffff833b9b2000
Level = 0
Assertions Set = None (4)


* Kernel Assertion ID = 503
Created At = 10/10/13 3:47:52 AM GMT+
Modified At = 1/1/70 1:00:00 AM GMT+01
Owner ID = 0xffffff833ba01000
Level = 0
Assertions Set = None (4)


* Kernel Assertion ID = 504
Created At = 10/10/13 3:48:29 AM GMT+
Modified At = 1/1/70 1:00:00 AM GMT+01
Owner ID = 0xffffff803c57de00
Level = 255
Assertions Set = None (256)


* Kernel Assertion ID = 505
Created At = 10/10/13 3:49:26 AM GMT+
Modified At = 1/1/70 1:00:00 AM GMT+01
Owner ID = 0xffffff8041e97000
Level = 255
Assertions Set = None (8)


* Kernel Assertion ID = 506
Created At = 10/10/13 3:54:39 AM GMT+
Modified At = 1/1/70 1:00:00 AM GMT+01
Owner ID = 0xffffff803c57f700
Level = 255
Assertions Set = None (128)


everything looks good to me. But now both sleep and auto-sleep are not working: pc is immediately woken up...dont know what to do!...
 
Joined
Aug 1, 2012
Messages
469
Motherboard
Asus Z490 Prime A
CPU
i9-10900K
Graphics
VEGA VII
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
more finding here:

Oct 10 03:57:25 Hack-Pro kernel[0]: Wake reason: EHC2
Oct 10 03:57:25 Hack-Pro kernel[0]: The USB device HubDevice (Port 1 of Hub at 0x1a000000) may have caused a wake by issuing a remote wakeup (2)
Oct 10 03:57:25 Hack-Pro kernel[0]: The USB device BCM920702 Bluetooth 4.0 (Port 1 of Hub at 0x1a100000) may have caused a wake by issuing a remote wakeup (3)
Oct 10 03:57:36 hack-pro PleaseSleep[479]: Wake notification received from the system
 
Status
Not open for further replies.
Top