Contribute
Register

[Success] ASUS Prime Z370-A+i7-8700 Pro Audio Build

Joined
Sep 17, 2019
Messages
16
Motherboard
Asus Prime Z370-A II
CPU
i7-9700K
Graphics
RX 580
Mac
iMac, MacBook Pro
Mobile Phone
iOS
Ah, check Library/Extensions. Remove anything there that you installed when you first got this build running then run Kext Utility to repair permissions or use Hackintool.

If you need help, send me a screen shot of the folder.
true, in the past i put some kext in the library
i can try to remove them and use your efi v2
will boot my older efi in case of failure and without these kext in library?
 
Joined
Jul 26, 2018
Messages
747
Motherboard
Asus Z370-A Prime II
CPU
i7-8700
Graphics
RX 580
Mac
MacBook Pro
Mobile Phone
iOS
true, in the past i put some kext in the library
i can try to remove them and use your efi v2
will boot my older efi in case of failure and without these kext in library?
Right this is where we move forward. Why don't you do this: backup those kext you're removing from L/E. That way if something is wrong you can put them in your EFI and boot from there.

However, I've worked this board and EFI out pretty well. Once you're booted I'll show you what needed to change.

If you're at all uncomfortable then back up your system! Which really, we should be doing anyways.

When you're ready, attached is your Opencore EFI.
 

Attachments

Last edited:
Joined
Sep 17, 2019
Messages
16
Motherboard
Asus Prime Z370-A II
CPU
i7-9700K
Graphics
RX 580
Mac
iMac, MacBook Pro
Mobile Phone
iOS
Right this is where we move forward. Why don't you do this: backup those kext you're removing from L/E. That way if something is wrong you can put them in your EFI and boot from there.

However, I've worked this board and EFI out pretty well. Once you're booted I'll show you what needed to change.

If you're at all uncomfortable then back up your system! Which really, we should be doing anyways.

When you're ready, attached is your Opencore EFI.
Woah EFIv2 booted well, but my ssd 3.0 external drive can't load

How can i switch to opencore? just replace the efi?
 
Joined
Jul 26, 2018
Messages
747
Motherboard
Asus Z370-A Prime II
CPU
i7-8700
Graphics
RX 580
Mac
MacBook Pro
Mobile Phone
iOS
Woah EFIv2 booted well, but my ssd 3.0 external drive can't load

How can i switch to opencore? just replace the efi?
Very cool. Check Disk Utility to see if the drive is actually loaded or not. Sometimes with OS I need to got Apple>Force Quit>Relaunch Finder.

Did you repair permissions for your L/E?

As for OC, you simply replace the EFI.
 
Joined
Sep 17, 2019
Messages
16
Motherboard
Asus Prime Z370-A II
CPU
i7-9700K
Graphics
RX 580
Mac
iMac, MacBook Pro
Mobile Phone
iOS
Very cool. Check Disk Utility to see if the drive is actually loaded or not. Sometimes with OS I need to got Apple>Force Quit>Relaunch Finder.

Did you repair permissions for your L/E?

As for OC, you simply replace the EFI.
I tried to reboot my old efi without kexts in L/E and macOS recognised the USB3.1 bus for system!
Do you think my EFI still uncorrect?

Ok i'll try your OpenCore
 
Joined
Jul 26, 2018
Messages
747
Motherboard
Asus Z370-A Prime II
CPU
i7-8700
Graphics
RX 580
Mac
MacBook Pro
Mobile Phone
iOS
I tried to reboot my old efi without kexts in L/E and macOS recognised the USB3.1 bus for system!
Do you think my still uncorrect?

Ok i'll try your OpenCore
Send a new copy of your IOReg and lets investigate a few things!
 
Joined
Sep 17, 2019
Messages
16
Motherboard
Asus Prime Z370-A II
CPU
i7-9700K
Graphics
RX 580
Mac
iMac, MacBook Pro
Mobile Phone
iOS
This doesn't look right yet. Don't use the OC EFI yet. I need to fix a few things.

Ok, fixed. Try this. Resend IOReg after.
I'll try later, now i'm busy
Same bios setting as Clover bootloader?
 
Top