Recent content by uchika96

  1. uchika96

    [GUIDE] Lenovo 510s 14-ISK using OpenCore UEFI

    Hello everyone, these are just some useful notes I took during the process if I have to do it again. You can use them at your advantage during the installation if you are new to hackintosh ;). OpenCore configuration EFI folder: https://github.com/blackwiz4rd/Lenovo-510s-14isk-OC-UEFI My laptop...
  2. uchika96

    [GUIDE] Lenovo 510s 14-ISK using OpenCore UEFI

    Yes, it is working fine. The guide was in fact updated for Big Sur.
  3. uchika96

    [GUIDE] Lenovo 510s 14-ISK using OpenCore UEFI

    Read the guide posted in post #1 for audio: https://dortania.github.io/OpenCore-Post-Install/universal/audio.html#making-layout-id-more-permanent. The HDMI black screen a problem that is not totally fixed for me. I have to disconnect and re-connect the cable to get the laptop screen back to work.
  4. uchika96

    [GUIDE] Lenovo 510s 14-ISK using OpenCore UEFI

    It is stable for me. I can use it normally for tasks such as compiling software, browsing, doing graphics. It is a little slower if you need video editing but I think it is globally stable.
  5. uchika96

    [GUIDE] Lenovo 510s 14-ISK using OpenCore UEFI

    Thanks for sharing. I have just updated my bootloader to OpenCore. I will share my configuration in a new post.
  6. uchika96

    [Problem] Black primary screen on laptop when booting with HDMI

    Hello everyone, I have a problem when booting my laptop (Lenovo 510s: https://www.tonymacx86.com/threads/guide-lenovo-510s-14-isk-using-clover-uefi.282660/) being connected to HDMI. The primary screen is black (but still recognized because the cursor can go on the primary screen), the secondary...
  7. uchika96

    [GUIDE] Lenovo 510s 14-ISK using OpenCore UEFI

    See point 11), I have fixed audio and HDMI problems following that guide if you are still interested.
  8. uchika96

    No brightness control - Lenovo 510s

    I solved the problem, I had many mistakes in my config.plist according to WhateverGreen.kext configurations. Moreover I had to remove FakePCIID kexts and AppleBacklightInjector since it is part of WhateverGreen.kext. Read...
  9. uchika96

    No brightness control - Lenovo 510s

    Hi, I have followed the guide: https://www.tonymacx86.com/threads/guide-laptop-backlight-control-using-applebacklightfixup-kext.218222/ I still have no backlight control. How can I be sure that I have done it correctly? I am attaching the debug report, Thanks.
  10. uchika96

    [GUIDE] Lenovo 510s 14-ISK using OpenCore UEFI

    I have uploaded a bug report on post #1 that should contain everything you need ;)
  11. uchika96

    [GUIDE] Lenovo 510s 14-ISK using OpenCore UEFI

    I can check this when I can connect to an HDMI monitor, stay tuned :D
  12. uchika96

    [GUIDE] Lenovo 510s 14-ISK using OpenCore UEFI

    Hi, you mean that the screen on your PC won't turn off? Can you try different SMBIOS? I have some problems when connecting to HDMI too, I think that you need properly patched backlight control (as suggested by Rehabman in some answers) and kexts installed in the correct way. I will attach a...
  13. uchika96

    Error updating to Catalina from Mojave 10.15.6

    A solution is reported here: https://www.tonymacx86.com/threads/cant-upgrade-from-catalina-beta-3-to-beta-6.281761/page-2
  14. uchika96

    [GUIDE] Lenovo 510s 14-ISK using OpenCore UEFI

    Guide moved to Big Sur: https://www.tonymacx86.com/threads/guide-lenovo-510s-14-isk-using-opencore-uefi.307622/
  15. uchika96

    << Solved >> Can't upgrade from Catalina beta 3 to beta 6

    I finally found a solution, all you need to do is to compile the SSDT as aml: https://github.com/acidanthera/OpenCorePkg/blob/master/Docs/AcpiSamples/SSDT-EC.dsl and put it in EFI/CLOVER/ACPI/Patched. It is also necessary to "Remove all patch about renaming acpi of EC or H_EC" in config.plist...
Top