1. Join Date
    Dec 2011
    Posts
    10
    System
    Windows
    CPU
    Core I5
    Graphics
    HD4000
    Online
    hrakoto is offline
    #1

    Lenovo Ideapad U410 Mountain Lion 98% working


    Update with Kext and DSDT

    Pretty cool Macbook pro like ultrabook. Usable at 90% with moutain lion. Only few features are not working so need your experience to get it work.

    Specs:
    CPU type Intel Core i3 3217U (Ivy Bridge)
    CPU speed 1700 Mhz
    Graphics HD400/Nvidia GeForce 610M nvidia optimus
    RAM 8GB, 750GB HD, 32GB SSD
    Sound chipset Connexant cx20590
    LAN Realtek RTL8105E , WLAN atheros ar5b95 (combo BT ar3011 Wifi ar9285)
    Card reader
    2x USB3 port éx USB2 port
    Webcam
    Synaptic touchpad
    HDMI out.

    WORKING FEATURES in 10.8.2:
    Graphics => HD4000 only (disable optimus in bios) => Efi String injection All OK
    Sound => Connexant cx20590 => DSDT injection => Apple HDA patched for cx20590 downloaded from osx86.net (Mic, speaker out, headphone, output autoswith features)
    Wifi => Atheros ar9285 => DSDT injection => Detected as airport
    Bluetooth => Ateheros ar3011 =>Use Kext from osx86.net
    Webcam => Lenovo easy camera => Remove XHCI kext(USB3) in IOUSBFAMILY.Kext and it's OK
    USB 2 port => DSDT fix for sleep (EHC1 and EHC2)
    Touchpad => Use kext from Multibeast.
    HDMI out => Work as soon as HD4000 is enabled but can't get it work with audio.
    Sleep => Work as soon as DSDT USB FIX , all usb device kext installed, AppleIntelCPUPowerManangement.Kext from Z580 post. No sleep enabler... needed.
    Lid => Lid sleep OK
    USB card reader => out of box.

    NOT WORKING FEATURES and ANNOYING THINGS that needs help:
    Sound trying to enable HDMI Audio with HD4000 but not OK.
    USB3 => Only mouse and keyboard works. so i disable the USB3 kext to use it as USB port to get Webcam working as it is attached to a USB3 controller. trying DSDTfix and severals Kext but not OK
    Lan => Realtek RTL8105E only work in 10mbps with official drivers. I test all available Kext available on the net but not OK only 10mbps with official drivers.

    Wifi and bluetooh not reactivate after sleep. I did a clean install and OK now.
    SpeedStep and Turbo boost OK now see page 5
    Attached Files Attached Files
    Last edited by hrakoto; 11-26-2012 at 06:18 PM.

  2. Join Date
    Aug 2012
    Posts
    66
    System
    Lenovo U410
    CPU
    Intel i5 3317U
    Graphics
    Intel HD4000
    Online
    pinsicchio is offline
    Android Phone
    #2

    Lenovo Ideapad U410 Mountain Lion 90% working


    wow awesome job, can you write a guide?

  3. Join Date
    Oct 2012
    Posts
    5
    System
    IdeaPad U410
    CPU
    i5-3317U
    Graphics
    Intel HD Graphics 4000
    Online
    treese1040 is offline
    iPhone
    #3

    Lenovo Ideapad U410 Mountain Lion 90% working


    LOL, I am not an early adaptor, especially with a computer I am dependent upon to earn a living.

    I think I need to wait to try this until there is a tried and true walk through.
    Best regards,


    Tony Reese

  4. Join Date
    Dec 2011
    Posts
    10
    System
    Windows
    CPU
    Core I5
    Graphics
    HD4000
    Online
    hrakoto is offline
    #4

    [Work in progress]Lenovo Ideapad U410 Mountain Lion 90% working


    Quote Originally Posted by treese1040 View Post
    LOL, I am not an early adaptor, especially with a computer I am dependent upon to earn a living.

    I think I need to wait to try this until there is a tried and true walk through.
    FYI It is stable, and fully usable. Non working features are just minor issues with pretty simple work around.
    I'm using it every day and i can perform everything i use to do with my old macbook pro.
    Also use it as java developement machine and use keynote for my presentation at work and no problem.

    Just dual booting with windows 7 for playing some games and use MS Office (don't want to buy another license).

    For a true walkthrough just read this http://www.tonymacx86.com/61-unibeas...-based-pc.html
    and adapt it with my first post using the attached files.
    Install it on an external usb drive so you don't touch your current configuration.

    Still in progress to get it work 100%

    Regards.
    Last edited by hrakoto; 10-25-2012 at 06:14 PM.

  5. Join Date
    Aug 2012
    Posts
    66
    System
    Lenovo U410
    CPU
    Intel i5 3317U
    Graphics
    Intel HD4000
    Online
    pinsicchio is offline
    Android Phone
    #5

    Lenovo Ideapad U410 Mountain Lion 90% working


    Quote Originally Posted by hrakoto View Post
    FYI It is stable, and fully usable. Non working features are just minor issues with pretty simple work around.
    I'm using it every day and i can perform everything i use to do with my old macbook pro.
    Also use it as java developement machine and use keynote for my presentation at work and no problem.

    Just dual booting with windows 7 for playing some games and use MS Office (don't want to buy another license).

    For a true walkthrough just read this http://www.tonymacx86.com/61-unibeas...-based-pc.html
    and adapt it with my first post using the attached files.
    Install it on an external usb drive so you don't touch your current configuration.

    Still in progress to get it work 100%

    Regards.
    did you success in installing the bootloader?

  6. Join Date
    Aug 2012
    Posts
    66
    System
    Lenovo U410
    CPU
    Intel i5 3317U
    Graphics
    Intel HD4000
    Online
    pinsicchio is offline
    Android Phone
    #6

    Lenovo Ideapad U410 Mountain Lion 90% working


    Ok i downloaded the file, now many things work but I still don't have wifi, bluetooth, and multitouch. What do I have to install for bt/wifi/mt? thanks a lot
    Last edited by pinsicchio; 10-27-2012 at 09:31 AM.

  7. Join Date
    Aug 2012
    Posts
    66
    System
    Lenovo U410
    CPU
    Intel i5 3317U
    Graphics
    Intel HD4000
    Online
    pinsicchio is offline
    Android Phone
    #7

    Lenovo Ideapad U410 Mountain Lion 90% working


    OK I got almost everything working, here's a little step-by-step guide:
    1) download the file in the first post
    2) install dsdt.aml and chimera via multibeast
    3) install the kexts
    4) copy the content of the Extra folder in the Extra folder created in the root of your hard drive when installing chimera
    5) reboot in unibeast again, disk utility, deactivate your mac partition, use macman's method to fix boot0 error, reactivate partition, reboot
    6) get the webcam working (see first post)
    7) i had to reinstall drivers -> network -> realtek gigabit ethernet from multibeast

    Now I have to try to get multitouch, wifi and bluetooth working, can someone help me?
    Last edited by pinsicchio; 10-28-2012 at 06:59 AM.

  8. Join Date
    Oct 2012
    Posts
    7
    System
    U410 IdeaPad
    CPU
    i5 3317u 1.7g
    Graphics
    nvidia
    Online
    joolzman is offline
    #8

    Lenovo Ideapad U410 Mountain Lion 90% working


    Hi All,

    I have the exact same Laptop Lenovo U410 intel i5 1.7G/6gb Ram/750gb HDD/32gb SSD/ Nvida Graphs....been following the guides now for a week and finally I've managed to build a working USB installation disk.....After I stopped jumping all over the room in celebrations I realised I'm far from done (i have done this before on an Acer 5742 I.Atk 10.7.2 sucessfully so not a complete noob...lets say noobish)My Problem now is I can't get to the setup screen, in safe mode I get SATA WARNING: enable auto activate failed & then sticks on Still waiting for Root device

    Erm...please can anybody show me some light...Lenovo Ideapad U410 Mountain Lion 90% working-20121101_111510.jpg

    Thanks in Advanced

  9. Join Date
    Aug 2012
    Posts
    66
    System
    Lenovo U410
    CPU
    Intel i5 3317U
    Graphics
    Intel HD4000
    Online
    pinsicchio is offline
    Android Phone
    #9

    Lenovo Ideapad U410 Mountain Lion 90% working


    that's what I did:
    1)format the whole drive
    2) set sata in AHCI mode and graphics in optimus
    3)installed ML
    4) do what I wrote some posts ago

    and now I have almost everything working (wifi and bt don't work, trackpad works as a mouse, no speedstep/turbo mode)


    has anybody got one of the things above working?

  10. Join Date
    Oct 2012
    Posts
    7
    System
    U410 IdeaPad
    CPU
    i5 3317u 1.7g
    Graphics
    nvidia
    Online
    joolzman is offline
    #10

    Lenovo Ideapad U410 Mountain Lion 90% working


    Quote Originally Posted by pinsicchio View Post
    that's what I did:
    1)format the whole drive
    2) set sata in AHCI mode and graphics in optimus
    3)installed ML
    4) do what I wrote some posts ago

    and now I have almost everything working (wifi and bt don't work, trackpad works as a mouse, no speedstep/turbo mode)


    has anybody got one of the things above working?

    Great that you managed to get it all running (nearly) and thank you for your speedy response

    i could not find your step by step posts (will keep looking) did you have to enter anything in the boot screen to get to the installation screen (-x -v bla bla??)

    I must be close now lol...Ive formatted the HDD and SSD....im starting to think it could be my ML (or should i say ML Gold Member?!?! whats the diff? as thats what i have)

    Again I appreciate any help thanks

  11. Similar Threads:

Page 1 of 31 12311 ... Last