1. Join Date
    Nov 2012
    Posts
    6
    System
    GA-Z68M-D2H F6
    CPU
    i7-3770k
    Graphics
    GTX 660 Ti
    Online
    Alejandro00 is offline
    Android Phone iMac
    #1

    Running Hackintosh with BIOS on RAID (XHD) mode


    Hi Forum!

    For easy reading, let's just go straight to the point:

    I'm trying to run Windows 8 Pro on a RAID 0 and Mountain Lion on a 3rd drive.
    I can boot Windows if I change BIOS to RAID (XHD) mode (It's a z68 gigabyte motherboard; GA-z68M-D2H F6) and can run Hackintosh if set to AHCI.
    So, both OS are installed and working, but I can't figure out how to run Hackintosh in RAID (XHD) mode instead of AHCI.

    I found this: http://legacy.tonymacx86.com/viewtopic.php?f=7&t=2311

    It didn't help and actually my problem is Hackintosh not booting, Windows works just fine on RAID mode.

    I will take a screenshot of how I configured multibeast later, maybe that helps... (I'm on Windows right now)

    Thanks for your help and let me please say that this forum is great! It's incredible how much support from users to users there is.
    Greetings from Chile!

  2. Moderator
    Join Date
    Aug 2010
    Posts
    14,153
    System
    GA-X58A-UD7 Rev.1 BIOS F7
    CPU
    i7-920
    Graphics
    Sapphire HD5770
    Online
    Going Bald is offline
    iMac MacBook Pro Mac Mini iMac
    #2

    Running Hackintosh with BIOS on RAID (XHD) mode


    Quote Originally Posted by Alejandro00 View Post
    Hi Forum!

    For easy reading, let's just go straight to the point:

    I'm trying to run Windows 8 Pro on a RAID 0 and Mountain Lion on a 3rd drive.
    I can boot Windows if I change BIOS to RAID (XHD) mode (It's a z68 gigabyte motherboard; GA-z68M-D2H F6) and can run Hackintosh if set to AHCI.
    So, both OS are installed and working, but I can't figure out how to run Hackintosh in RAID (XHD) mode instead of AHCI.

    I found this: http://legacy.tonymacx86.com/viewtopic.php?f=7&t=2311

    It didn't help and actually my problem is Hackintosh not booting, Windows works just fine on RAID mode.

    I will take a screenshot of how I configured multibeast later, maybe that helps... (I'm on Windows right now)

    Thanks for your help and let me please say that this forum is great! It's incredible how much support from users to users there is.
    Greetings from Chile!
    You will never get this to work using the mainboard ports. The ONLY way to have Windows on RAID dual booting with OS X without having to boot to BIOS and change it every time you change OS is to use a RAID controller card for the Windows drives - assuming you want OS X to see the Windows RAID. And OS X will not "see" the RAID array. It will "see" individual drives if you use the mainboard SATA ports.

  3. Join Date
    Nov 2012
    Posts
    6
    System
    GA-Z68M-D2H F6
    CPU
    i7-3770k
    Graphics
    GTX 660 Ti
    Online
    Alejandro00 is offline
    Android Phone iMac
    #3

    Running Hackintosh with BIOS on RAID mode


    Quote Originally Posted by Going Bald View Post
    use a RAID controller card for the Windows drives
    Oh, I see. Thanks for your help, is there a specific Raid controller you recommend maybe?

    For now I guess I will just leave it as it is, as I usually use Windows more than MAC OS.

    Greetings!

  4. Join Date
    Nov 2012
    Posts
    6
    System
    GA-Z68M-D2H F6
    CPU
    i7-3770k
    Graphics
    GTX 660 Ti
    Online
    Alejandro00 is offline
    Android Phone iMac
    #4

    Running Hackintosh with BIOS on RAID (XHD) mode


    I have been reading about configuring RAID 0 for Windows with BIOS set to AHCI (With Software, as in MAC OS). It says it has some "punishment" on the CPU, but as I have a i7-3770K I don't think that should be a problem. That would theoretically work!

    I will be trying it next week as I don't have more time now, will be posting updates though.

  5. Join Date
    Nov 2012
    Posts
    6
    System
    GA-Z68M-D2H F6
    CPU
    i7-3770k
    Graphics
    GTX 660 Ti
    Online
    Alejandro00 is offline
    Android Phone iMac
    #5

    Running Hackintosh with BIOS on RAID (XHD) mode


    Info update for later read:
    http://legacy.tonymacx86.com/viewtopic.php?f=79&t=21704
    and post #7 here for how to get the right data:
    http://www.insanelymac.com/forum/top...ci-controller/

    **I think Going Bald was right and it will not work, but since I'm having lot of free time this week, I loose nothing giving it a try.

  6. Similar Threads:

Tags for this Thread