1.   
    Join Date
    Jan 2010
    Posts
    2,952
    System
    Gigabyte Z77X-UD5H
    CPU
    Core i7-3770K @4.2-4.4GHz
    Graphics
    Galaxy GeForce GTX 660 Ti
    Geekbench Score
    15902
    Online
    thelostswede is offline
    Android Phone
    #1

    Article: Quick guide to configuring the UEFI on Gigabyte's 7-series LGA-1155 motherbo


    With Gigabyte having moved entirely to UEFI on its 7-series LGA-1155 motherboards, we thought itís about time that we put together a quick guide for those of you that are new to UEFI. There are really very few settings that you have to change in Gigabyteís new UEFI to get your CustoMac up and running, but we also thought weíd include a few helpful tricks that will make your system work even better. So click on through and weíll take you on a tour through the wonderful world of UEFI settings.

    Letís start with the basics. Start by getting out of the "3D BIOS" by pressing the F1 key. This will bring you to the standard UI as itís actually much easier to change the settings that you have to make changes to here. Next, press the F7 key on the keyboard, this will load the optimized defaults settings. Click yes on the prompt and your system will be re-set to the optimized default settings. Note that all of Gigabyteís 7-series LGA-1155 boards have AHCI enabled by default, so this one setting you donít have to worry about changing any more.

    Now we can start making a few changes. Note that if youíre using a dual-boot system, none of these settings will affect Windows 7 in any way, but we canít say for certain what effects these settings might have in other operating systems.


    First, head over to Peripherals, here you want to make sure that the xHCI mode is set to Auto. In some UEFI versions this defaults to Smart Auto, but this setting doesnít work in OS X. You also want to make sure that xHCI and EHCI Hand-off is enabled.

    On the peripherals settings screen you can also configure the display settings. In the case of the example above, a discrete graphics card was used, so PEG is what you want to select under Init Display First. If youíre using the integrated Intel graphics, then you want to select IGFX here. You donít need to make any changes to the Internal Graphics Memory Size setting here, just leave it at the default of 64MB.


    Finally, go to the Power Management options. Here the important setting is High Precision Event Timer, although it should be enabled by default. A little tip here is to disable Wake on LAN, as it seems to cause a reboot after a couple of seconds if you select to shut down your system from within OS X. This might not be a viable option for everyone, but itís the easy way of solving the reboot issue.

    As for any of the other UEFI settings, well, they donít have to be changed to have a fully working system. You do want to set up the correct boot drive under BIOS Features and note that you canít set the boot drive to one with the UEFI prefix for OS X, as you wonít be able to boot into the OS if this is set, instead you need to select the legacy option which is usually listed as something like "P0: Drive name" if youíre using the standard Intel SATA ports.

    Hopefully this will make life easier for everyone when it comes to setting up the UEFI options on your Gigabyte 7-series LGA-1155 motherboard.

    Update: After some user comments it has come to light that Gigabyte has apparently solved the issues with having to enable EIST and Turbo Boost. These can now be left on Auto and there's no need to make any changes here, as long as you're using the latest UEFI release from Gigabyte. So far I've only tested on a Sandy Bridge CPU on a Z77 motherboard, but unlike some of the reports here, I didn't experience any performance drops by enabling either option. Do note that EIST might throttle the CPU speed as EIST is short for Enhanced Intel Speed Step and as such is a power saving feature for when the CPU is not being utilized. If I find anything different on my Ivy Bridge system I'll post a further update here.

    One more thing I'd like to point out is the fact that this guide does not apply to overclocked system, it's a basic guide to get you up and running with minimal fuss. A lot of things can be tweaked to further enhance the performance of your system, but that's something we'll follow up with in a separate guide.

    Update 2: Some non-K Ivy Bridge CPUs, including the i7-3770 need to set VT-D to disabled in order to boot successfully. The boot flag to get around not having that option in BIOS is dart=0.
    Last edited by adamsmasher; 12-07-2014 at 03:27 PM.
    Core i7-3770K, Gigabyte Gigabyte GA-Z77X-UD5H-WB WiFi (not using the Wi-Fi card), Galaxy GeForce GTX 660 Ti, 8GB of Kingston HyperX Memory at 2133MHz, 60GB Corsair Force GT SSD for OS X, a bunch of other drives, a Pioneer DVD writer and a few bits that don't work in OS X...

  2.   
    Join Date
    Feb 2012
    Posts
    370
    System
    GA-H77N;GA-Z68XP-UD3; GA-Z68MA-D2H-B3
    CPU
    i3 3225; i7 2600k; i3 2105
    Graphics
    HD4000/HD6870
    Online
    jmpa is offline
    iPhone Mac Pro PowerMac PowerBook
    #2
    Great guide

    This settings are the same for ga-z68 mb with uefi bios?

  3.   
    Join Date
    Jan 2010
    Posts
    2,952
    System
    Gigabyte Z77X-UD5H
    CPU
    Core i7-3770K @4.2-4.4GHz
    Graphics
    Galaxy GeForce GTX 660 Ti
    Geekbench Score
    15902
    Online
    thelostswede is offline
    Android Phone
    #3
    Quote Originally Posted by jmpa View Post
    Great guide

    This settings are the same for ga-z68 mb with uefi bios?
    In theory yes, but I haven't tried yet. That's on my to-do list though.
    Core i7-3770K, Gigabyte Gigabyte GA-Z77X-UD5H-WB WiFi (not using the Wi-Fi card), Galaxy GeForce GTX 660 Ti, 8GB of Kingston HyperX Memory at 2133MHz, 60GB Corsair Force GT SSD for OS X, a bunch of other drives, a Pioneer DVD writer and a few bits that don't work in OS X...

  4. Join Date
    Mar 2011
    Posts
    104
    System
    Gigabyte EP45
    CPU
    E6600
    Graphics
    430GT
    Online
    natdeamer is offline
    #4
    What should we do if we want to use Wake On Lan?

  5.   
    Join Date
    Jan 2010
    Posts
    2,952
    System
    Gigabyte Z77X-UD5H
    CPU
    Core i7-3770K @4.2-4.4GHz
    Graphics
    Galaxy GeForce GTX 660 Ti
    Geekbench Score
    15902
    Online
    thelostswede is offline
    Android Phone
    #5
    Quote Originally Posted by natdeamer View Post
    What should we do if we want to use Wake On Lan?
    Until we can figure out a better solution, then you have to live with the reboot issue and manually power off your system.
    Core i7-3770K, Gigabyte Gigabyte GA-Z77X-UD5H-WB WiFi (not using the Wi-Fi card), Galaxy GeForce GTX 660 Ti, 8GB of Kingston HyperX Memory at 2133MHz, 60GB Corsair Force GT SSD for OS X, a bunch of other drives, a Pioneer DVD writer and a few bits that don't work in OS X...

  6. Join Date
    Dec 2010
    Posts
    28
    System
    GA-Z68MX-UD2H-B3 Rev 1.0
    CPU
    i5 2500k
    Graphics
    AMD Radeon HD 6850
    Online
    sahil m is offline
    #6
    Just an idea, but what if someone could create a guide on how to migrate an existing BIOS installation to a UEFI installation (what kexts to delete, etc.)?

    I'm interested in installing UEFI on my z68-mx-ud2h-b3, but I really don't know what needs to be kept and deleted, so I'm holding off.

  7. Join Date
    Apr 2012
    Posts
    30
    System
    GA-Z77X-UD5H
    CPU
    3770K
    Graphics
    EVGA GTX 670
    Online
    mmcakes is offline
    #7
    Thanks for the guide. I'm using this same Mobo. I'm getting an issue with ML where the mouse drivers are not reloaded after the computer wakes from sleep and it causes my mouse (Cyborg R.A.T. 7) to misbehave (not highlighting menu items, not allowing proper screenshot function). I have the Cyborg software installed which works fine until the computer goes to sleep. Once it wakes up, I have to restart the machine in order to obtain full functionality again. Any ideas? Thanks!

  8.   
    Join Date
    Jan 2010
    Posts
    2,952
    System
    Gigabyte Z77X-UD5H
    CPU
    Core i7-3770K @4.2-4.4GHz
    Graphics
    Galaxy GeForce GTX 660 Ti
    Geekbench Score
    15902
    Online
    thelostswede is offline
    Android Phone
    #8
    Quote Originally Posted by sahil m View Post
    Just an idea, but what if someone could create a guide on how to migrate an existing BIOS installation to a UEFI installation (what kexts to delete, etc.)?

    I'm interested in installing UEFI on my z68-mx-ud2h-b3, but I really don't know what needs to be kept and deleted, so I'm holding off.
    Sure, we can have a look see what we can do, but it'll take a little while to put together, but I have a Z68 board that I can use for this.
    Core i7-3770K, Gigabyte Gigabyte GA-Z77X-UD5H-WB WiFi (not using the Wi-Fi card), Galaxy GeForce GTX 660 Ti, 8GB of Kingston HyperX Memory at 2133MHz, 60GB Corsair Force GT SSD for OS X, a bunch of other drives, a Pioneer DVD writer and a few bits that don't work in OS X...

  9.   
    Join Date
    Jan 2010
    Posts
    2,952
    System
    Gigabyte Z77X-UD5H
    CPU
    Core i7-3770K @4.2-4.4GHz
    Graphics
    Galaxy GeForce GTX 660 Ti
    Geekbench Score
    15902
    Online
    thelostswede is offline
    Android Phone
    #9
    Quote Originally Posted by mmcakes View Post
    Thanks for the guide. I'm using this same Mobo. I'm getting an issue with ML where the mouse drivers are not reloaded after the computer wakes from sleep and it causes my mouse (Cyborg R.A.T. 7) to misbehave (not highlighting menu items, not allowing proper screenshot function). I have the Cyborg software installed which works fine until the computer goes to sleep. Once it wakes up, I have to restart the machine in order to obtain full functionality again. Any ideas? Thanks!
    Sounds like something unique to your mouse. Admittedly I only have a pair of Logitech mice, but neither (one gaming mouse, one older wireless model) have problems waking the system from sleep, or working after sleep and that is on two different systems. Might be worth checking with MadCatz as it seems to be a driver issue of some kind.
    Core i7-3770K, Gigabyte Gigabyte GA-Z77X-UD5H-WB WiFi (not using the Wi-Fi card), Galaxy GeForce GTX 660 Ti, 8GB of Kingston HyperX Memory at 2133MHz, 60GB Corsair Force GT SSD for OS X, a bunch of other drives, a Pioneer DVD writer and a few bits that don't work in OS X...

  10. Join Date
    Apr 2011
    Posts
    6
    System
    Mountain Lion
    CPU
    Intel Core i7 3770K
    Graphics
    Asus GTX670
    Geekbench Score
    17416
    Online
    chippo911 is offline
    iPhone MacBook Air MacBook Pro Mac Mini
    #10
    i have UD5H motherboard and auto-restart problem seems to appear only when usb3 ports are used, independently with sleep wake on lan options

  11. Similar Threads:

Page 1 of 22 12311 ... Last