Contribute
Register

Zbook G1 big sur power management not working

Joined
Oct 19, 2019
Messages
6
Motherboard
HP Zbook G1 15
CPU
i74900MQ
Graphics
HD 4600
Hello, I have a working clover+catalina setup, i'm trying to update to big sur but both clover and OC can't boot.
With OC I stuck at apfs_module_start:2436

OC efi attached

CPU: Intel Core i7 4900MQ 3.8GHz
GPU: Intel HD 4600 Mobile
 

Attachments

  • OC.zip
    5.3 MB · Views: 39
Joined
Oct 19, 2019
Messages
6
Motherboard
HP Zbook G1 15
CPU
i74900MQ
Graphics
HD 4600
edit: I managed to boot, but GPU acceleration is broken and acpi patches aren't working i guess, cause battery stats are not working and i got cmos reset at every boot(using rehabman one, updated efi attached)
 

Attachments

  • OC.zip
    15.5 MB · Views: 146
Joined
Jul 10, 2016
Messages
2
Motherboard
Asus Z170 Deluxe
CPU
i7 6700
Graphics
RX 580
Mac
  1. iMac
Mobile Phone
  1. Android
  2. iOS
Hi there, having a similar issue to this but with a pc. How did you solve the problem of apfs_module_start:2436 ?
 
Joined
Oct 19, 2019
Messages
6
Motherboard
HP Zbook G1 15
CPU
i74900MQ
Graphics
HD 4600
Hi there, having a similar issue to this but with a pc. How did you solve the problem of apfs_module_start:2436 ?
I've remade the EFI, took a prebuilt one for skylake here on the forum and make modification according to the Opencore guide

EDIT: fixed all, only battery stats seems not to work.

EDIT2: patched dsdt, all is working. Thread can be closed.
 
Last edited:

Feartech

Moderator
Joined
Aug 3, 2013
Messages
24,783
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
where can that efi be found?
 
Top