Contribute
Register

Z97 4790k can't shutdown properly now on Mojave

Joined
May 14, 2017
Messages
1
Motherboard
Gigabyte Z97X Gaming-3
CPU
i7-4790K
Graphics
RX 580
Mac
  1. MacBook Pro
My Hackintosh will not shutdown now, it goes through the shutdown procedure until the screen becomes black, waiting icon spins around and then I can hear the mobo click, which usually happens right before the whole PC just turns off, but now it restarts instead. Interestingly the system is able to go to sleep and wake up successfully. (it's dual boot, when I try to shutdown in Windows it does that normally)

How it happened: it all worked fine after a new installation of 10.14.0, but I had some intermittent issues with USB 3.0 - sometimes it would work, sometimes not. So I looked up the new MultiBeast and installed these things:
- 3rd party usb
- 7/8/9 usb support
- remove port limit
- usb inject all
I can remember vaguely that this would help with my previous installs of 10.12.x so I just tried it without giving it much thought.

Then the dead USB 3.0 ports on the back would work, but I encountered a couple new problems. The one I described in the beginning and the other being: the system is crashed by my WD Elements external drive. This drive works fine on my MBP. Other external drives work fine on my system, but putting the feral WD Elements in now just crashes the computer (before all that it worked perfectly for years and even on this install of OSX, now I tried formatting it several times and it doesn't help), it works fine for a sec, then freezes, then blacks out on me or restarts. I don't know if those two problems are a coincidence, but they started both after I tried to fix USB 3.0.

Since then I tried:
- changing the mobo battery
- unplugging all USB devices apart from keyboard and mouse
- changing the mac type from iMac 14,2 to 14,1 to 15,1 to Mac Pro 6,1
- ticking the 'fix shutdown' option in Clover configurator
- changing the various numbers of darkwake option in Clover configurator
- deleting tablet drivers that would crash system on shutdown, now it closes properly, just restarts... no shutdown crashes occur any more
- removing the aforementioned usb kexts that I added through MultiBeast

If any of you guys have any ideas I would love to hear them, because I am slowly beginning to lose my mind over that :D my setup is listed on the left under my avatar
 
Top