Z790 Chipset & Raptor Lake

Yes, I’m using -ctrsmt. I do let Mac OS “settle” a bit. I suppose there definitely could be some processes in the background slowing it down, as in Mac I have a full compliment of stuff installed whereas in Windows there’s absolutely nothing… so that’s a good thought for sure. Too bad I never tested with Max OS clean!
Ultimately, it’s not a huge swing I guess, and there’s nothing indicative of an opencore install issue, so I guess it is what it is. What I need to do is check my 13700k scores vs Windows and see if there’s a similar difference.

Thanks for the response!
Also Apple have never used that CPU in their machines so it is reasonable to assume that the CPU will not be 100% optimised
Also Apple have never used that CPU in their machines so it is reasonable to assume that the CPU will not be 100% optimised
My colleague just bought a MacPro with a 13900k directly from Apple.
This mythical Mac Pro would have Sapphire Rapids not Raptor Lake.
OMG, the 3459X has 112 PCIe lanes and a BASE power of 350W, up to 420W turbo. Gonna need nitro to cool that thing!
I didn't see that the board is not the same; you have an Asus. I've attached my EFI. I've been testing it for 2 weeks, and everything is working very well.

I have the same motherboard as you (Gigabyte z790 Aero G), and I am trying to get USB ports, Two Red ports in back + the Two USB port Type C in the Back I/o Shield working at the Right speed which is up to 10/gbs at least ... they are USB 3.2 Gen 2 ... But I have tried several time to do USB Mapping with different tools like Hackintool and USB toolBox through Windows 11 or even through Mac . But I haven't succeed .. by the way I have usb flash 3.2 Gen 1 and gen 2 that support this speed and I have tested them on Z790 Master and got the right speed up to 10 Gbs ..

I am attaching picture from Hackintool to understand me exactly and I wanna know if you have facing the same issue too, Or you have fixed already .. I tried that with bios F4, F5 and even F6C..

I will appreciate for answering me back.. Before I return the motherboard if there is no solution to fix that and get another z790 master or Asus z790 pro-art

by the way I am using iMac Pro 1.1 SMBIOS.

Screenshot 2023-05-24 at 11.29.18 AM.png
Last edited:
This happened to me amongst my testing, mainly on 0704 BIOS.

In my case it wouldn't recover (wake up) at all. Had to hard reset it (power off and on), then I'd have a red flashing light (every 4 seconds) which meant no Boot Drive Discovered. To recover the system I had to CMOS reset it by bridging the two pins and then re-configure bios again.

Can't say I narrowed it down as at the time I was heavily focused on TB2 testing, trying to get my UAD Apollo MKII to connect with the TB2->TB3 Apple adapter (with no luck) and thought the Thunderbolt was causing that sleep issue. XMP on/off, using speeds 4800, 5000 and 5600, still happened.

So I updated to BIOS 0814 tested again, no TB2 connection, but in the same instance I borrowed a friend's UAD Apollo Twin X (TB3) to test, and that worked no problem, hot plugged, on/off while in the OS, cold boot, warm boot, everything works. So I went and bought one, and, since then, I haven't experienced that sleep issue.

Now was it the Thunderbolt? Was it the BIOS version? Can't say..

Side note:
I'm on Big Sur 11.7.2
OC 0.8.8
Latest kexts/drivers (at the time of this post)
Thunderbolt driver 1.41.1340.0 (NVM 38.0)
SMBIOS MacPro7,1 & iMacPro 1,1 tested.

What I can say is, I downloaded your EFI to compare to mine quickly, I noticed you're using different **z790.aml files, are they just renamed from Casey's z690 ProArt EFI? Or they different? I'm using his z690 ProArt EFI, updated it to all latest kexts/drivers, added BRG0.aml as I'm using the 6900XTXH variant, fresh installed Big Sur, and it worked. Perhaps use his and test (if not already).

Few questions..
What BIOS version are you running, 0704 or 0814?

Do you have any thunderbolt devices connected? Try cold booting without them connected and put it to sleep to see if it does it again.

Try using SSDT-MAPLE-RIDGE-RP05-V1B.aml instead of V2, I'm currently running V1B and haven't had issues.

One more thing that may not be relevant, but good to test.. What monitor are you using? How is it connected to your GPU, HDMI or DP? In Displays, do you have the resolution SCALED or normal?

I discovered in my case, whenever i had the Display SCALED, i noticed my VRAM would increase to the point of no return (iStatistica showed it) and the machine became noticeably slower, even re-scaling the FINDER window would eat the VRAM...?!
When the Display is set to "Default for Resolution" there is no problems whatsoever, and i tested this by opening Logic Pro X with 20+ graphical meter plugins, 10 youtube videos in google chrome, plus Netflix and Prime in Safari with no VRAM issues.
If you've scaled it, Try Default For Resolution and put it to sleep to see if the same problem occurs.

Hopefully there's some info here that can help you, let us know how you go!
Would you mind sharing your EFI? I'm having trouble with my ASUS z790 ProArt build
I think it depend on BIOS version.
How could I find & download F4K Bios for Z790 AERO G?
Anyone know if it'd be possible to install a GPU onto one of the M.2 slots of the z790 using a riser like this one?

I'm trying to build a 4-GPU system with two GPU's connected to the CPU (in 8/x8 PCIe 5.0), another connected to the 3rd x16PCIe slot (connected to the chipset at x4, Gen4.0), and the fourth one connected to an M.2 slot (also connected to the chipset at x4, Gen 4.0)
do you know if Gigabyte Z790 AORUS ELITE AX has unlock able CFG-LOCK ( with bios or by the manual procedure its not important, important is that is unlock able, I had the Asus z790p prime and I couldn't in any way unlock it )

Seems like the z790 ProArt Creator doesn't allow for CFG Lock to be disabled either.

Can anyone confirm?
So I was peeking around threads, and forgive me if I missed one, but..

How's Raptor Lake fairing with Ventura, so far? It's def time for me to build a new machine, and I would prefer to build-to-last, again. <3

My currrent Hackintosh has lived a decent 6 years, and still kicking. Can't upgrade OS with a Core i7-6700K anymore, though. Now stuck on Monterey. Boo. I can definitely tell my hardware's getting tired, too. I really need a boost, for After Effects and streaming, these days. My new M2 Macbook Air renders better than my desktop, now. Oof.