Z77 Extreme4 keeps disappear LAN(Onboard)

Discussion in 'Network' started by forumi0721, Oct 5, 2017.

  1. forumi0721

    forumi0721

    Joined:
    Jul 8, 2013
    Messages:
    2
    Oct 5, 2017 at 11:06 AM #1
    forumi0721

    forumi0721

    Joined:
    Jul 8, 2013
    Messages:
    2
    Hi

    I use Z77.

    I use ASRock Z77 Extermr4 board and BCM57781 LAN (Onboard).



    It was ok until High Sierra.



    But after install High Sierra, The onboard LAN keeps disappearing.







    It does not seem to have LAN at all.

    On linux, lspci, on windows, device manager and on mac lspci/ioregistryexplorer....

    There's no lan.


    The only way to get it back is the CMOS reset. (Not a bios lload default menu, H/W jumper clear).



    I wonder if others have this problem.
     
  2. kjknpupil

    kjknpupil

    Joined:
    Oct 18, 2011
    Messages:
    1
    Mobo:
    Sandy-E
    CPU:
    3820@4.6g
    Graphics:
    ati hd 5750
    Oct 5, 2017 at 3:35 PM #2
    kjknpupil

    kjknpupil

    Joined:
    Oct 18, 2011
    Messages:
    1
    Mobo:
    Sandy-E
    CPU:
    3820@4.6g
    Graphics:
    ati hd 5750
    asrock x79 extreme6 model.

    i have same problem.

    but, did you active ethernet in high sierra?

    Just use fakePCID_BCM57xx_as_BCM57765.kext until el capitan
     
  3. forumi0721

    forumi0721

    Joined:
    Jul 8, 2013
    Messages:
    2
    Oct 10, 2017 at 4:51 PM #3
    forumi0721

    forumi0721

    Joined:
    Jul 8, 2013
    Messages:
    2
    this is active patch code. (for 17A405)
    Binary
    e8ea9affff668983 -> b8b4160000668983
    e87b9affff668983 -> b8e4140000668983
    e8609affff668983 -> b8b4160000668983

    Info.plist
    <string>pci14e4,16b4</string> -> <string>pci14e4,16b1</string>
     
  4. VioletDragon

    VioletDragon

    Joined:
    Jun 9, 2013
    Messages:
    10,899
    Mobo:
    GA-H77N-WIFI
    CPU:
    Core i7-3770
    Graphics:
    Intel HD 4000
    Mac:
    MacBook, Mac mini
    Mobile Phone:
    iOS
    Oct 10, 2017 at 4:59 PM #4
    VioletDragon

    VioletDragon

    Joined:
    Jun 9, 2013
    Messages:
    10,899
    Mobo:
    GA-H77N-WIFI
    CPU:
    Core i7-3770
    Graphics:
    Intel HD 4000
    Mac:
    MacBook, Mac mini
    Mobile Phone:
    iOS
    You'll have better luck buying a Supported PCI-E Ethernet Card. Something like a HP NC360T works.
     

Share This Page