Contribute
Register

Z68X-UD3-B3 - USB not working after sleep

Joined
Nov 4, 2011
Messages
14
Motherboard
Z97X-UD5H-BK
CPU
i7-4790K
Graphics
RX 580
Mac
MacBook Pro, Mac Pro
Mobile Phone
iOS
Hi guys,

I've been using my hackintosh since Lion 10.7. Every update since then went without any problems. But this time I have a problem and I hope you can help me out.

Here are my specs:
- Gigabyte Z68X-UD3-B3 F8 since there were no problems with USB devices after wake from sleep (notice it's not the H version)
- intel i7 2600K
- Gigabyte Radeon HD6850 1GB,
- 16 Gigs of RAM (Corsair)
- Few HDDs
- SSD drive (system)
- Apple Led Cinema Display (connected through DP + USB)
- home made Airport WiFi card (apple)
- Apple Bluetooth board connected directly to the mainboard's USB header.
- Apple Magic Mouse and bluetooth KB

The clean installation of ML went almost without any problems. I used UniBeast, removed ati6000 kext. When my hack booted again I run MultiBeast, KextBeast to put ati6000 kext on place and rebooted. Everything works like a charm - WiFi, bluetooth, LAN, even sound (used audio rollback option and then UseKernelCache=No). In every earlier version of OS X I used sleep without any problems. But now something strange is happening. After pushing the power button the computer goes to sleep instatntly. The problem starts after wake. It wakes (darkwake=0) in a second but all the USB devices and most of all my apple bluetooth module are dead. Reconnecting of the devices is not working also. Time on the clock is changing, but when I want to put it to sleep again nothing happens. The only possibility is to rebooth the machine again. Did someone experience similar problems with USB devices after wake?
 
Joined
Nov 4, 2011
Messages
14
Motherboard
Z97X-UD5H-BK
CPU
i7-4790K
Graphics
RX 580
Mac
MacBook Pro, Mac Pro
Mobile Phone
iOS
Does anyone know what could be the problem? I heard that people with z68x-ud3h had similar problems, but reconnecting devices in most cases helps.
 
Joined
Jul 25, 2012
Messages
67
Motherboard
Gigabyte Z68X-UD3H-B3
CPU
Intel i7 2600K @4.6 GHz
Graphics
XFX HD6870
Mac
iMac, MacBook
Classic Mac
Mobile Phone
iOS
Me to

I never had any USB problems, but since my ML upgrade I also have no keyboard after wake (stangely my mouse still works). Reconnect does work for me, so not a big problem. Will try USB fix and some Bios legacy options to fix.
 
Joined
Nov 4, 2011
Messages
14
Motherboard
Z97X-UD5H-BK
CPU
i7-4790K
Graphics
RX 580
Mac
MacBook Pro, Mac Pro
Mobile Phone
iOS
Problem solved! When I disconnected original Apple bluetooth module from the mainboard everything started working like it should. This is really strange - my chinese bt dongle for breathtaking 2.5$ is working without any problems.
 
Joined
Aug 13, 2011
Messages
358
Motherboard
Probook 4440:4540
CPU
i3-3110M
Graphics
HD4000
Mac
iMac, MacBook Pro, Mac mini
Classic Mac
Mobile Phone
I had the same issue with Z68-UD5-B3 and it was indeed Apple bluetooth dongle. I just reconnected it away from USB2 to USB3(operates as USB2 in Mac OSX) port and it is happy now.
 
Top