Contribute
Register

Z170X-UD5 TH, i7-6700K. Ventura install Help.

Joined
Jul 7, 2016
Messages
14
Motherboard
Asus Z170-Pro
CPU
i5-6600
Graphics
RX 560 + HD 530
Mobile Phone
  1. iOS
I will wait a couple of weeks before I try to upgrade to Ventura, maybe when the second stable version release
 
Joined
Jul 30, 2011
Messages
68
Motherboard
Asus Z170 Pro Gaming
CPU
i7-7700
Graphics
RX 5800
Mac
  1. MacBook Air
  2. Mac mini
Classic Mac
  1. iMac
  2. Portable
  3. Quadra
  4. Xserve
Mobile Phone
  1. Android
  2. iOS
hi
for what is worth...
I have an ASUS z170 pro gamers with i7 6700. And of course no Ventura support.
I know you can patch the bios and do some 'simple' mod on mainboard and presto you can support 9th generation CPU on the board.
There are video and forums.
Of course you will need an eprom burner to flash the Bios. I do have one (amazon, came from china)
anyway when I checked online the CPU supported by the mainboard, I noticed the i7 7700 is supported.
If I am correct, I can then change Mac model to a 2018 therefore Ventura support without doing anything.
anyway I can get my hand on a 8xxx cpu for dead cheap.

here some links for info.


 
Joined
Jul 30, 2011
Messages
68
Motherboard
Asus Z170 Pro Gaming
CPU
i7-7700
Graphics
RX 5800
Mac
  1. MacBook Air
  2. Mac mini
Classic Mac
  1. iMac
  2. Portable
  3. Quadra
  4. Xserve
Mobile Phone
  1. Android
  2. iOS
I will wait a couple of weeks before I try to upgrade to Ventura, maybe when the second stable version release
for what is worth...
I have an ASUS Z170 pro gaming with i7 6700. And of course no Ventura support since too old.
I know you can patch the bios and do some 'simple' mod on mainboard and presto you can support 9th generation CPU on the board with the Z170 chipset
There are videos and forums.
Of course you will need an eprom burner to flash the Bios. I do have one (amazon, came from china) from another job.

Anyway when I checked online the CPU supported by my motherboard, I noticed the i7 7700 is supported even so it is a 'kaby-lake' and the chipset is 'sky-lake'
I have updated to OC85 to make sure all up to date and working ok(?)
I got my hand onto a i7 7700, installed it and when I booted I got a warning about the CPU change.
checked bios settings, saved it and booted as normal.
my rig is still iMac17,x. All is working fine.
I changed it to iMac18,2 and rebooted.
all still working fine (it seems). of course I hade to re sign onto iCloud, etc....
Anyway the update for Ventura popped up. Which is a good sign
install went fine and Now my rig is running Ventura.
Now I need to get my hand onto a i7 8700 or 9700 to get more cores...
But Ventura as it is right now is good enough for me.

I have added my config.plist for info


1666971108699.png
 

Attachments

  • config.plist
    32.5 KB · Views: 34
Joined
Jul 7, 2016
Messages
14
Motherboard
Asus Z170-Pro
CPU
i5-6600
Graphics
RX 560 + HD 530
Mobile Phone
  1. iOS
I did some tests with my Skylake system changing only smbios to 18,3. I had no issues with the installation but the system stopped waking up after sleep mode (actually the screen remains black). With all the previous os I didn't have any problem with sleep/wake. Any tips?

ps: I have d-gpu,sapphire rx560 4gb
 
Joined
Jun 11, 2015
Messages
21
Motherboard
ASUS Rog Strix X99
CPU
i7-6850K
Graphics
RX580
Thanks for the reply. My main problem is that is the Opencore Legacy Patcher option to add the spoof to my efi is always grayed out so I cant patch the efi. I've tried with 18.1, 18.2 and 19.1 same results.
Use other computer than the one for which u creating USB installer then nothing will be grayed.
 
Joined
Jun 11, 2015
Messages
21
Motherboard
ASUS Rog Strix X99
CPU
i7-6850K
Graphics
RX580
I did some tests with my Skylake system changing only smbios to 18,3. I had no issues with the installation but the system stopped waking up after sleep mode (actually the screen remains black). With all the previous os I didn't have any problem with sleep/wake. Any tips?

ps: I have d-gpu,sapphire rx560 4gb
I have the same problem.
 
Joined
Apr 23, 2015
Messages
128
Motherboard
MSI Z690A PRO WIFI DDR4
CPU
i5-12400
Graphics
RX 580
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
for what is worth...
I have an ASUS Z170 pro gaming with i7 6700. And of course no Ventura support since too old.
I know you can patch the bios and do some 'simple' mod on mainboard and presto you can support 9th generation CPU on the board with the Z170 chipset
There are videos and forums.
Of course you will need an eprom burner to flash the Bios. I do have one (amazon, came from china) from another job.

Anyway when I checked online the CPU supported by my motherboard, I noticed the i7 7700 is supported even so it is a 'kaby-lake' and the chipset is 'sky-lake'
I have updated to OC85 to make sure all up to date and working ok(?)
I got my hand onto a i7 7700, installed it and when I booted I got a warning about the CPU change.
checked bios settings, saved it and booted as normal.
my rig is still iMac17,x. All is working fine.
I changed it to iMac18,2 and rebooted.
all still working fine (it seems). of course I hade to re sign onto iCloud, etc....
Anyway the update for Ventura popped up. Which is a good sign
install went fine and Now my rig is running Ventura.
Now I need to get my hand onto a i7 8700 or 9700 to get more cores...
But Ventura as it is right now is good enough for me.

I have added my config.plist for info


View attachment 557203
Hi Andrelabbe,
i saw that we have almost the same system.
Comparing the 2 I noticed that mine, while working properly, reports "VDA Decoder: failed".
Before I had smbios 18.3 then I changed to 18.2 by adapting mine to your config.plist but the result has not changed.
I enclose the details of my system: can you please tell me how I can fix it? thank you
 

Attachments

  • system_info_hackintool.txt
    2.2 KB · Views: 14
  • info_system.png
    info_system.png
    50.4 KB · Views: 23
  • EFI.zip
    24.4 MB · Views: 24
Joined
Jul 30, 2011
Messages
68
Motherboard
Asus Z170 Pro Gaming
CPU
i7-7700
Graphics
RX 5800
Mac
  1. MacBook Air
  2. Mac mini
Classic Mac
  1. iMac
  2. Portable
  3. Quadra
  4. Xserve
Mobile Phone
  1. Android
  2. iOS
Hi Andrelabbe,
i saw that we have almost the same system.
Comparing the 2 I noticed that mine, while working properly, reports "VDA Decoder: failed".
Before I had smbios 18.3 then I changed to 18.2 by adapting mine to your config.plist but the result has not changed.
I enclose the details of my system: can you please tell me how I can fix it? thank you
hi
for what is worth (I am not an expert)
I do use a z170 Pro Gaming with a i7-7700 since the motherboard support it out of the box without any modifications.
I enabled the Intel HD Graphics 630 and added in boot-args this entry: shikigva=80
after this the VDA Decoder is fully supported.
I believe having the right/best value for shikigva does the trick.
Now is it all perfect as a real Mac? not quite TV (app) is sill a bit templemental.


When I was using my old i7-6700, my 'iMac' was a iMac17,2

this is PCIe from my board. As you can see it is a z170 at heart
1668881378626.png

this is its current CPU.
1668881409776.png
 
Top