Contribute
Register

Z170X-UD5 TH High Sierra tips and tricks

Joined
Sep 22, 2016
Messages
463
Motherboard
Z170X-UD5 TH-Clover
CPU
i7-6700K
Graphics
RX Vega 56
Mac
  1. Mac mini
Mobile Phone
  1. iOS
have followed your instruction for creating my own USB-SSDT. On mixed USB2/3 ports I disabled the USB 2 port. Now USB 3 seems to work fine if the usb device is plugged in while booting, but I observed that hot plug does not work. Does hot plug a USB3 device work on your machine?
For first, please do not quote full posts! Do not use quotes if you really don’t need it!

I have no issues with USB. I can plug devices without issues. You probably have missed something or your clover configuration is invalid etc.
 
Joined
Nov 30, 2016
Messages
10
Motherboard
Gigabyte GA-Z170X-UD5 TH
CPU
i7-6700K
Graphics
RX 580
Hello, is anyone able to share the relevent SSDT's for enabling Thunderbolt 3 on their machine-building upon the fantastic info in this thread, i have learnt a lot since starting my hackintosh journey but find creating my own a bit daunting.

It might be worth the original poster adding a section on the first page perhaps?
 
Joined
Sep 22, 2016
Messages
463
Motherboard
Z170X-UD5 TH-Clover
CPU
i7-6700K
Graphics
RX Vega 56
Mac
  1. Mac mini
Mobile Phone
  1. iOS
Hello, is anyone able to share the relevent SSDT's for enabling Thunderbolt 3 on their machine-building upon the fantastic info in this thread, i have learnt a lot since starting my hackintosh journey but find creating my own a bit daunting.

It might be worth the original poster adding a section on the first page perhaps?

You have misunderstood Thunderbolt part. There is no SSDT solution.

 
Joined
Jun 3, 2010
Messages
11
Motherboard
GA-Z170X-UD5 Th
CPU
i5-6600k
Graphics
RX 580
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Worth mentioning that thunderbolt devices need to be plugged in before booting to be detected. The hot-swapping aspect doesn't seem to work on hackintosh.
 
Joined
Nov 30, 2016
Messages
10
Motherboard
Gigabyte GA-Z170X-UD5 TH
CPU
i7-6700K
Graphics
RX 580
Would it be possible for anyone to share their entire EFI folder with me? My Geekbench scores have returned above average for my setup, but my performance in FCPX has been very sluggish (even with quicksync enabled) and in the BruceX test returned results of 52 seconds whereas the average seems about 15.

My machine is mostly used for editing and I fear I have fudged my way through learning the hackintosh way to a point where I am effectively boxed into a corner, my EFI/ config.plist is likely a mess somewhere I but fear starting again almost as much as I do trial and error at this point.

If my bio has not updated correctly my current setup is the same execpt I am now using the 580 rather than 480.
 
Joined
Sep 22, 2016
Messages
463
Motherboard
Z170X-UD5 TH-Clover
CPU
i7-6700K
Graphics
RX Vega 56
Mac
  1. Mac mini
Mobile Phone
  1. iOS
Would it be possible for anyone to share their entire EFI folder with me?

I think that’s not the very best idea at all. For first it’s dangerous as you don’t have downloaded Kexts etc from original source and if some items are corrupted etc, you aren’t properly protected. Also each installation requires some personalisation, to make Hackintosh comp unique etc.

Instead it’s wise to learn and fix issues. You have to figure out what exactly causes issues. There is also a chance that performance related issues are related to hardware malfunctioning.
 
Joined
Jan 13, 2012
Messages
5
Motherboard
Z170X-UD5 TH
CPU
i5-6600K
Graphics
RX 580
Thanks for the guide!

Also USB2 ports on blue USB3 ports can be excluded.

I'm on Mojave 10.14.4 and require both HS01-04 and SS01-04 for the external USB3 ports to function correctly. Otherwise only USB3 devices are detected and hot-plug does not work. If I only enable HS-ports and exclude SS-ports, USB3 devices work as USB2 devices (as expected).

I generated the SSDT files with https://github.com/cnrd/OSX-USB-SSDT. It is working without USB-Inject-all kext and without a port-limit patch. I enabled all external ports, but no internal ports except HS10.

Do you want to enable: HS01? [Y/n]
You enabled: HS01, are you using it as an internally connected port (For example WiFi/Bluetooth module)? [y/N]
Is: HS01 a USB 3.0 connector? [Y/n] y
Do you want to enable: HS02? [Y/n]
You enabled: HS02, are you using it as an internally connected port (For example WiFi/Bluetooth module)? [y/N]
Is: HS02 a USB 3.0 connector? [Y/n] y
Do you want to enable: HS03? [Y/n]
You enabled: HS03, are you using it as an internally connected port (For example WiFi/Bluetooth module)? [y/N]
Is: HS03 a USB 3.0 connector? [Y/n] y
Do you want to enable: HS04? [Y/n]
You enabled: HS04, are you using it as an internally connected port (For example WiFi/Bluetooth module)? [y/N]
Is: HS04 a USB 3.0 connector? [Y/n] y
Do you want to enable: HS05? [Y/n] n
Do you want to enable: HS06? [Y/n] n
Do you want to enable: HS07? [Y/n] n
Do you want to enable: HS08? [Y/n] n
Do you want to enable: HS09? [Y/n] n
Do you want to enable: HS10? [Y/n]
You enabled: HS10, are you using it as an internally connected port (For example WiFi/Bluetooth module)? [y/N]
Is: HS10 a USB 3.0 connector? [Y/n] n
Do you want to enable: HS11? [Y/n]
You enabled: HS11, are you using it as an internally connected port (For example WiFi/Bluetooth module)? [y/N]
Is: HS11 a USB 3.0 connector? [Y/n] n
Do you want to enable: HS12? [Y/n]
You enabled: HS12, are you using it as an internally connected port (For example WiFi/Bluetooth module)? [y/N]
Is: HS12 a USB 3.0 connector? [Y/n] n
Do you want to enable: HS13? [Y/n]
You enabled: HS13, are you using it as an internally connected port (For example WiFi/Bluetooth module)? [y/N]
Is: HS13 a USB 3.0 connector? [Y/n] n
Do you want to enable: HS14? [Y/n]
You enabled: HS14, are you using it as an internally connected port (For example WiFi/Bluetooth module)? [y/N]
Is: HS14 a USB 3.0 connector? [Y/n] n
Do you want to enable: SS01? [Y/n]
You enabled: SS01, are you using it as an internally connected port (For example WiFi/Bluetooth module)? [y/N]
Do you want to enable: SS02? [Y/n]
You enabled: SS02, are you using it as an internally connected port (For example WiFi/Bluetooth module)? [y/N]
Do you want to enable: SS03? [Y/n]
You enabled: SS03, are you using it as an internally connected port (For example WiFi/Bluetooth module)? [y/N]
Do you want to enable: SS04? [Y/n]
You enabled: SS04, are you using it as an internally connected port (For example WiFi/Bluetooth module)? [y/N]
Do you want to enable: SS05? [Y/n] n
Do you want to enable: SS06? [Y/n] n
Do you want to enable: SS07? [Y/n] n
Do you want to enable: SS08? [Y/n] n
Do you want to enable: SS09? [Y/n]
You enabled: SS09, are you using it as an internally connected port (For example WiFi/Bluetooth module)? [y/N]
Do you want to enable: SS10? [Y/n]
You enabled: SS10, are you using it as an internally connected port (For example WiFi/Bluetooth module)? [y/N]



The file USB-SSDT.aml was added to your Desktop.

Remove any other USB patches (Like USBInjectAll).

Place the file in /EFI/Clover/ACPI/patched

Add the following to ACPI in your config.plist
<key>DropTables</key>
<array>
<dict>
<key>Signature</key>
<string>SSDT</string>
<key>TableId</key>
<string>xh_rvp10</string>
</dict>
</array>


I attached the SSDT.
- The aml file should be placed in /EFI/Clover/ACPI/patched.
- ACPI table "xh_rvp10" should be dropped in config.plist (see spoiler above).
- USB inject all kext should be removed. Port unlimit patches can be removed.

Troubleshooting:
- The terminal command "bdmesg" shows if the SSDT was injected
- At boot: Clover->settings->ACPI patching can disable "xh_rvp10" table drop in case no USB device is working anymore.
- Internal USB ports except HS10 are disabled to meet the 15 USB port limit.

399527
 

Attachments

  • USB-SSDT_all-external_no-internal_except-HS10.aml
    10.9 KB · Views: 239
Joined
Oct 16, 2010
Messages
47
Motherboard
Gigabyte Z390 Designare
CPU
i9 9900K
Graphics
AMD VII
Mac
  1. MacBook Pro
Classic Mac
  1. iMac
  2. PowerBook
Mobile Phone
  1. iOS
Thanks for the guide!



I'm on Mojave 10.14.4 and require both HS01-04 and SS01-04 for the external USB3 ports to function correctly. Otherwise only USB3 devices are detected and hot-plug does not work. If I only enable HS-ports and exclude SS-ports, USB3 devices work as USB2 devices (as expected).

I generated the SSDT files with https://github.com/cnrd/OSX-USB-SSDT. It is working without USB-Inject-all kext and without a port-limit patch. I enabled all external ports, but no internal ports except HS10.

Do you want to enable: HS01? [Y/n]
You enabled: HS01, are you using it as an internally connected port (For example WiFi/Bluetooth module)? [y/N]
Is: HS01 a USB 3.0 connector? [Y/n] y
Do you want to enable: HS02? [Y/n]
You enabled: HS02, are you using it as an internally connected port (For example WiFi/Bluetooth module)? [y/N]
Is: HS02 a USB 3.0 connector? [Y/n] y
Do you want to enable: HS03? [Y/n]
You enabled: HS03, are you using it as an internally connected port (For example WiFi/Bluetooth module)? [y/N]
Is: HS03 a USB 3.0 connector? [Y/n] y
Do you want to enable: HS04? [Y/n]
You enabled: HS04, are you using it as an internally connected port (For example WiFi/Bluetooth module)? [y/N]
Is: HS04 a USB 3.0 connector? [Y/n] y
Do you want to enable: HS05? [Y/n] n
Do you want to enable: HS06? [Y/n] n
Do you want to enable: HS07? [Y/n] n
Do you want to enable: HS08? [Y/n] n
Do you want to enable: HS09? [Y/n] n
Do you want to enable: HS10? [Y/n]
You enabled: HS10, are you using it as an internally connected port (For example WiFi/Bluetooth module)? [y/N]
Is: HS10 a USB 3.0 connector? [Y/n] n
Do you want to enable: HS11? [Y/n]
You enabled: HS11, are you using it as an internally connected port (For example WiFi/Bluetooth module)? [y/N]
Is: HS11 a USB 3.0 connector? [Y/n] n
Do you want to enable: HS12? [Y/n]
You enabled: HS12, are you using it as an internally connected port (For example WiFi/Bluetooth module)? [y/N]
Is: HS12 a USB 3.0 connector? [Y/n] n
Do you want to enable: HS13? [Y/n]
You enabled: HS13, are you using it as an internally connected port (For example WiFi/Bluetooth module)? [y/N]
Is: HS13 a USB 3.0 connector? [Y/n] n
Do you want to enable: HS14? [Y/n]
You enabled: HS14, are you using it as an internally connected port (For example WiFi/Bluetooth module)? [y/N]
Is: HS14 a USB 3.0 connector? [Y/n] n
Do you want to enable: SS01? [Y/n]
You enabled: SS01, are you using it as an internally connected port (For example WiFi/Bluetooth module)? [y/N]
Do you want to enable: SS02? [Y/n]
You enabled: SS02, are you using it as an internally connected port (For example WiFi/Bluetooth module)? [y/N]
Do you want to enable: SS03? [Y/n]
You enabled: SS03, are you using it as an internally connected port (For example WiFi/Bluetooth module)? [y/N]
Do you want to enable: SS04? [Y/n]
You enabled: SS04, are you using it as an internally connected port (For example WiFi/Bluetooth module)? [y/N]
Do you want to enable: SS05? [Y/n] n
Do you want to enable: SS06? [Y/n] n
Do you want to enable: SS07? [Y/n] n
Do you want to enable: SS08? [Y/n] n
Do you want to enable: SS09? [Y/n]
You enabled: SS09, are you using it as an internally connected port (For example WiFi/Bluetooth module)? [y/N]
Do you want to enable: SS10? [Y/n]
You enabled: SS10, are you using it as an internally connected port (For example WiFi/Bluetooth module)? [y/N]



The file USB-SSDT.aml was added to your Desktop.

Remove any other USB patches (Like USBInjectAll).

Place the file in /EFI/Clover/ACPI/patched

Add the following to ACPI in your config.plist
<key>DropTables</key>
<array>
<dict>
<key>Signature</key>
<string>SSDT</string>
<key>TableId</key>
<string>xh_rvp10</string>
</dict>
</array>


I attached the SSDT.
- The aml file should be placed in /EFI/Clover/ACPI/patched.
- ACPI table "xh_rvp10" should be dropped in config.plist (see spoiler above).
- USB inject all kext should be removed. Port unlimit patches can be removed.

Troubleshooting:
- The terminal command "bdmesg" shows if the SSDT was injected
- At boot: Clover->settings->ACPI patching can disable "xh_rvp10" table drop in case no USB device is working anymore.
- Internal USB ports except HS10 are disabled to meet the 15 USB port limit.

View attachment 399527

Nice! High Sierra is running smooth, but I want to upgrade to Mojave for testing eGPU support with a Radeon VII.

two questions:

What system definitions are you using?
Is Thunderbolt 3 working?
 
Joined
Jan 3, 2017
Messages
11
Motherboard
ASRock Z390 Phantom Gaming-ITX/AC
CPU
i7-8700K
Graphics
Vega 56 Air Boost
Hi
First Thank's very much for this guide ...
I'm running Sierra 10.12.6 on this motherboard with bios f5. I want to install High Sierra on an M2 NVMe disk and I'm not an expert.
If I understood properly I have to upgrade the bios first to f22g and patch the CFG Lock ?
On this guide I've seen a zip file of the f22g bios already patched ? can I just use it to upgrade the bios ??
Thank's
 
Joined
Aug 26, 2017
Messages
177
Motherboard
Gigabyte Z170X-UD5 TH
CPU
i7-6700K
Graphics
RX 580
Mac
  1. iMac
Classic Mac
  1. iMac
  2. LC
  3. Power Mac
  4. Quadra
hello

i will install for mojave. i have change my video card nvidia to radeon Rx580

wieerik you need to change your video card !!
 
Last edited:
Top