Contribute
Register

Yosemite USB 3.0 problem

Joined
Nov 23, 2012
Messages
30
Motherboard
Asus Sabertooth X79
CPU
Intel i7 3930K 6 Core Sandy Bridge
Graphics
Gigabyte GeForce GTX 670
Mac
Classic Mac
Mobile Phone
I've been looking to update my GPU for awhile now from the 970 to the Titan X but I've read that you have to have Yosemite or El Capitan fully running to support the Titan X. I have Mavericks running completely right now and trying to get everything working on a test drive with Yosemite and I have everything working completely besides USB 3.0.

The problem is my USB 3.0 will only work if I leave the drive plugged in for a restart, or if I plug a USB 2.0 drive into a port next to it or before the 3.0 drive. Not a huge deal as long as this set up isn't going to fry my USB 3.0 drives for not working completely right.

I've installed the GenericUSBxhci.kext from the Multibeast for El Capitan but I believe it behaves the same with the Kext from the Multibeast for Yosemite. I've tried injecting the patched applekext but it doesn't work either.

My current motherboard is the Sabertooth X79.

Looks like it uses Asmedia as the USB 3.0 chipset but I have no idea to see what version it is or how to update it.

Also is there a simple solution to just buy a PCI-E USB 3.0 card that will work like normal? or would I have problems with that also?

Thanks
 
Joined
Apr 27, 2010
Messages
9
Motherboard
ElCapitan
CPU
Intel Core i7 3.39 GHz
Graphics
NVidia Quadro K5000
Mac
  1. Mac Pro
Classic Mac
Mobile Phone
  1. iOS
This card will work with ElCapitan and my motherboard GA-Z68XP-UD3-F10 ?
 
Top